Notices


Reply
Thread Tools
Posts: 30 | Thanked: 118 times | Joined on Dec 2014
#31
Originally Posted by mautz View Post
Could you please post /dev/shm/bt-sleep-monitor.log ?

And the check if the service bt-sleep-monitor.service and bt-sleep-monitor.timer are running?
I don't have the /dev/shm/bt-sleep-monitor.log which may be related to the service/timer being inactive.

Code:
-bash-3.2$ systemctl status bt-sleep-monitor.service
bt-sleep-monitor.service - Start Minimecs bt-sleep-monitor script at startup
   Loaded: loaded (/lib/systemd/system/bt-sleep-monitor.service; static)
   Active: inactive (dead)

-bash-3.2$ systemctl status bt-sleep-monitor.timer  
bt-sleep-monitor.timer - Delay start of minimecs bt-sleep-monitor script to avoid getting wrong bluetooth value on startup
   Loaded: loaded (/lib/systemd/system/bt-sleep-monitor.timer; disabled)
   Active: inactive (dead)
 

The Following 2 Users Say Thank You to tealc For This Useful Post:
Posts: 424 | Thanked: 1,157 times | Joined on Feb 2014 @ Germany
#32
@tealc

could you please post the output of
Code:
ls -lha /proc/bluetooth/sleep/lpm
and check if the file bt-sleep-monitor.sh is present in /usr/bin?
 

The Following 2 Users Say Thank You to mautz For This Useful Post:
Posts: 30 | Thanked: 118 times | Joined on Dec 2014
#33
Originally Posted by mautz View Post
@tealc

could you please post the output of
Code:
ls -lha /proc/bluetooth/sleep/lpm
and check if the file bt-sleep-monitor.sh is present in /usr/bin?
Code:
-bash-3.2$ ls -l /usr/bin/bt-sleep-monitor.sh 
-rwxr-xr-x 1 root root 5560 May 10 09:42 /usr/bin/bt-sleep-monitor.sh
Code:
-bash-3.2$ ls -lha /proc/bluetooth/sleep/lpm
-rw-rw---- 1 bluetooth net_bt_stack 0 May 14 21:27 /proc/bluetooth/sleep/lpm
 

The Following 3 Users Say Thank You to tealc For This Useful Post:
Posts: 424 | Thanked: 1,157 times | Joined on Feb 2014 @ Germany
#34
Seems like the script doesn't start at boot. Could you try starting it manually with devel-su systemctl start bt-sleep-monitor.timer or devel-su /usr/bin/bt-sleep-monitor.sh?

UPDATE: Seems like i forgot to enable the script service.
Code:
devel-su systemctl enable bt-sleep-monitor.timer
devel-su systemctl start bt-sleep-monitor.timer
should solve the problem.

I will correct this in the next build.

UPDATE: Thanks BluesLee for pointing out the missing systemctl command.

Last edited by mautz; 2017-05-16 at 14:42.
 

The Following 5 Users Say Thank You to mautz For This Useful Post:
Posts: 30 | Thanked: 118 times | Joined on Dec 2014
#35
That worked better! Now the /dev/shm/bt-sleep-monitor.log file indicates that bluetooth is disabled. Thanks!
 

The Following 2 Users Say Thank You to tealc For This Useful Post:
BluesLee's Avatar
Posts: 390 | Thanked: 1,026 times | Joined on Jan 2010 @ Europe
#36
Originally Posted by mautz View Post
Seems like the script doesn't start at boot. Could you try starting it manually with devel-su systemctl start bt-sleep-monitor.timer or devel-su /usr/bin/bt-sleep-monitor.sh?

UPDATE: Seems like i forgot to enable the script service.
Code:
devel-su enable bt-sleep-monitor.timer
devel-su start bt-sleep-monitor.timer
should solve the problem.

I will correct this in the next build.
Typo. For those who are not familiar with those commands, it should be
Code:
devel-su systemctl enable bt-sleep-monitor.timer 
devel-su systemctl start bt-sleep-monitor.timer
 

The Following 4 Users Say Thank You to BluesLee For This Useful Post:
Posts: 92 | Thanked: 161 times | Joined on Sep 2010 @ Switzerland
#37
Just to be sure, this does not help with the bad Bluetooth hands free problem right?
 

The Following 2 Users Say Thank You to maximilian1st For This Useful Post:
Posts: 424 | Thanked: 1,157 times | Joined on Feb 2014 @ Germany
#38
Originally Posted by maximilian1st View Post
Just to be sure, this does not help with the bad Bluetooth hands free problem right?
Nope, that's another problem.
 

The Following 4 Users Say Thank You to mautz For This Useful Post:
BluesLee's Avatar
Posts: 390 | Thanked: 1,026 times | Joined on Jan 2010 @ Europe
#39
Very good battery life behaviour so far with cm13 + sfos 2.1 + using workaround regarding bluetooth sleep issue, great.

Last edited by BluesLee; 2017-05-16 at 14:10.
 

The Following 5 Users Say Thank You to BluesLee For This Useful Post:
Posts: 424 | Thanked: 1,157 times | Joined on Feb 2014 @ Germany
#40
Uploaded build 0.3 which fixes the bt sleep issue.
 

The Following 5 Users Say Thank You to mautz For This Useful Post:
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 01:51.