Notices


Reply
Thread Tools
BluesLee's Avatar
Posts: 388 | Thanked: 1,023 times | Joined on Jan 2010 @ Europe
#121
Originally Posted by matemana View Post
I searched the internet for that missing library file for OPX. It seems some people needed them too. I downloaded CM11 for OPX made img file from system.dat and pulled out that missing library and included in this latest package but it did not help.

Video playback works for me without a problem. One thing i noticed camera does not work for me on nexus 5 with android apps.
I am talking about the Nexus 5 rpm package you provided for CM12 base, not about OPX.
 
Posts: 145 | Thanked: 236 times | Joined on Feb 2017 @ Tbilisi, Georgia (caucasus)
#122
Originally Posted by BluesLee View Post
I am talking about the Nexus 5 rpm package you provided for CM12 base, not about OPX.
Oh sorry, there are no other changes, so far i am trying to get google play store to work on Nexus 5.

I have got it working on Nexus 4 though and created package for it too. On Nexus 4 i have 2 packages. Aliendalvik and gapps. If you install them that's it everything works.

Oh and you remember your output, when it said that could not creat links to /system/vendor/lib/egl/egl.cfg and so on some files.
Guess what i have got that same errors and aliendalvik works for me. I'll check it on my Nexus 4 too.
 
Posts: 145 | Thanked: 236 times | Joined on Feb 2017 @ Tbilisi, Georgia (caucasus)
#123
Originally Posted by lfc22 View Post
https://i.imgsafe.org/e153490f3d.png
please answer pm
 
Posts: 117 | Thanked: 55 times | Joined on Jul 2013
#124
Originally Posted by matemana View Post
please answer pm
just did (10-chars)
 
Posts: 145 | Thanked: 236 times | Joined on Feb 2017 @ Tbilisi, Georgia (caucasus)
#125
Originally Posted by nieldk View Post
A journal reveals some errors

Feb 08 12:57:29 Sailfish systemd[1]: Starting Myriad Alien Dalvik...
Feb 08 12:57:29 Sailfish start_alien.sh[21522]: ln: creating symbolic link `/system/vendor/lib/egl/egl.cfg': No such file or directory
Feb 08 12:57:30 Sailfish start_alien.sh[21522]: ln: creating symbolic link `/system/vendor/lib/egl/eglsubAndroid.so': No such file or directory
Feb 08 12:57:30 Sailfish start_alien.sh[21522]: ln: creating symbolic link `/system/vendor/lib/egl/libEGL_adreno.so': No such file or directory
Feb 08 12:57:30 Sailfish start_alien.sh[21522]: ln: creating symbolic link `/system/vendor/lib/egl/libGLESv1_CM_adreno.so': No such file or directory
Feb 08 12:57:30 Sailfish start_alien.sh[21522]: ln: creating symbolic link `/system/vendor/lib/egl/libGLESv2_adreno.so': No such file or directory
Feb 08 12:57:30 Sailfish start_alien.sh[21522]: ln: creating symbolic link `/system/vendor/lib/egl/libq3dtools_adreno.so': No such file or directory
Feb 08 12:57:30 Sailfish start_alien.sh[21522]: ln: creating symbolic link `/system/vendor/lib/libadreno_utils.so': No such file or directory
Feb 08 12:57:30 Sailfish start_alien.sh[21522]: ln: creating symbolic link `/system/vendor/lib/libgsl.so': No such file or directory

Feb 08 12:57:30 Sailfish start_alien.sh[21522]: ln: creating symbolic link `/data/misc/camera/camera': File exists
Feb 08 12:57:30 Sailfish start_alien.sh[21522]: /data exists already
Found this problem with my Nexus 5 too. It does not affect aliendalvik work because it works for mee. Although camera does not work in my Nexus 5.

To solve this problem you just have to create this path. That's it
"/opt/alien/system/vendor/lib/egl/"

Last edited by matemana; 2017-02-10 at 22:23.
 
Posts: 117 | Thanked: 55 times | Joined on Jul 2013
#126
debug question: other than journal and service status, does anyone have any other clues what to look for to figure out why aliendalvik won't start (on opx)?
 
Posts: 735 | Thanked: 806 times | Joined on Jan 2012 @ Berlin
#127
with logcat

chroot /opt/alien /system/bin/logcat
__________________
www.sailfishmods.de
 
BluesLee's Avatar
Posts: 388 | Thanked: 1,023 times | Joined on Jan 2010 @ Europe
#128
I also see the error messages of nieldk

Code:
[QUOTE=nieldk;1523028]A journal reveals some errors

Feb 08 12:57:29 Sailfish systemd[1]: Starting Myriad Alien Dalvik...
Feb 08 12:57:29 Sailfish start_alien.sh[21522]: ln: creating symbolic link `/system/vendor/lib/egl/egl.cfg': No such file or directory
Feb 08 12:57:30 Sailfish start_alien.sh[21522]: ln: creating symbolic link `/system/vendor/lib/egl/eglsubAndroid.so': No such file or directory
Feb 08 12:57:30 Sailfish start_alien.sh[21522]: ln: creating symbolic link `/system/vendor/lib/egl/libEGL_adreno.so': No such file or directory
Feb 08 12:57:30 Sailfish start_alien.sh[21522]: ln: creating symbolic link `/system/vendor/lib/egl/libGLESv1_CM_adreno.so': No such file or directory
Feb 08 12:57:30 Sailfish start_alien.sh[21522]: ln: creating symbolic link `/system/vendor/lib/egl/libGLESv2_adreno.so': No such file or directory
Feb 08 12:57:30 Sailfish start_alien.sh[21522]: ln: creating symbolic link `/system/vendor/lib/egl/libq3dtools_adreno.so': No such file or directory
Feb 08 12:57:30 Sailfish start_alien.sh[21522]: ln: creating symbolic link `/system/vendor/lib/libadreno_utils.so': No such file or directory
Feb 08 12:57:30 Sailfish start_alien.sh[21522]: ln: creating symbolic link `/system/vendor/lib/libgsl.so': No such file or directory
but it's solved as mentioned above by matemana

Though aliendalvik is somehow working a lot of apps do not have sound (gl tron, tuxrider) or video playback (webtube). For the latter i don't have a positive example yet. Other apps crash when interacting (bushido). Try out those of f-droid.

Suprising that sensors work too.


@cvp: logcat doesn't work
Code:
sh-3.2# /system/bin/logcat
Unable to open log device '/dev/alog/main':
No such file or directory

Last edited by BluesLee; 2017-02-11 at 06:42.
 
Posts: 419 | Thanked: 1,133 times | Joined on Feb 2014 @ Germany
#129
Originally Posted by taixzo View Post
I'm hopeful we can get OPX working as well - unlike the Nexus devices there is no way to multiboot Android and SFOS.
You could try to boot an android kernel using fasboot, it should get you into CM since all android parts are not altered.
 

The Following User Says Thank You to mautz For This Useful Post:
Posts: 735 | Thanked: 806 times | Joined on Jan 2012 @ Berlin
#130
in opx and jolla device works the commandline.
__________________
www.sailfishmods.de
 
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 16:44.