Notices


Reply
Thread Tools
Posts: 33 | Thanked: 64 times | Joined on Sep 2013 @ Norway
#1
Hello.
I use Jolla C and have used ver. 2.1.1.12 for over 1 month. After installing some lib ... devel packages, the sailfish browser has stopped working. I have compared to my Jolla 1 and uninstalled unnecessary ..- devel packages. I have removed and reinstalled the sailfish browser without this having solved the problem. In the app settings for the sailfish browser, I have deleted all settings. Web Pirate and Webcat work without any problems. Start from terminal provides this error message.

[Nemo @ sailfish ~] $ sailfish browser
[D] unknown: 0 - Using Wayland-EGL
GreHome from GRE_HOME: / usr / bin
Libxul.so is not found, in /usr/bin/libxul.so
Created LOG for EmbedLite
[D] onCompleted: 103 - ViewPlaceholder requires a SilicaFlickable parent
Loaded xulDir: /usr/lib/xulrunner-qt5-38.8.0/libxul.so, appDir: / usr / bin
EmbedLiteExt virtual nsresult EmbedChromeManager :: Observe (nsISupports *, const char *, const char16_t *): 82: obj: (nil), top: app startup
EmbedLiteExt virtual nsresult EmbedTouchManager :: Observe (nsISupports *, const char *, const char16_t *): 86: obj: (nil), top: app startup
EmbedLiteGlobalHelper app startup
EmbedLiteSyncService app startup
PREFS SERVICE INITAILIZED
EmbedPrefService app startup
EmbedliteDownloadManager initialized
UserAgentOverrideHelper app startup
1498404380424 addons.manager DEBUG Application has been upgraded
1498404380582 addons.manager DEBUG Loaded provider scope for resource: //gre/modules/addons/XPIProvider.jsm: ["XPIProvider"]
1498404380597 addons.manager DEBUG Loaded provider scope for resource: //gre/modules/LightweightThemeManager.jsm: ["LightweightThemeManager"]
1498404380623 addons.manager DEBUG Loaded provider scope for resource: //gre/modules/addons/GMPProvider.jsm
1498404380640 addons.manager DEBUG Loaded provider scope for resource: //gre/modules/addons/PluginProvider.jsm
1498404380646 addons.manager DEBUG Starting Provider: XPIProvider
1498404380648 addons.xpi DEBUG startup
1498404380657 addons.xpi DEBUG checkForChanges
1498404380672 addons.xpi DEBUG Loaded add-on state from prefs: {}
1498404380680 addons.xpi DEBUG getInstallState changed: false, state: {}
1498404380689 addons.xpi DEBUG Empty XPI database, setting schedule version preference to 16
1498404380693 addons.xpi DEBUG No changes found
1498404380696 addons.manager DEBUG Registration shutdown blocker for XPIProvider
1498404380700 addons.manager DEBUG Provider finished startup: XPIProvider
1498404380701 addons.manager DEBUG Starting Provider: LightweightThemeManager
1498404380703 addons.manager DEBUG Registration shutdown blocker for LightweightThemeManager
1498404380707 addons.manager DEBUG Provider finished startup: LightweightThemeManager
1498404380709 addons.manager DEBUG Starting provider: GMPProvider
1498404380723 addons.manager DEBUG Registration shutdown blocker for GMPProvider
1498404380725 addons.manager DEBUG Provider finished startup: GMPProvider
1498404380727 addons.manager DEBUG Starting Provider: PluginProvider
1498404380728 addons.manager DEBUG Registration shutdown blocker for PluginProvider
1498404380731 addons.manager DEBUG Provider finished startup: PluginProvider
1498404380732 addons.manager DEBUG Completed startup sequence
Created LOG for EmbedPrefs
[D] QMozWindowPrivate :: setSize: 71 - Trying to set empty size: QSize (-1, -1)
JavaScript error: jar: file: ///usr/lib/xulrunner-qt5-38.8.0/omni.ja !/components/nsPrompter.js, line 370: NS_ERROR_ABORT: Component returned failure code: 0x80004004 (NS_ERROR_ABORT) [nsIWindowWatcher. open window]
Aborted

[Nemo @ sailfish ~] $

If nobody can help me, I think only one option is to reset the device. I hope to avoid this.
 

The Following 2 Users Say Thank You to PamNor For This Useful Post:
Markkyboy's Avatar
Posts: 239 | Thanked: 278 times | Joined on Oct 2012 @ Planet Thanet
#2
"Libxul.so is not found, in /usr/bin/libxul.so..........."

"JavaScript error: jar: file: ///usr/lib/xulrunner-qt5-38.8.0/omni.ja !/components/nsPrompter.js, line 370"

Possible corruption of xulrunner..?

In terminal, do 'pkcon search name xulrunner' - xulrunner-qt5-38.8 should be installed on your device, if not, install it.....alternatively, if it is installed, reinstall it, restart device and try opening sailfish browser again but with launcher icon not with terminal.
__________________
moderator@openrepos
___________________

T.J.C.

Omelettes - You can't make one without breaking an egg.
 

The Following 3 Users Say Thank You to Markkyboy For This Useful Post:
Posts: 33 | Thanked: 64 times | Joined on Sep 2013 @ Norway
#3
Tried as root.
zypper in -f xulrunner-qt5
reboot
Start sailfish-browser from launcher.

Result: Browser crash, same error.
 

The Following User Says Thank You to PamNor For This Useful Post:
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 09:31.