Notices


Reply
Thread Tools
Posts: 235 | Thanked: 527 times | Joined on Aug 2011 @ suncity
#1
Hi All!

I happened to successfully install neovim 0.1.7-4 on my n900. You can find the details here.

jm

 

The Following 5 Users Say Thank You to justmemory For This Useful Post:
Posts: 748 | Thanked: 2,300 times | Joined on Jan 2011 @ Germany
#2
From your github:
These are just repacked Debian Stretch installers (since building Neovim for the n900 always failed for me); installing them are working fine.

WARNING! Neovim depends on libc6 >= 2.7 but Maemo5 has only 2.5.1.
Actually, the armel stretch package formally only depends on libc6 >= 2.4 [1], so at least that shouldn't be a problem when just installing the Stretch package on Maemo with libc6 2.5.1.
Of course there might be actual binary dependencies in neovim that require a higher libc6 version, but if that's the case, you should file a bug report against the Debian package, asking for corrected dependencies.

btw, I don't know neovim, but the N900 is my only device where I prefer nano over vim because I find it hard to hit vi shortcuts without breaking my fingers.
Does this work any better with neovim?


[1] https://packages.debian.org/stretch/neovim
 

The Following 3 Users Say Thank You to sulu For This Useful Post:
Posts: 235 | Thanked: 527 times | Joined on Aug 2011 @ suncity
#3
Originally Posted by sulu View Post
From your github:Actually, the armel stretch package formally only depends on libc6 >= 2.4 [1], so at least that shouldn't be a problem when just installing the Stretch package on Maemo with libc6 2.5.1.
Of course there might be actual binary dependencies in neovim that require a higher libc6 version, but if that's the case, you should file a bug report against the Debian package, asking for corrected dependencies.

btw, I don't know neovim, but the N900 is my only device where I prefer nano over vim because I find it hard to hit vi shortcuts without breaking my fingers.
Does this work any better with neovim?


[1] https://packages.debian.org/stretch/neovim
Thanks for the correction, you are right of course.
The "needed" version of libtermkey1 and libuv1 depends on libc6 >= 2.7 and neovim depends on libuv1. I shall correct that on github as well.

Hmm... About shortcuts... I do not know nano the way I know (neo)vim - I find the latter(s) more suitable for my usecase; I do not find hard the shortcuts. I used to vim/neovim so I do not know the answer... And you can map shortcuts as well...

Last edited by justmemory; 2018-02-14 at 08:28. Reason: Correcting libc6 dependency information
 

The Following 3 Users Say Thank You to justmemory For This Useful Post:
Posts: 748 | Thanked: 2,300 times | Joined on Jan 2011 @ Germany
#4
Originally Posted by justmemory View Post
The "needed" version of libtermkey1 and libuv1 depends on libc6 >= 2.7 and neovim depends on libuv1.
You could try to just drop the libc6 version check from the libuv1 package or rebuild libuv1 after lowering the required libc6 dependency in its source package.
Either result might or might not work properly, but I think it's worth a try.

Originally Posted by justmemory View Post
And you can map shortcuts as well...
Thanks! I'll try that.
 

The Following 2 Users Say Thank You to sulu For This Useful Post:
Posts: 235 | Thanked: 527 times | Joined on Aug 2011 @ suncity
#5
Originally Posted by sulu View Post
You could try to just drop the libc6 version check from the libuv1 package or rebuild libuv1 after lowering the required libc6 dependency in its source package.
Either result might or might not work properly, but I think it's worth a try.
I tried to lower libc6 dependency level at repacking libuv1 and libtermkey1; installation worked but of course nvim did not start because it was only the check that I tricked so yeah rebuilding libuv1 and libvterm1 would be a solution but as I'm not an expert (especially in this field) I do not know how to rebuild package against a given libc6 or anything else. But maybe I will try to find out
One other thing is that I'm in the same boat as you - n900 is my only device (home laptop is not an option as my wife and kids would "kill" me...) so all my development is done on chrooted maemo-sdk. Building things not always easy as sometimes there are packages that building is depending on that I cannot get work on the n900. But I shall try and we will see. Thanks for the suggestion.
 

The Following User Says Thank You to justmemory For This Useful Post:
Posts: 748 | Thanked: 2,300 times | Joined on Jan 2011 @ Germany
#6
I still have some Debian chroots on my Cubieboard2 for Easy Debian backports, where I could try to rebuild those packages for older libc6 versions.
So far I know that you'd need libuv1 and libtermkey1. Are there any other packages I should build?

Edit:
Did you use armel or armhf packages?
 

The Following 2 Users Say Thank You to sulu For This Useful Post:
Posts: 235 | Thanked: 527 times | Joined on Aug 2011 @ suncity
#7
Originally Posted by sulu View Post
I still have some Debian chroots on my Cubieboard2 for Easy Debian backports, where I could try to rebuild those packages for older libc6 versions.
So far I know that you'd need libuv1 and libtermkey1. Are there any other packages I should build?
Technically only libuv1 and libtermkey1 depends on libc6 >= 2.7 so I think for the first try it is enough to rebuild these and then see if the other dependencies and neovim can be installed and run.

Originally Posted by sulu View Post
Edit:
Did you use armel or armhf packages?
I used armel packages.

Last edited by justmemory; 2018-02-14 at 11:08. Reason: Misspelled libtermkey1...
 

The Following 2 Users Say Thank You to justmemory For This Useful Post:
Posts: 748 | Thanked: 2,300 times | Joined on Jan 2011 @ Germany
#8
I'm sorry, I can't build those packages.
There is no explicit dependency on libc6 2.7 in the packages, it comes implicitely from the build system.
If there is a way to manipulate this implicit dependency, then I don't know it.

The alternative would be to actually build the packages on a Debian version that still had glibc <= 2.5. This would mean to use Etch, but the armel architecture didn't appear in Debian until Lenny, which already had glibc 2.7.
 

The Following User Says Thank You to sulu For This Useful Post:
Posts: 235 | Thanked: 527 times | Joined on Aug 2011 @ suncity
#9
Originally Posted by sulu View Post
I'm sorry, I can't build those packages.
There is no explicit dependency on libc6 2.7 in the packages, it comes implicitely from the build system.
If there is a way to manipulate this implicit dependency, then I don't know it.

The alternative would be to actually build the packages on a Debian version that still had glibc <= 2.5. This would mean to use Etch, but the armel architecture didn't appear in Debian until Lenny, which already had glibc 2.7.
I think you don't need to feel sorry Many thanks for you to tried this!

Then it remains this way...
 
Reply

Tags
libc6, maemo 5, neovim, porting

Thread Tools

 
Forum Jump


All times are GMT. The time now is 11:06.