Notices


Reply
Thread Tools
thp's Avatar
Posts: 1,389 | Thanked: 4,248 times | Joined on Sep 2007 @ Vienna, Austria
#381
Originally Posted by verrnum View Post
And about N9 version, is a bugfix exists ?
Also in Git (master branch), will come with the next release, which should be out soon.
 
Posts: 116 | Thanked: 4 times | Joined on Jan 2010
#382
Originally Posted by thp View Post
Also in Git (master branch), will come with the next release, which should be out soon.
Hi,

Is exists a way to retrieve the bug fix now ?
The youtube downloader does not work for several months.

Thanks a lot.
 
thp's Avatar
Posts: 1,389 | Thanked: 4,248 times | Joined on Sep 2007 @ Vienna, Austria
#383
Originally Posted by verrnum View Post
Is exists a way to retrieve the bug fix now ?
The youtube downloader does not work for several months.
Yes, replace the youtube.py file with the one from Git.
 
Posts: 116 | Thanked: 4 times | Joined on Jan 2010
#384
Hi,

I am sorry but youtube.py does not exist on meego version :

find / -name youtube.py 2>/dev/null
does not find anything...

Any ideas ?

Regards
 
Posts: 116 | Thanked: 4 times | Joined on Jan 2010
#385
Originally Posted by thp View Post
Yes, replace the youtube.py file with the one from Git.
Hi,

In fact i have wrote a little bit faster.
After addition research i found it here :

"/opt/gpodder/lib/python2.6/dist-packages/gpodder"

Then i retrieved the 2.6 youtube.py fixed file here :


And it works fine !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Thanks a lot !
 
Posts: 445 | Thanked: 362 times | Joined on Nov 2010 @ Italy
#386
i downloaded all the files and folders to my N900 from the gpodder github (branch trs-gtk3) https://github.com/gpodder/gpodder/tree/tres-gtk3

i have python-pyside installed so i tried to run (from /bin folder):
./gpodder --qml

and it started!

of course,as gpodder3 developing for maemo has been discontinued long time ago, is not 100% ready and is trowing some errors in terminal but the UI is smooth, and i really like to play the podcast inside the application, without opening external media player!

On thp blog post it says: "Unfortunately, Qt Mobility 1.2's QML Video component is broken, so there's no video playback on the N900" Any workaround?

is there anybody interested in improving qml version of gpodder for N900? even just for audio podcasts will be fine. maybe using newer python version from AapoRantalainen?
__________________
Flickr photos taken with N900 https://www.flickr.com/cameras/nokia/n900/
"Closed source software tells you what you can do. With open source, you decide what software can do for you" Richard Stallman

Last edited by gianko; 2013-10-23 at 00:28. Reason: link added
 
thp's Avatar
Posts: 1,389 | Thanked: 4,248 times | Joined on Sep 2007 @ Vienna, Austria
#387
Originally Posted by gianko View Post
On thp blog post it says: "Unfortunately, Qt Mobility 1.2's QML Video component is broken, so there's no video playback on the N900" Any workaround?

is there anybody interested in improving qml version of gpodder for N900? even just for audio podcasts will be fine. maybe using newer python version from AapoRantalainen?
If you install Qt Components, you should be able to get the "master" branch working too (there might be some fixes wrt Harmattan vs Fremantle necessary, but nothing too difficult). Even on Harmattan we then decided not to have video playback in the application, so even there we now delegate opening/playing videos to the built-in media player (while still playing audio inside the app). If you go that route, I can help you by answering questions about the codebase that you might have. Also, we could merge the Fremantle-support patches upstream for integration into 3.x releases if you or somebody writes them.

Or go all the way and use Qt 5 (a port seems to exist according to http://wiki.maemo.org/Qt5-Maemo5) and Python 3 plus PyOtherSide (once you have Qt 5 and Python 3 running, PyOtherSide should be easy). Then you can use the cuatro branch + the new QML UI (http://github.com/gpodder/gpodder-ui-qml), which looks a bit like that: http://www.youtube.com/watch?v=iqphTKirkKw
 

The Following User Says Thank You to thp For This Useful Post:
Posts: 197 | Thanked: 85 times | Joined on Dec 2010
#388
I installed gpodder on my N900 and gpodder 3.5.2 on my Ubuntu box. How is synchronization supposed to be working? Ideally, when I download a podcast via my Ubuntu box, I would like it to have transfered to my N900. Then, once I listen to it, I would like to be able to remove it so that the change would get picked up on my Ubuntu box. Is this possible via gpodder.net? I tried to set it up but this does not seem to be a case.

I have seen suggestions to use rsync, but configuration files for Ubuntu and N900 versions of gpodder are different.
 
Posts: 569 | Thanked: 461 times | Joined on Jul 2010 @ USA
#389
gPodder is great!

I have not used gpodder's sync, because I have so many other audio files that also need to be synced. Unison works well for me, although it gets slower the more files you have, & it had a problem with the N900 on a Linux Mint box. I use Unison on a Lubuntu box & it's fine.
 
Posts: 197 | Thanked: 85 times | Joined on Dec 2010
#390
Originally Posted by rotoflex View Post
gPodder is great!

I have not used gpodder's sync, because I have so many other audio files that also need to be synced. Unison works well for me, although it gets slower the more files you have, & it had a problem with the N900 on a Linux Mint box. I use Unison on a Lubuntu box & it's fine.
Well, I would like to browse the podcast on N900 using gppoder interface. I know I can copy the podcasts as files and then play them via the music player, but tha tis cumbersome because I cannot see the description of each epizode. That is why I am after syncing,
 

The Following User Says Thank You to sup For This Useful Post:
Reply

Tags
fremantle, gpodder, maemo 5, not android, podcast, testing

Thread Tools

 
Forum Jump


All times are GMT. The time now is 01:13.