Notices


Reply
Thread Tools
Posts: 1,066 | Thanked: 1,157 times | Joined on Aug 2011
#91
Originally Posted by liar View Post
you need to find the correct options for your controller for inputautocfg.ini and add them to this file.

maybe you can look it up on the device where it was working or online, look for the sdl name of your controller, then google the name + mupen64plus + inputautocfg.ini

also you seem to have invalid statements for controller 3 and 4 in your settings
strange because i have same file in my N9 and it works good. why?
 
Posts: 210 | Thanked: 835 times | Joined on Feb 2013
#92
did you find the issue? i am not sure but it could be that it detects the buttons in the wrong way, i think libsdl uses a different interface under harmattan and sailfish that might also explain why the same file behaves differently
 
Posts: 1,066 | Thanked: 1,157 times | Joined on Aug 2011
#93
Hello,

I am on sfos x on my xperia X.

I would like to connect my ps3 controller to my device with BT like that:

Code:
[nemo@Sailfish ~]$ devel-su
Password:
[root@Sailfish nemo]# killall bluetoothd
[root@Sailfish nemo]# killall bluetoothd
bluetoothd: no process found
[root@Sailfish nemo]# /usr/sbin/hciconfig hci0 up
Can't init device hci0: Operation not possible due to RF-ki
ll (132)
[root@Sailfish nemo]# connmanctl enable bluetooth
Enabled bluetooth
[root@Sailfish nemo]# /usr/sbin/hciconfig hci0 up
[root@Sailfish nemo]# /usr/sbin/hciconfig hci0 lm master
[root@Sailfish nemo]# /usr/sbin/hciconfig hci0 piscan
[root@Sailfish nemo]# ./sixaxisd
This command:

Code:
/usr/sbin/hciconfig hci0 up
Not found.
doesn't work
where is hciconfig?

Let me know.
Thanks
 
Posts: 396 | Thanked: 713 times | Joined on Aug 2014
#94
This has also been discussed here as you have probably already seen:http://talk.maemo.org/showthread.php...ame+controller
 

The Following User Says Thank You to aspergerguy For This Useful Post:
Posts: 1,066 | Thanked: 1,157 times | Joined on Aug 2011
#95
Originally Posted by aspergerguy View Post
This has also been discussed here as you have probably already seen:http://talk.maemo.org/showthread.php...ame+controller
I see that.
But like on my n9 and on my jolla devices in sfos i have connected to them.
On Xperia X i don't see hciconfig?
Where is it?
 
Posts: 1,066 | Thanked: 1,157 times | Joined on Aug 2011
#96
Code:
[nemo@Sailfish ~]$ devel-su
Password:
[root@Sailfish nemo]# killall bluetoothd
bluetoothd: no process found
[root@Sailfish nemo]# hciconfig hci0 up
[root@Sailfish nemo]# hciconfig hci0 lm master
[root@Sailfish nemo]# hciconfig hci0 piscan
[root@Sailfish nemo]# ./sixaxisd
listening for connections
���Y�z
���Y�z
���Y{
���Y{
Error on uinput dev createsixaxisd: uinput_open(): : C
annot allocate memory
[root@Sailfish nemo]# ./sixaxisd
listening for connections
how to correct the error?

Last edited by n950; 2017-10-28 at 15:40.
 
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 19:15.