Notices


Reply
Thread Tools
Posts: 810 | Thanked: 2,883 times | Joined on Apr 2012
#1
Last week, CuteSpot broke, along with all other applications using libspotify, as Spotify changed something that prevents it retrieving user playlists. It seems a fix for this is using the Spotify Web API to retrieve the playlists and then use libspotify itself to play the songs: see this bug report discussion for more details. Would it be possibly to implement this sort of fix in CuteSpot?
(Using the Android client is apparently not an option, because sound playback is apparently broken in it on Sailfish X.)
 

The Following 4 Users Say Thank You to taixzo For This Useful Post:
Posts: 15 | Thanked: 30 times | Joined on Nov 2014
#2
Originally Posted by taixzo View Post
Last week, CuteSpot broke, along with all other applications using libspotify, as Spotify changed something that prevents it retrieving user playlists. It seems a fix for this is using the Spotify Web API to retrieve the playlists and then use libspotify itself to play the songs: see this bug report discussion for more details. Would it be possibly to implement this sort of fix in CuteSpot?
(Using the Android client is apparently not an option, because sound playback is apparently broken in it on Sailfish X.)
I'm using Spotify Android client on Sailfish X and I didn't notice any problems with audio playback, is it something that occured in 2.2.0? My version is 2.1.4.14.
 

The Following User Says Thank You to kempus5 For This Useful Post:
Community Council | Posts: 4,479 | Thanked: 11,219 times | Joined on May 2012 @ Southerrn Finland
#3
When did cutespot break?

I used it last tuesday the last time as I recall, and then it did work correctly.
 
Community Council | Posts: 4,479 | Thanked: 11,219 times | Joined on May 2012 @ Southerrn Finland
#4
So I just checked it and at least on my XperiaX/2.2.0 Cutespot works just like before. So what gives?
 
Posts: 15 | Thanked: 30 times | Joined on Nov 2014
#5
Originally Posted by juiceme View Post
So I just checked it and at least on my XperiaX/2.2.0 Cutespot works just like before. So what gives?
On my Xperia X CuteSpot shows no playlists at all, while searching for songs and albums and playing them works fine.
 

The Following 2 Users Say Thank You to kempus5 For This Useful Post:
Community Council | Posts: 4,479 | Thanked: 11,219 times | Joined on May 2012 @ Southerrn Finland
#6
Originally Posted by kempus5 View Post
On my Xperia X CuteSpot shows no playlists at all, while searching for songs and albums and playing them works fine.
AH, then it makes sense... I don't us playlists at all, have no clue even how to make a playlist!
I listen to albums, you know; from the first track to the last track, like they were made to be listened.
 
Posts: 1 | Thanked: 1 time | Joined on Sep 2018
#7
Private playlists are retrievable for the present client and requires the playlist-read-private degree to have been approved by the client. Note that this degree alone won't return community oriented playlists, despite the fact that they are constantly private.


__________________________
Ross Mathis
talk.maemo.org write my essay
 

The Following User Says Thank You to RossMathis For This Useful Post:
Community Council | Posts: 4,479 | Thanked: 11,219 times | Joined on May 2012 @ Southerrn Finland
#8
CuteSpot cannot connect any longer to the spotify backend servers...
 
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 16:49.