Active Topics

 



Notices


Reply
Thread Tools
Posts: 225 | Thanked: 81 times | Joined on Apr 2008
#1
A couple of days ago my desktop and statusbar applets have suddenly started closing randomly. It has always happened when I'm not using the tablet, but I come back and my two desktop applets (OMWeather and Internet Search) and my statusbar applets (Advanced Backlight and Large Statusbar Clock) will have disappeared. This will happen a few times per day now.

I came across this old post with two users with the same problem, so hopefully I've figured out how to fix without rebooting, but I'm wondering why it might have started now (I haven't installed anything new for a few weeks) and what I might be able to try to fix it.
 

The Following User Says Thank You to dylanemcgregor For This Useful Post:
Posts: 860 | Thanked: 895 times | Joined on Sep 2010
#2
An applet or hildon-desktop itself is crashing due to a bug or corrupt settings.

Does the entire statusbar and desktop go blank (hildon-desktop crashed and kept crashing when DSME restarted it) or do the default statusbar applets show (hildon-desktop crashed and restarted with default settings)?
 

The Following User Says Thank You to auouymous For This Useful Post:
Posts: 225 | Thanked: 81 times | Joined on Apr 2008
#3
The default statusbar applets show and my screen brightness seems to be reset to the default level. The desktop applets all disappear.

A system reboot returns the applets and I've also been able to test rechecking the desktop applets works without a reboot. I have not had the chance to test re-enabling the statusbar applets from the panels menu yet.

Last edited by dylanemcgregor; 2011-06-01 at 02:17.
 
Posts: 860 | Thanked: 895 times | Joined on Sep 2010
#4
Try enabling all statusbar and desktop applets except for one, run it for a day and see if it happens. If it does happen then enable that applet and disable another, repeat until it is stable with one of the applets disabled, that will be the culprit.
 
Posts: 225 | Thanked: 81 times | Joined on Apr 2008
#5
Thanks. I'll give that a try, although I haven't had a crash now in about 24 hours with all applets enabled.
 
tso's Avatar
Posts: 4,783 | Thanked: 1,252 times | Joined on Aug 2007 @ norway
#6
Iirc, large statusbar clock have a known issue with alarms. Try disabling its alarm feature.
__________________
Be warned, posts are often line of thoughts at highway speeds...
 

The Following 2 Users Say Thank You to tso For This Useful Post:
Posts: 225 | Thanked: 81 times | Joined on Apr 2008
#7
Thanks. That seems more likely as I did set an alarm over the weekend, which I don't do regularly, and this started happening a day or two later.
 
Posts: 313 | Thanked: 97 times | Joined on Jan 2009
#8
Thanks tso, it gave me the same problem.
 
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 16:50.