Active Topics

 



Notices


Reply
Thread Tools
gerbick's Avatar
Posts: 6,465 | Thanked: 14,008 times | Joined on Jul 2007 @ undecided.
#1
Okay, here's the story.

Was on the latest iteration of Sailfish on a Jolla Tablet. Decided to reset the device, refresh the install of Sailfish and call it a day.

Well, it didn't work as such. The tablet went all the way back to Eineheminlampi 1.1.9.28 and then attempted to update to 1.1.9.30. No problem so far.

Then the update downloaded next was for Saimaa 2.0.0.10. It installed, rebooted then... nothing. It boots into the Jolla/Intel boot screen, the screen flashes and it doesn't go past that.

There's no way to SSH into the device - Developer Mode was not activated. I can enter recovery where it offers me to telnet into a Class A (10.xxx.xxx.xxx) address but not sure how to reflash a stuck Jolla tablet.

Using macOS here mostly (10.12.3 Beta at the moment) but can pull up a Linux VM is need be.

Really stuck. Help?
__________________
gerbick | iPhone 7 [ 128GB iOS 11.0 Beta ] | iPad Pro [ 256GB iOS 11.0 Beta ]
Former Maemo Council Member - 2015
 

The Following 4 Users Say Thank You to gerbick For This Useful Post:
mosen's Avatar
Community Council | Posts: 809 | Thanked: 4,903 times | Joined on Nov 2014 @ Kitchen
#2
I once reflashed my stuck tablet to android 4 in droidboot first and then back to sailfish using tools collected by coderus.

circumstances with my faulty install were different though.
Maybe you missed the thread? I see you did not comment in there back then.
 

The Following 4 Users Say Thank You to mosen For This Useful Post:
coderus's Avatar
Posts: 6,055 | Thanked: 11,183 times | Joined on Nov 2011 @ Open Mobile Platform, Innopolis, Russia
#3
Correct. You can reflash Jolla Tablet just at any time you want
__________________
Twitter | Openrepos | GitHub | PayPal.Me
 

The Following 5 Users Say Thank You to coderus For This Useful Post:
gerbick's Avatar
Posts: 6,465 | Thanked: 14,008 times | Joined on Jul 2007 @ undecided.
#4
Originally Posted by mosen View Post
I once reflashed my stuck tablet to android 4 in droidboot first and then back to sailfish using tools collected by coderus.

circumstances with my faulty install were different though.
Maybe you missed the thread? I see you did not comment in there back then.
Totally missed that thread. Thank you.
__________________
gerbick | iPhone 7 [ 128GB iOS 11.0 Beta ] | iPad Pro [ 256GB iOS 11.0 Beta ]
Former Maemo Council Member - 2015
 

The Following 3 Users Say Thank You to gerbick For This Useful Post:
gerbick's Avatar
Posts: 6,465 | Thanked: 14,008 times | Joined on Jul 2007 @ undecided.
#5
Okay... grabbed the Fastboot/ADB standalone from Google. Can enter DnX Mode, but now I'm stuck again.

Code:
./fastboot flashall
That fails. As does

Code:
./fastboot flash recovery hybris-recovery.img
I don't mind admitting that I might be missing something here given that I'm not using the same tools or directions as mosen's thread since I'm macOS.

Code:
./flash.sh
That's also giving me an error... but it's because it cannot locate the device it seems... ugh.
__________________
gerbick | iPhone 7 [ 128GB iOS 11.0 Beta ] | iPad Pro [ 256GB iOS 11.0 Beta ]
Former Maemo Council Member - 2015

Last edited by gerbick; 2017-01-15 at 22:52.
 

The Following 3 Users Say Thank You to gerbick For This Useful Post:
gerbick's Avatar
Posts: 6,465 | Thanked: 14,008 times | Joined on Jul 2007 @ undecided.
#6
Finally got this darn thing... had to download Intel's USB drivers first:

Code:
https://software.intel.com/en-us/android/articles/intel-usb-driver-for-android-devices
Then re-download the tools - opted for the newly released standalone ADB tools from Google for Windows:

Code:
https://developer.android.com/studio/releases/platform-tools.html
And ran this damn thing from my Windows 2012 Server VM. Now it works... it would lose connection on MacOS 10.12.3 (currently beta) on the initial reboot once you run flash.sh on Mac, but ran through via Window's flash.bat.

More in a bit if I hit any other snags.
__________________
gerbick | iPhone 7 [ 128GB iOS 11.0 Beta ] | iPad Pro [ 256GB iOS 11.0 Beta ]
Former Maemo Council Member - 2015

Last edited by gerbick; 2017-01-15 at 23:49.
 

The Following 7 Users Say Thank You to gerbick For This Useful Post:
Community Council | Posts: 4,060 | Thanked: 9,730 times | Joined on May 2012 @ Southerrn Finland
#7
Please share how it turns out in the end, since I will soon need to reset my Jolla Tablet to factory settings and this post made me a bit worried.

I am now at the latest release and have never had to reset it since all updates have always gone through cleanly.

However as I have donated the tablet as a prize to the Coding Competition I am going to need to wipe it before I send it away...
 

The Following 7 Users Say Thank You to juiceme For This Useful Post:
gerbick's Avatar
Posts: 6,465 | Thanked: 14,008 times | Joined on Jul 2007 @ undecided.
#8
Originally Posted by juiceme View Post
Please share how it turns out in the end, since I will soon need to reset my Jolla Tablet to factory settings and this post made me a bit worried.

I am now at the latest release and have never had to reset it since all updates have always gone through cleanly.

However as I have donated the tablet as a prize to the Coding Competition I am going to need to wipe it before I send it away...
Didn't mean to leave a cliffhanger. It's all fine now. The hiccup came after 2.0.0.10 but it's all good now. No flickering, no issues. Still installing things like Google Play but that will come tomorrow if I go that route (actually might not)
__________________
gerbick | iPhone 7 [ 128GB iOS 11.0 Beta ] | iPad Pro [ 256GB iOS 11.0 Beta ]
Former Maemo Council Member - 2015
 

The Following 6 Users Say Thank You to gerbick For This Useful Post:
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 00:28.