Notices


Reply
Thread Tools
Posts: 751 | Thanked: 2,797 times | Joined on Jan 2011 @ Czech Republic
#1
Hello,

I would like to announce a (currently) simple Google Play client for SailfishOS. It is available under GPL here and on OpenRepos. It requires Google credentials and is using the 'Google Play Downloader' python libraries.

Please tell me if you have any questions/requests and/or experience problems with the application. It is currently using a simple webview, but better implementation is planned (either using web-scraping, or Google's protobuf, once it is available for Python 3).

If you like it, please consider a small donation: EUR, USD, CZK.

EDIT: The app has been pulled from OpenRepos until reported issues are fixed.

Last edited by chemist; 2015-05-04 at 12:15.
 

The Following 24 Users Say Thank You to nodevel For This Useful Post:
Posts: 49 | Thanked: 11 times | Joined on Jan 2014 @ Moscow
#2
Set from openrepos, but the application is not open.
 
Posts: 751 | Thanked: 2,797 times | Joined on Jan 2011 @ Czech Republic
#3
Originally Posted by Victorious View Post
Set from openrepos, but the application is not open.
Thank you for feedback.
I am investigating the issue - try rebooting and see if it helps.

I also released a new version (the old one had broken downloading of apps), so check that you have the newest one (0.1-3).
 
Posts: 42 | Thanked: 106 times | Joined on Jan 2014
#4
Hi, installed 0.1-3 from open repos, but the application will not start even after reboot. Do I need to have something else installed for it to run?
 
Posts: 751 | Thanked: 2,797 times | Joined on Jan 2011 @ Czech Republic
#5
Originally Posted by nestori View Post
Hi, installed 0.1-3 from open repos, but the application will not start even after reboot. Do I need to have something else installed for it to run?
Hm, that is weird. Could you please try launching it from the terminal?
Just open the terminal windows, type 'harbour-hopscotch' and tell me what it says.
 
Posts: 440 | Thanked: 274 times | Joined on Oct 2011 @ Grenoble, France
#6
Can't download/install it from open repo, it says ;

rpm not found on medium : http://sailfish.openrepos.net/nodevel/personal/main
 
Posts: 751 | Thanked: 2,797 times | Joined on Jan 2011 @ Czech Republic
#7
Originally Posted by mousse04 View Post
Can't download/install it from open repo, it says ;

rpm not found on medium : http://sailfish.openrepos.net/nodevel/personal/main
You need to update the repository ('Check for updates' in Warehouse) first.

Originally Posted by nestori View Post
Hi, installed 0.1-3 from open repos, but the application will not start even after reboot. Do I need to have something else installed for it to run?
Try upgrading to version (0.1-5) which I just uploaded to OpenRepos. Thank you for patience.

EDIT: 0.1-5 reported as not working either. It looks like a dependency issue. I am now removing it from the OpenRepos main page and will investigate further tomorrow. Sorry for inconvenience.

It would be very helpful if someone provided the terminal output.

Last edited by nodevel; 2015-02-22 at 19:39.
 

The Following 2 Users Say Thank You to nodevel For This Useful Post:
Posts: 42 | Thanked: 106 times | Joined on Jan 2014
#8
Guess I'm late with this, but anyways here's what terminal gives me

:SailfishOS 1.1.1.27 (Vaarainjärvi) (armv7hl)
'---
[nemo@Jolla ~]$ harbour-hopscotch
[D] QWaylandEglClientBufferIntegration::QWaylandEglCli entBu
fferIntegration:62 - Using Wayland-EGL
[W] QQmlImportDatabase::registerPluginTypes:1875 - Module '
Sailfish.Silica' does not contain a module identifier direc
tive - it cannot be protected from external registrations.
[W] unknown:3 - file:///usr/share/harbour-hopscotch/qml/har
bour-hopscotch.qml:3:1: module "io.thp.pyotherside" is not
installed
import io.thp.pyotherside 1.3
^
^A^C
[nemo@Jolla ~]$
 
late88's Avatar
Posts: 196 | Thanked: 195 times | Joined on Feb 2012 @ Helsinki, Finland
#9
The app runs pretty smooth but after setting it up, I'm not able to install or download anything. They just does nothing.
__________________
Join the movement. Jolla.
 
Posts: 440 | Thanked: 274 times | Joined on Oct 2011 @ Grenoble, France
#10
Originally Posted by late88 View Post
The app runs pretty smooth but after setting it up, I'm not able to install or download anything. They just does nothing.
Same here .....
 
Reply

Tags
android, google

Thread Tools

 
Forum Jump


All times are GMT. The time now is 13:38.