Notices


Reply
Thread Tools
Posts: 1,208 | Thanked: 1,028 times | Joined on Oct 2007
#1
Quim Gil reported that Mad Bomber is not installable from fremantle extras-devel.
Hi, I have tried to install Mad Bomber from Fremantle extras-devel but I get the error:

Mad Bomber breaks the 3rd party package policy

Unable to install
Because I've never heard of such error I decided to move discussion here.

Does anybody know what causes this?

Quim, is it possible to get more detailed error report from AM itself or by trying to install it with apt-get?

Last edited by mikkov; 2009-06-21 at 14:34.
 
Jaffa's Avatar
Posts: 2,535 | Thanked: 6,676 times | Joined on Mar 2008 @ UK
#2
Never heard of it either. Deb info (on x86 at least) looks reasonable.

I haven't got time to grep through the h-a-m source at the moment.
__________________
Andrew Flegg -- mailto:andrew@bleb.org | http://www.bleb.org
 
Jaffa's Avatar
Posts: 2,535 | Thanked: 6,676 times | Joined on Mar 2008 @ UK
#3
Have a look at src/apt-worker.cc lines 3085 and 3096:

http://gitorious.org/hildon-applicat...er.cc#line3076

My guess is one of the depends conflicts with the SSU-installed packages (e.g. by requiring a higher version than installed on the device):

Code:
Depends: libc6 (>= 2.5.0-1), libsdl-image1.2 (>= 1.2.4-5), libsdl-mixer1.2, libsdl1.2 (>= 1.2.10-1), libx11-6, madbomber-data (= 0.2.5-3maemo4
__________________
Andrew Flegg -- mailto:andrew@bleb.org | http://www.bleb.org
 

The Following 6 Users Say Thank You to Jaffa For This Useful Post:
Posts: 1,208 | Thanked: 1,028 times | Joined on Oct 2007
#4
If that's the case then this cannot be fixed until SDK is updated. There could be other packages which require rebuilding too.
 
Posts: 2,802 | Thanked: 4,486 times | Joined on Nov 2007
#5
Originally Posted by Jaffa View Post
Have a look at src/apt-worker.cc lines 3085 and 3096:
It's got to be the first one, since there are no conflicts in the package. This then results in the reported error message here.

Originally Posted by Jaffa View Post
My guess is one of the depends conflicts with the SSU-installed packages (e.g. by requiring a higher version than installed on the device):

Code:
Depends: libc6 (>= 2.5.0-1), libsdl-image1.2 (>= 1.2.4-5), libsdl-mixer1.2, libsdl1.2 (>= 1.2.10-1), libx11-6, madbomber-data (= 0.2.5-3maemo4
All of the above (except madbomber-data) have equal or higher versions in the beta SDK already.

My C++-foo isn't great, but I suspect apt-pkg misuse or bug. This check should trigger for all the listed dependencies:

Code:
          if (op == pkgCache::Dep::NoOp
              || op == pkgCache::Dep::GreaterEq
              || op == pkgCache::Dep::Greater)
            continue;
or am I missing something?
 
qgil's Avatar
Posts: 3,105 | Thanked: 11,075 times | Joined on Jul 2007 @ Mountain View (CA, USA)
#6
Here you have, hope it helps.

/home/user # apt-get install madbomber
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
madbomber: Depends: madbomber-data (= 0.2.5-3maemo4) but it is not going to be installed
ukmp: Depends: python-pygame but it is not going to be installed
Depends: python-imaging but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
/home/user #
 
qgil's Avatar
Posts: 3,105 | Thanked: 11,075 times | Joined on Jul 2007 @ Mountain View (CA, USA)
#7
Coincidentally or not, there was an UKMP update. I have installed and now the story was different:

?
/home/user # apt-get install madbomber
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
madbomber-data
The following NEW packages will be installed:
madbomber madbomber-data
0 upgraded, 2 newly installed, 0 to remove and 3 not upgraded.
Need to get 2485kB of archives.
After this operation, 3666kB of additional disk space will be used.
Do you want to continue [Y/n]?
WARNING: The following packages cannot be authenticated!
madbomber-data madbomber
Install these packages without verification [y/N]? y
Get:1 http://repository.maemo.org fremantle/free madbomber-data 0.2.5-3maemo4 [2459kB]
Get:2 http://repository.maemo.org fremantle/free madbomber 0.2.5-3maemo4 [25,6kB]
Fetched 2485kB in 4s (527kB/s)
Selecting previously deselected package madbomber-data.
(Reading database ... 27749 files and directories currently installed.)
Unpacking madbomber-data (from .../madbomber-data_0.2.5-3maemo4_all.deb) ...
Selecting previously deselected package madbomber.
Unpacking madbomber (from .../madbomber_0.2.5-3maemo4_armel.deb) ...
Setting up madbomber-data (0.2.5-3maemo4) ...
Setting up madbomber (0.2.5-3maemo4) ...
gtk-update-icon-cache: Cache file created successfully.
/home/user #
 

The Following User Says Thank You to qgil For This Useful Post:
qgil's Avatar
Posts: 3,105 | Thanked: 11,075 times | Joined on Jul 2007 @ Mountain View (CA, USA)
#8
MadBomber works, apparently (just gave it a try, time to bed).

btw, you might want to consider using the interface with the accelerometers, but this is a topic for another thread.
 
qgil's Avatar
Posts: 3,105 | Thanked: 11,075 times | Joined on Jul 2007 @ Mountain View (CA, USA)
#9
So... is this 'third party package policy' about conflicting dependencies in extras? About third party packages that can't be authenticated? Both? Else?
 
Posts: 1,208 | Thanked: 1,028 times | Joined on Oct 2007
#10
Originally Posted by qgil View Post
So... is this 'third party package policy' about conflicting dependencies in extras? About third party packages that can't be authenticated? Both? Else?
That you probably have to ask from Nokia

But to me it looked like that Application Manager wasn't able to resolve depencies, possibly because ukmp installation was somehow halfway.
 

The Following User Says Thank You to mikkov For This Useful Post:
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 00:03.