Notices


Reply
Thread Tools
qole's Avatar
Moderator | Posts: 7,109 | Thanked: 8,802 times | Joined on Oct 2007 @ Vancouver, BC, Canada
#1
I've been asked to start a new Easy Debian thread because the old one is getting too long and hairy. So OK, here it is.

Here is the old thread for reference.

Here is info about my new versions, eventually going into the maemo.org extras free repository.

(original post)

I have uploaded new versions of easy-chroot and easy-deb-chroot to to the Diablo Extras-devel repository. Could I get a few beta-testers to try updating and report back here?

If I get no responses by the weekend, I will promote the packages to Extras and then I'll hear about the problems

Changes:
  • Added thp's patches to allow ssh-to-debian-shell.
  • Using the autobuilder process: the packages are now in "free"!
  • Now using separate dm-loop packages!


All of those changes are very geeky things to be excited about, I know.



Look at those beautiful, wonderful dependencies. Sweet.
__________________
qole.org --- twitter --- Easy Debian wiki page
Please don't send me a private message, post to the appropriate thread.
Thank you all for your donations!
 

The Following 16 Users Say Thank You to qole For This Useful Post:
thorbo's Avatar
Posts: 161 | Thanked: 55 times | Joined on Dec 2006 @ SLO, CA; United States
#2
Qole,

Just did the install. It initially balked at the easy-chroot, but said it installed... I turned off my Extras-devel repository, reinstalled (as now it showed up as an upgradeable package) the install then completed (seemed like a repair, really). Then I turned the repository back on, installed the easy-deb-chroot with no issue.

I erased my old image, and downloaded a new one... everything seems to be going swimmingly. I am not a power user, but I do "play" with this from time to time.

No negative repercussions so far. Should I stumble across something I will let you know. I mean, even a blind squirrel gets a nut once in a while.

Thor
__________________
Overworked, underpowered.
 

The Following 4 Users Say Thank You to thorbo For This Useful Post:
qole's Avatar
Moderator | Posts: 7,109 | Thanked: 8,802 times | Joined on Oct 2007 @ Vancouver, BC, Canada
#3
thorbo, thanks, I bet your double-install was required because my package went from having the dm-loop stuff embedded inside it to depending on external dm-loop packages. But if it works, that's great. I'll just warn people that it will take two runs at it to get it working.
__________________
qole.org --- twitter --- Easy Debian wiki page
Please don't send me a private message, post to the appropriate thread.
Thank you all for your donations!
 
Posts: 3,319 | Thanked: 5,607 times | Joined on Aug 2008 @ Finland
#4
Maybe some preinst magic in the dm-loop package can help ?
 
qole's Avatar
Moderator | Posts: 7,109 | Thanked: 8,802 times | Joined on Oct 2007 @ Vancouver, BC, Canada
#5
attila77: any magical ideas?

I think what's happening is that the dmsetup stuff is conflicting with my package because the same files are in both packages.

One ugly hack would be to have fake names for the binaries in the package, which you then move to the correct name in the postinst...? I don't know...
__________________
qole.org --- twitter --- Easy Debian wiki page
Please don't send me a private message, post to the appropriate thread.
Thank you all for your donations!
 
smarsh's Avatar
Posts: 155 | Thanked: 117 times | Joined on Jan 2008 @ Ontario, Canada
#6
I had the same issue, so thanks for the post Thor. apart from that, it's looking fine so far. Thanks again for this qole, it really does make my molbile life workable.

I'll be playing more with it tomolrrow and will get back with anything I find.
__________________
broken pencil
 

The Following User Says Thank You to smarsh For This Useful Post:
Posts: 183 | Thanked: 18 times | Joined on Jul 2009 @ italy
#7
hi qole ^^ I was testing it and i'm satisfied from the use, i manly use ffice and gimp, without ussues (apart the slow start, but it's normal xD) there are sime prograns that i do not use: epiphany and firefox, i want ti uninstall t, what i have to wrute in the terminal? (i mean the name of the packages), and how to remove the dead icons from hildon menu? i tried to modify the menu.conf but the icons are only mived to extras... can you help me?

thx a lot ^^
 
Posts: 3,319 | Thanked: 5,607 times | Joined on Aug 2008 @ Finland
#8
Originally Posted by qole View Post
attila77: any magical ideas?

I think what's happening is that the dmsetup stuff is conflicting with my package because the same files are in both packages.
That in itself should not be a problem (it would be helpful if we knew the exact error message, like what apt-get prints) Are those files perhaps in use somehow ?

One ugly hack would be to have fake names for the binaries in the package, which you then move to the correct name in the postinst...? I don't know...
In that case I think it's better to put a 'rm' for the old stuff in preinst ? (if you rename it in postinst, then you also have to change postrm to delete whan you renamed, etc)
 
qole's Avatar
Moderator | Posts: 7,109 | Thanked: 8,802 times | Joined on Oct 2007 @ Vancouver, BC, Canada
#9
Originally Posted by attila77 View Post
That in itself should not be a problem (it would be helpful if we knew the exact error message, like what apt-get prints) Are those files perhaps in use somehow ?
It is as I thought:

The following NEW packages will be installed
dmsetup kernel-diablo-modules-dmloop libdevmapper1.02.1
The following packages will be upgraded:
easy-chroot
1 upgraded, 3 newly installed, 0 to remove and 116 not upgraded.
Need to get 124kB/246kB of archives.
After unpacking 381kB of additional disk space will be used.
Do you want to continue [Y/n]? y
WARNING: The following packages cannot be authenticated!
libdevmapper1.02.1 dmsetup kernel-diablo-modules-dmloop easy-chroot
Install these packages without verification [y/N]? y
Get: 1 http://repository.maemo.org diablo/free easy-chroot 0.2.2-1diablo1 [124kB]Fetched 124kB in 2s (53.2kB/s)
Selecting previously deselected package libdevmapper1.02.1.
(Reading database ... 26889 files and directories currently installed.)
Unpacking libdevmapper1.02.1 (from .../libdevmapper1.02.1_2%3a1.02.27-maemo1_armel.deb) ...
dpkg: error processing /var/cache/apt/archives/libdevmapper1.02.1_2%3a1.02.27-maemo1_armel.deb (--unpack):
trying to overwrite `/lib/libdevmapper.so.1.02.1', which is also in package easy-chroot
Selecting previously deselected package dmsetup.
Unpacking dmsetup (from .../dmsetup_2%3a1.02.27-maemo1_armel.deb) ...
dpkg: error processing /var/cache/apt/archives/dmsetup_2%3a1.02.27-maemo1_armel.deb (--unpack):
trying to overwrite `/sbin/dmsetup', which is also in package easy-chroot
Selecting previously deselected package kernel-diablo-modules-dmloop.
Unpacking kernel-diablo-modules-dmloop (from .../kernel-diablo-modules-dmloop_2.6.21-200842maemo1.3_armel.deb) ...
Preparing to replace easy-chroot 0.1.9 (using .../easy-chroot_0.2.2-1diablo1_armel.deb) ...
Unpacking replacement easy-chroot ...
Errors were encountered while processing:
/var/cache/apt/archives/libdevmapper1.02.1_2%3a1.02.27-maemo1_armel.deb
/var/cache/apt/archives/dmsetup_2%3a1.02.27-maemo1_armel.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
__________________
qole.org --- twitter --- Easy Debian wiki page
Please don't send me a private message, post to the appropriate thread.
Thank you all for your donations!
 
Posts: 3,319 | Thanked: 5,607 times | Joined on Aug 2008 @ Finland
#10
I see. From my Debian packaging experience this suggests libdevmapper/dmsetup would have to have a "Replaces:" and/or "Conflicts:" in it's control file for the OLD easy-chroot package. Without it, the order of installs influences the outcome (if easy-chroot gets upgraded first, libdevmapper is OK, if libdevmapper comes first, it errors -> that's why it works out on the second try). Can you tell me the versions you used in easy-chroot (i.e. which is the last old-style package ver) ?
 

The Following User Says Thank You to attila77 For This Useful Post:
Reply

Tags
debian, easy debian, extras-devel, free

Thread Tools

 
Forum Jump


All times are GMT. The time now is 02:20.