Notices


Reply
Thread Tools
Posts: 62 | Thanked: 33 times | Joined on Jul 2010
#21
Ok I've got Fedora 12 to work with multiboot and it's indeed alot faster than I expected.
I've installed the kernel packages from MohammedAG at: http://mohammadag.xceleo.org/public/...s/framebuffer/
And I'm using his: http://mohammadag.xceleo.org/public/...e-fb-omap1.bin as /boot/multiboot/vmlinuz-2.6.28-framebuffer1

However I've got a few problems.
First of all the sound doesn't work, there is no documentation on that.
Second problem is that the mac-address changes on each boot, deleting the 70-persistant-net-rules is not really an option since my dhcp server will still assign a different ip-address. I would like to make the mac address to stay the same.
And the last problem is that I can't find the n900-support script for the battery.
cp -p /mnt/mer/etc/init.d/n900-support /etc/init.d/
# edit n900-support, adding this line:
# chkconfig: - 58 74
chkconfig --level 35 n900-support on
Any ideas?
 
kingoddball's Avatar
Posts: 1,175 | Thanked: 790 times | Joined on Apr 2010 @ Australia
#22
How do you do the CHroot part? I am having the same trouble with Fedora and Ubuntu. I can not get past the chroot (/bin/bash sections).
__________________
The thanks button? Sure! You can press it! I would!
 
Posts: 52 | Thanked: 17 times | Joined on Jun 2010 @ United Kingdom....for now.
#23
Masta, I never did get around the MAC address changing at each boot, but I just installed Network Manager so that I ddnt have to run a script to get the Wlan up and running.

King, you need to mount the partition fist, the chroot into it.

Like so:
Code:
mount /dev/mmcblk1px /media/mmcx
chroot /media/mmcx /bin/bash
 
Posts: 62 | Thanked: 33 times | Joined on Jul 2010
#24
for some reason multiboot seems unstable...
I cant get it to boot anymore for some reason
I've installed everything in this order:
Code:
kernel-framebuffer_2.6.28-20101501+0m5-framebuffer1_armel.deb
kernel-framebuffer-modules_2.6.28-20101501+0m5-framebuffer1_armel.deb
kernel-framebuffer-flasher_2.6.28-20101501+0m5-framebuffer1_armel.deb
multiboot-extras_0.1_armel.deb
multiboot_0.2.5_armel.deb
I've placed "zImage-fb-omap1.bin" from http://mohammadag.xceleo.org/public/maemo/kernels/ as /boot/multiboot/vmlinuz-2.6.28-framebuffer1

And there two items in /etc/multiboot.d:
Fedora-2.6.28.item
Code:
ITEM_NAME="Fedora 12"
ITEM_KERNEL="2.6.28-framebuffer1"
ITEM_MODULES="mbcache jbd ext3"
ITEM_DEVICE="${EXT_CARD}p3"
ITEM_FSTYPE="ext3"
ITEM_FSOPTIONS="noatime,rw"
and

Maemo-2.6.28-omap1.item
Code:
ITEM_NAME="Maemo 2.6.28-omap1"
ITEM_KERNEL=2.6.28-omap1
ITEM_MODULES=ext3
Only maemo works and for some reason it boots in framebuffer mode and only when there is no charger connected.

I've tried to issue the flasher commands:
Code:
flasher-3.5 --set-rd-flags=no-ext-wd
flasher-3.5 --set-rd-flags=no-omap-wd
flasher-3.5 --enable-rd-mode
But it doesn't help.

When I try to boot Fedora 12 it gets stuck or reboot.
 
Posts: 52 | Thanked: 17 times | Joined on Jun 2010 @ United Kingdom....for now.
#25
I did this. Reflash the phone with pr1.2 to start anew.
Use maemo flasher to flash the framebuffer kernel. don't install any modules, it works fine without.
in other word, use the framebuffer kernel for maemo and fedora.
install fedora.
install multiboot.
create fedora.item
check that you can boot both.
when you boot normal maemo it should boot the framebuffer kernel.
install maemo power, but dont flash the kernel, just install the kernels and modules.
create an item file to point to this kernel.
make sure the power kernel image and framebuffer image is in /boot/multiboot and that the names match to those is the item files.
check that you can boot all 3
install NITDroid
 
mankir's Avatar
Posts: 254 | Thanked: 186 times | Joined on Dec 2009 @ Frankfurt, Germany
#26
Anybody tried Fedora 13: http://scotland.proximity.on.ca/fedo...-06-29.tar.bz2
In http://fedoraproject.org/wiki/Archit...rdFP_Bootstrap they write, that thumb2 is disabled by default. So any application should be useable in easy chroot?
__________________
MOD-Package: http://talk.maemo.org/showthread.php?t=42415
 
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 15:12.