Reply
Thread Tools
Posts: 50 | Thanked: 45 times | Joined on Dec 2009 @ France
#1
Hi,

somebody know how to disable screen rotation in the phone app ?

I want use the phone app always in landscape mode.

Last edited by mymybib; 01-22-2010 at 07:18 AM.
 
pycage's Avatar
Posts: 3,225 | Thanked: 3,588 times | Joined on Oct 2005 @ Germany
#2
It's in the application menu.
There are 3 options: auto-rotate, always portrait, and launch automatically when in portrait orientation

Unfortunately, to force it to be always landscape (instead of always portrait which is possible), you would have to keep the keyboard slider open.
__________________
Apps For MeeGo - Graphical Client for N9/N950 and other devices
- http://apps.formeego.org

MediaBox Media Center - music, videos, pictures, UPnP, etc. for N8(10) and N900
- http://garage.maemo.org/projects/mediabox

pyFMRadio - control the FM radio on N800 and N900 with Python
- http://garage.maemo.org/projects/pyfmradio
 

The Following User Says Thank You to pycage For This Useful Post:
Posts: 87 | Thanked: 47 times | Joined on Sep 2009 @ Sorocaba, Brasil
#3
Unfortunately it's not possible with the current firmware.

The settings are available from the main menu in the phone app, but the only options available are "portrait" or "automatic", which will change its orientation using the accelerometer.

But there's no fix "landscape" option available.
 

The Following User Says Thank You to dalonso For This Useful Post:
Posts: 113 | Thanked: 18 times | Joined on Jun 2010
#4
Is very annoying that although setting portrait mode to the Phone app, when incoming call sometimes launches in landscape orientation, sometimes launches portrait, and sometimes rotates with the movement.
 
Posts: 5 | Thanked: 0 times | Joined on Apr 2010
#5
what is monumentally annoying, is that
1 - the phone rings,
2 - i pick up the phone,
3 - detects movement,
4 - i tap accept call,
5 - it's prior request to rotate screen from movement detection has priority
6 - screen rotates, now where accept button was, is now mostly "reject call" button.
7 - the prior screen tap co-ordinates registered, now able to processed.
8 - tap co-ords are on the now "reject call" button
9 - call rejected.

i'm trying to get $%^&ing job contracts, and running a business. rejecting calls is not "$%ing helping. screen rotation not being available in the main settings, didn't even cross my mind that it was a per application setting.
i love what i can do with my N900, and the promise it had, but looking back, it's been a mistake from day one. i want the N9, but that just looks like it's going to be another orphaned device, with the same issues, giving me the same pain.
i very nearly had an N900 shaped hole in the wall a few minutes ago from rejecting another called from "unknown number" (random agency), but then remembered i'd canceled my insurance. wrong move again on my part. goddamn. i am a virment apple hater, but my god, silly little things like this, i might just turn iphone.

thanks for the heads up btw on the rotation settings.
 
Posts: 183 | Thanked: 98 times | Joined on Mar 2011 @ Brisbane, Australia
#6
darksun, install the CSSU and turn on "lock to landscape" mode from the status menu. This will ensure that the phone will not rotate at all, and will stay in the landscape position no matter what
 
bingomion's Avatar
Posts: 493 | Thanked: 268 times | Joined on Aug 2010 @ MLB.AU
#7
start the phone app.
click phone (top bar)
click Turning control
click display orientation
options: portrait, landscape automatic.
I prefer landscape on all apps.. the only app that doesn't work in landscape is fakecaller, which i only use in an emergency.
 

The Following 2 Users Say Thank You to bingomion For This Useful Post:
peter2p's Avatar
Posts: 254 | Thanked: 143 times | Joined on Dec 2010 @ Antwerp Belgium
#8
Originally Posted by narcisgarcia View Post
Is very annoying that although setting portrait mode to the Phone app, when incoming call sometimes launches in landscape orientation, sometimes launches portrait, and sometimes rotates with the movement.
Here's another way
- Install Leafpad
- open X-terminal
- become root
- type leafpad /usr/share/hildon-desktop/transitions.ini
- leafpad opens
- edit file at the bottom
- blacklist = the-app-you-want-to-be-blacklisted (list by Boemien) should be rtcom-call-ui
- save, close and reboot
__________________
.................................................. ...........
..........................
................................N900 is a way of life....................
surfing the web, navigate, chat, ttweet, email, scan, hack, share, tweak...
.....................and you can also use him to make a call
 

The Following User Says Thank You to peter2p For This Useful Post:
Posts: 642 | Thanked: 737 times | Joined on Jan 2011 @ Touring
#9
Originally Posted by peter2p View Post
Here's another way
- type leafpad /usr/share/hildon-desktop/transitions.ini
- leafpad opens
- edit file at the bottom
- blacklist = the-app-you-want-to-be-blacklisted (list by Boemien) should be rtcom-call-ui
- save, close and reboot
For anyone wanting to try this method it will leave you unable to start any apps and fix the mistake after reboting.
Since my wifi is disabled I am trying to figure out a creative way to edit /usr/share/hildon-desktop/transitions.ini

Fortunately I had bash on my desktop and there was a short period at bootup where I could get my desktop apps to load where I edited the transitions conf file and fixed my phone.

Last edited by biketool; 10-03-2012 at 07:14 AM.
 
Posts: 1,178 | Thanked: 1,100 times | Joined on Mar 2010
#10
Originally Posted by peter2p View Post
Here's another way
- Install Leafpad
- open X-terminal
- become root
- type leafpad /usr/share/hildon-desktop/transitions.ini
- leafpad opens
- edit file at the bottom
- blacklist = the-app-you-want-to-be-blacklisted (list by Boemien) should be rtcom-call-ui
- save, close and reboot
Came to post this
 
Reply

Thread Tools

 
Forum Jump


All times are GMT -4. The time now is 09:58 PM.