Notices


Reply
Thread Tools
Posts: 1 | Thanked: 0 times | Joined on Oct 2011
#1051
This forum won't allow me to search the thread for the word `new` so I'm not sure if this is already covered but here's my feedback:

1) I'm not able to send an SMS to a new number. I have tried with and without international prefixes of +1

2) I'm not able to send Google Voice SMS from contact list (may tie in with the above)

3) Over a period of time, threads appear empty, even though conversation list shows the last message. The messages are not lost, sometimes a reboot is required.

4) According to your article http://maemo.org/packages/view/telepathy-theonering/ you state "Reduce battery drain by setting your status to Away". It doesn't seem possible to change the status of a Google Voice account. It will change all other accounts but Google Voice will remain as `online`.

If there are any solutions for the above, please fill me in.

On a side note, this is not relevant to your package but I'm hoping you can shed some light on this too. I'm not able to receive Google Voice calls on Google Talk but I can receive voice/video chats sent from Google Talk. Is there a remedy for this? I use Google Talk when I'm outside of the United States so the callback feature wouldn't work, therefore I rely on Google Talk.

Thank you for your time.
 
epage's Avatar
Posts: 1,684 | Thanked: 1,551 times | Joined on Jun 2008 @ Austin, TX
#1052
I'll have to get back to you later on the other problems

Originally Posted by ajayahmed View Post
On a side note, this is not relevant to your package but I'm hoping you can shed some light on this too. I'm not able to receive Google Voice calls on Google Talk but I can receive voice/video chats sent from Google Talk. Is there a remedy for this? I use Google Talk when I'm outside of the United States so the callback feature wouldn't work, therefore I rely on Google Talk.

Thank you for your time.
I believe this generally requires a browser plugin and can't be done through normal XMPP. account.
__________________
770, n810, n900, Ideapad S10-3t
TheOneRing, DialCentral, Gonvert, Quicknote, Multilist, ejpi, nQa, Waters of Shiloah
Programming Blog
 
Banned | Posts: 388 | Thanked: 57 times | Joined on Mar 2010
#1053
Hi,

I have just seen that it is possible to download via all calling and conversation history for Google Voice using "Google Takeout"
 
Posts: 228 | Thanked: 143 times | Joined on Dec 2009
#1054
@epage, are you still around? no posts in this thread in almost a year.

but i use TOR daily! or at least used to use it. got a weird problem.

if i'm on wifi - any wifi - it works. if i'm on GRPS with at&t, TOR fails to sign in (but it used to sign in fine). if on GPRS i access the web interface to GV, i.e., https://www.google.com/voice/m , that works fine. any ideas?
 
Addison's Avatar
Posts: 3,807 | Thanked: 1,132 times | Joined on Oct 2007 @ East Lansing, MI
#1055
I changed to just using Modest with 1 minute notifications and going to google.com/voice/m with the browser zoomed in and have been really happy ever since.

This way you can have both an LED and ringtone notification as well when receiving any new messages.
 
epage's Avatar
Posts: 1,684 | Thanked: 1,551 times | Joined on Jun 2008 @ Austin, TX
#1056
Originally Posted by jacktanner View Post
@epage, are you still around? no posts in this thread in almost a year.

but i use TOR daily! or at least used to use it. got a weird problem.

if i'm on wifi - any wifi - it works. if i'm on GRPS with at&t, TOR fails to sign in (but it used to sign in fine). if on GPRS i access the web interface to GV, i.e., https://www.google.com/voice/m , that works fine. any ideas?
Could be a timeout issue, I remember those happening quite a bit.

The wiki page has some information on how to collect information to see why it is happening
http://wiki.maemo.org/The_One_Ring

Other than that, I've sadly moved on. QML was frustrating enough that I've just stopped development in general and now I'm getting dead pixels on my n950 due to dropping it. I don't see much point in keeping up with n8x0 and n900.

__________________
770, n810, n900, Ideapad S10-3t
TheOneRing, DialCentral, Gonvert, Quicknote, Multilist, ejpi, nQa, Waters of Shiloah
Programming Blog
 

The Following 2 Users Say Thank You to epage For This Useful Post:
Addison's Avatar
Posts: 3,807 | Thanked: 1,132 times | Joined on Oct 2007 @ East Lansing, MI
#1057
Aww... I'm sorry Ed.

Well, it's still good to see you around here.

You've been missed.
 
Posts: 228 | Thanked: 143 times | Joined on Dec 2009
#1058
Ha. TOR started working on GRPS again for me. No idea what changed. But back to normal.

Cheers, Ed. Too bad about the QML development pains.

I'm sticking with my N900. It's a fine phone and music player, decent address book, email. I don't use it for much more than that. And I've zero desire to join any of the "ecosystems" out there. They all creep me out.
 
Posts: 1,343 | Thanked: 3,571 times | Joined on Dec 2010 @ Dayton, Ohio
#1059
Originally Posted by jacktanner View Post
I'm sticking with my N900. It's a fine phone and music player, decent address book, email. I don't use it for much more than that. And I've zero desire to join any of the "ecosystems" out there. They all creep me out.
Just a "me, too" response here. My N900 is a little Linux box that doubles as a phone; what else could I possibly want? There's more than enough cpu power and memory to create and run an endless series of programs. And, whenever I do move on to another device, as long as it runs a decent flavor of Unix, all my programs will come with me. That's something you can't do when you've bought into an "ecosystem" and tied yourself to a single corporation.
 
Xenolith0's Avatar
Posts: 8 | Thanked: 33 times | Joined on Mar 2010
#1060
For the last 5 or so days TOR has been unable to connect to GV. After researching the problem, I found what has changed is Google's login URL. Which previously was "https://www.google.com/accounts/ServiceLoginAuth" and has now changed to be "https://accounts.google.com/ServiceLoginAuth".

Until the developer updates his package, a quick work-around to this is to edit the file "/opt/theonering/lib/gvoice/backend.py" go to line 169 and change:
self._loginURL = "https://www.google.com/accounts/ServiceLoginAuth"
to
self._loginURL = "https://accounts.google.com/ServiceLoginAuth"

After that just initiate a reconnect, and it should work.... Assuming anyone else is having this issue. After searching the forums I have not seen anyone else reporting this problem, so maybe Google only hates me.

However, this is why I LOVE open source software. <3 Maemo.

theonering.log:
Code:
(2013-01-30 16:49:56,405) DEBUG AsyncPool.gvoice.browser_emu: Performing download of https://www.google.com/voice/m
(2013-01-30 16:49:57,410) DEBUG AsyncPool.gvoice.browser_emu: Performing download of https://www.google.com/accounts/ServiceLoginAuth
(2013-01-30 16:49:58,586) DEBUG AsyncPool.gvoice.browser_emu: HTTP Error 404: Not Found: https://www.google.com/accounts/ServiceLoginAuth
(2013-01-30 16:49:58,591) DEBUG AsyncPool.gvoice.browser_emu: MozillaEmulator: urllib2.URLError, retrying 1
(2013-01-30 16:49:59,058) DEBUG AsyncPool.gvoice.browser_emu: HTTP Error 404: Not Found: https://www.google.com/accounts/ServiceLoginAuth
(2013-01-30 16:49:59,119) ERROR AsyncPool.gvoice.backend: Translating error: HTTP Error 404: Not Found
(2013-01-30 16:49:59,159) ERROR AsyncPool.util.go_utils: Error, passing it back to the main thread
Traceback (most recent call last):
  File "/opt/theonering/lib/util/go_utils.py", line 191, in __consume_queue
    result = func(*args, **kwds)
  File "/opt/theonering/lib/gvoice/backend.py", line 294, in login
    loginSuccessOrFailurePage = self._login(username, password, galxToken)
  File "/opt/theonering/lib/gvoice/backend.py", line 283, in _login
    loginSuccessOrFailurePage = self._get_page(self._loginURL, loginData)
  File "/opt/theonering/lib/gvoice/backend.py", line 779, in _get_page
    raise NetworkError("%s is not accesible" % url)
NetworkError: https://www.google.com/accounts/ServiceLoginAuth is not accesible
(2013-01-30 16:49:59,171) ERROR MainThread.connection: https://www.google.com/accounts/ServiceLoginAuth is not accesible
(2013-01-30 16:49:59,175) INFO  MainThread.connection: Disconnecting

Last edited by Xenolith0; 2013-01-31 at 00:24. Reason: Stupid typos
 

The Following 10 Users Say Thank You to Xenolith0 For This Useful Post:
Reply

Tags
google voice

Thread Tools

 
Forum Jump


All times are GMT. The time now is 22:11.