Notices


Reply
Thread Tools
calvin_42's Avatar
Posts: 286 | Thanked: 217 times | Joined on Feb 2010 @ France
#1
Autodisconnect v0.4.8
Automatically closes your idle connections and auto-switches the network mode to 2G when 3G is not required.

Description
------------------------------------------------------

This application automatically closes your idle connections (Wifi + 3G/GPRS + Bluetooth) and switches the network mode of your phone to 2G when 3G is not used, in order for your batteries to last much longer.

Analysis made with one automatic sync (calendar & contacts) running on a unused device every hour using Wifi Access Point : your batteries will last up to 5x longer with AutoDisconnect enable.

The package is available on the extras repository for the stable version, and on the extras-devel repository for the testing version.

Please check the Wiki here to get all the information you want.

To manage the application, you can launch the program 'AutoDisconnect' which is available in Settings > Connectivity. You will find 5 tabs :







Last Changelog
------------------------------------------------------

v0.4.8 - 12-28-10
  • Fix [#6380] : Disconnect fails when interface traffic exceeds 2 GiB
  • Fix [#6705] : Multiple connections support for the same interface
  • New feature [#6102] : Exception for Mobile Hotspot/JoikuSpot

Last edited by calvin_42; 2010-12-29 at 08:54. Reason: Version 0.4.8
 

The Following 96 Users Say Thank You to calvin_42 For This Useful Post:
#9370, AndiThebest, asidana, atilla, bald.eagle.one, berlinermaxe, bheetebrij, biggzy, bitcrusher, bob_bipbip, borghal, bousch, bzhnjm, cardiff-blues, casper27, cheve, chowdahhead, cjp, codeMonkey, craftyguy, DarkFulgore, defixio, DrWilken, El Amir, etuoyo, frals, Gusse, Hannu, Helmuth, HRZ, hypnotik, Ikari, imo, ioan, jakiman, jerra, jmk, Johnx, joppu, jpala16, jrox, juahan, juise-, kevloral, kik, kopte3, labra, logicalsid, manaryde, mannakiosk, marble, mclarson, MiNe, moepda, n900maniac, naabi, Natan_xy, Netweaver, noipv4, nokiac, P@t, pelago, peterleinchen, PhonoN900, piascyk, pillar, PMaff, qwerty12, raily, RetoPMWF, Russe89, sachin007, SallyJane, Sasler, scifi.guy, sjgadsby, skalogre, smoothc, sorodoros, stas123, stayloa, Stealth131, stlpaul, surferr, Switch_, thommy, todor_tsankov, tuminoid, udaychaitanya16, Wanker, woodyear99, x-lette, xabaras, xgrind, zvogt, _David_
casper27's Avatar
Posts: 839 | Thanked: 508 times | Joined on Jan 2009 @ UK southampton
#2
Thank you calvin will test it out
 
b666m's Avatar
Posts: 1,090 | Thanked: 468 times | Joined on Jan 2010 @ Ingolstadt, Germany
#3
following would be worth testing:
1. fully charge your phone
2.
a) let it idle with wlan ON
b) let it idle with wlan OFF
3. look at the differences in battery usage
(which lasts longer and how much longer ^^)
 
Posts: 318 | Thanked: 49 times | Joined on Nov 2009
#4
Sounds awesome, perhaps I will re enable all the cool widgets if this works properly
 
amorek13's Avatar
Posts: 245 | Thanked: 31 times | Joined on Oct 2009 @ CT USA
#5
works great here what do the global settings do ?
 
calvin_42's Avatar
Posts: 286 | Thanked: 217 times | Joined on Feb 2010 @ France
#6
Originally Posted by amorek13 View Post
works great here what do the global settings do ?
- Enabled = active or not the application
- Notifications = display or not a message on the screen when you start a connection and when AutoDisconnect closes it.
 
Ronaldo's Avatar
Posts: 682 | Thanked: 206 times | Joined on Jan 2010 @ UK
#7
sounds good. will i have to manually connect again if i need connection?
 
amorek13's Avatar
Posts: 245 | Thanked: 31 times | Joined on Oct 2009 @ CT USA
#8
ok here is one bug i guess i will call it
after installing autodisconnect it delays the internet connection which cause my widgets not to update becasue its still connecting to the internet tested with autodisconnect installed and unistalled( connects to internet within 5 seconds instead of 12)
 

The Following User Says Thank You to amorek13 For This Useful Post:
Posts: 1,427 | Thanked: 2,075 times | Joined on Aug 2009 @ Sydney
#9
This program is just what I needed. Awesome app. Thank you.

I use adhoc connection with my N900 quite a lot. (not infrastructure) When N900 is connected in adhoc, the wireless does not disconnect automatically even when the adhoc connection is out of range or disconnected. So my N900 gets really hot and battery dies within couple of hours if I forget to disconnect it manually myself.

Two points I would like to make:

1. Interval number only shows 1 digit number. Would like this to show 2 digits. (Also, Max Idle traffic is 3 digits but would prefer 4)

2. Is it possible to have 1 for Wifi Infrastructure and 1 for Wifi Adhoc for monitored connections? (instead of just 'Wifi' which does both)
 

The Following User Says Thank You to jakiman For This Useful Post:
calvin_42's Avatar
Posts: 286 | Thanked: 217 times | Joined on Feb 2010 @ France
#10
Originally Posted by amorek13 View Post
ok here is one bug i guess i will call it
after installing autodisconnect it delays the internet connection which cause my widgets not to update becasue its still connecting to the internet tested with autodisconnect installed and unistalled( connects to internet within 5 seconds instead of 12)
Thanks for reporting it amorek.
 

The Following User Says Thank You to calvin_42 For This Useful Post:
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 09:10.