Reply
Thread Tools
Posts: 729 | Thanked: 154 times | Joined on Dec 2009
#1
I have a strange problem with libsdl-ttf2.0 and libsdl-ttf2.0-0 after I tried to install the new PyGame 1.9.1 build. I think both packages do the same and you can only install one of them at the same time. The problem is that every package seems to use libsdl-ttf2.0-0 but PyGame 1.9.1 libsdl-ttf2.0 and now I am stuck and I don't know how to solve the problem:

Code:
Nokia-N900:~# apt-get install python-pygame
Reading package lists... Done
Building dependency tree
Reading state information... Done
python-pygame is already the newest version.
python-pygame set to manually installed.
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  python-pygame: Depends: libsdl-ttf2.0 (>= 2.0.9) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Nokia-N900:~# apt-get install libsdl-ttf2.0
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
  libsdl-ttf2.0
0 upgraded, 1 newly installed, 0 to remove and 16 not upgraded.
2 not fully installed or removed.
Need to get 0B/13,5kB of archives.
After this operation, 77,8kB of additional disk space will be used.
(Reading database ... 48590 files and directories currently installed.)
Unpacking libsdl-ttf2.0 (from .../libsdl-ttf2.0_2.0.9-1osso0+0m5_armel.deb) ...
dpkg: error processing /var/cache/apt/archives/libsdl-ttf2.0_2.0.9-1osso0+0m5_armel.deb (--unpack):
 trying to overwrite `/usr/lib/libSDL_ttf-2.0.so.0.6.3', which is also in package libsdl-ttf2.0-0
Errors were encountered while processing:
 /var/cache/apt/archives/libsdl-ttf2.0_2.0.9-1osso0+0m5_armel.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
I cannot even install/upgrade other packages because of this.
How can I solve that problem?
Thanks
 
Posts: 104 | Thanked: 15 times | Joined on Jan 2010 @ Luxembourg
#2
Try looking in this thread as I had something similar: http://talk.maemo.org/showthread.php?t=59553
 
Posts: 2 | Thanked: 0 times | Joined on Aug 2010
#3
Same here, and I don't have a clue how to fiz it. Maybe I will reflash-it, but I rather prefer not doing so...
 
Posts: 729 | Thanked: 154 times | Joined on Dec 2009
#4
I think even a re-flash doesn't help if you want to install the same packages again.
There is a bug report on https://bugs.maemo.org/show_bug.cgi?id=10450 for this. I hope it will be fixed soon.
 
Posts: 2 | Thanked: 16 times | Joined on Aug 2010 @ Belgium
#5
The problem seems to be caused because apt tries to install both libsdl-ttf2.0-0 and libsdl-ttf2.0.

I resolved this by force removing the installed libsdl-ttf2 version:

Code:
$ dpkg --force-all -r libsdl-ttf2.0-0
Afterward running apt-get install -f resolved the issue and installed both packages without problems. (logic? no clue.)
 

The Following 14 Users Say Thank You to vStone For This Useful Post:
shazosbourne's Avatar
Posts: 257 | Thanked: 204 times | Joined on Jan 2010 @ Sydney, Australia
#6
Originally Posted by vStone View Post
The problem seems to be caused because apt tries to install both libsdl-ttf2.0-0 and libsdl-ttf2.0.

I resolved this by force removing the installed libsdl-ttf2 version:

Code:
$ dpkg --force-all -r libsdl-ttf2.0-0
Afterward running apt-get install -f resolved the issue and installed both packages without problems. (logic? no clue.)
This fixed mine. Thanks a lot vStone!
 
Posts: 75 | Thanked: 17 times | Joined on Aug 2010 @ under the sky
#7
Originally Posted by vStone View Post
The problem seems to be caused because apt tries to install both libsdl-ttf2.0-0 and libsdl-ttf2.0.

I resolved this by force removing the installed libsdl-ttf2 version:

Code:
$ dpkg --force-all -r libsdl-ttf2.0-0
Afterward running apt-get install -f resolved the issue and installed both packages without problems. (logic? no clue.)
this solves the issue, many thanks. can you tell us why we removed libsdl-ttf2.0-0 and not libsdl-ttf2.0 ?

also, how different is apt-get install -f from apt-get -f install
 
Helmuth's Avatar
Posts: 1,259 | Thanked: 1,339 times | Joined on Oct 2009 @ Germany
#8
Hmm... apt-get install -f is not working at my device. I got following error:

Errors were encountered while processing:
/var/cache/archives/libsdl-ttf2.0-0_2.0.9-1maemo2_armel.deb
E: Sub-process /usr/bindpkg returned an error code (1)
Could someone please try to help me?
 
Helmuth's Avatar
Posts: 1,259 | Thanked: 1,339 times | Joined on Oct 2009 @ Germany
#9
Okay, solved using activated Extra-Devel to get the newest version.
 
pH5's Avatar
Posts: 138 | Thanked: 369 times | Joined on Aug 2009 @ Berlin
#10
Originally Posted by TDSii View Post
this solves the issue, many thanks. can you tell us why we removed libsdl-ttf2.0-0 and not libsdl-ttf2.0 ?
libsdl-ttf2.0 is from the Nokia repositories, libsdl-ttf2.0-0 is from Extras-devel.

libsdl-ttf2.0-0 <= 2.0.9-1maemo2 contains the same library as libsdl-ttf2.0 - they can't be installed at the same time.

libsdl-ttf2.0-0 >= 2.0.9-1maemo3 is just an empty package that depends on libsdl-ttf2.0

Now if you installed a game that depends on libsdl-ttf2.0-0 (and have 2.0.9-1maemo2 installed), you can't install a game that depends on libsdl-ttf2.0 later, because those two packages conflict.
You can't just update from libsdl-ttf2.0-0 2.0.9-1maemo2 to 2.0.9-1maemo3 either, because the latter depends on libsdl-ttf2.0, which can't be installed as long as libsdl-ttf2.0-0 2.0.9-1maemo2 is still there.
Now after force-deinstalling libsdl-ttf2.0-0 2.0.9-1maemo2, apt-get -f install can install the libsdl-ttf2.0 + libsdl-ttf2.0-0 2.0.9-1maemo3 combination to make both games depending on libsdl-ttf2.0 and games depending on libsdl-ttf2.0-0 happy.

Last edited by pH5; 2010-09-07 at 17:31.
 
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 17:44.