Notices


Reply
Thread Tools
MohammadAG's Avatar
Posts: 2,473 | Thanked: 12,205 times | Joined on Oct 2009 @ Jerusalem, PS/IL
#1
This is a new pulseaudio package, not sure if this is the full patch http://www.mail-archive.com/pulseaud.../msg07401.html but it should solve stuttering.

For some reason, it does NOT work on the stock kernel, you'll need to install kernel-power.

Doing some tests yesterday it didn't stutter, today it did, so I'm not sure if it's working or not, so I'll release this to the community and leave you to decide.

Packages available here, download all.tar.gz and install all packages except the -dev package.
http://mohammadag.xceleo.org/public/maemo/test/

To pin the package (so it won't be upgraded by apt-get upgrade):
Code:
for x in pulseaudio libpulse-mainloop-glib0 libpulse0 pulseaudio-esound-compat pulseaudio-module-bluetooth pulseaudio-module-extra pulseaudio-module-gconf pulseaudio-module-hal pulseaudio-module-x11 pulseaudio-utils
do echo -e "Package: $x
Pin: release a=unstable 
Pin-Priority: 1001\n" >> /etc/apt/preferences
done
Need some feedback, this is not a perfect fix, it just seems to reduce stuttering.

Last edited by MohammadAG; 2010-08-22 at 09:53.
 

The Following 85 Users Say Thank You to MohammadAG For This Useful Post:
CepiPerez's Avatar
Posts: 806 | Thanked: 3,337 times | Joined on Feb 2010 @ Argentina
#2
Testing...

EDIT: No more stuttering when I lock the screen pressing twice the power button... thanks for this!

Last edited by CepiPerez; 2010-08-21 at 23:37.
 
ToJa92's Avatar
Posts: 1,091 | Thanked: 322 times | Joined on Feb 2010 @ ~
#3
Installs ok, playing a internet radio stream and browsing with MicroB doesn't cause any stuttering. I have not tried any FLAC files though(they stuttered with the old PulseAudio, not sure about the new one).
__________________
NITDroid forum, for everything NITDroid related.
Nokia N900[Power Kernel+CSSU] + GameGripper | Apple iPhone 4(32GB, iOS 6.0.1) | Apple iPad Mini(32GB, iOS 6.0.1)
 
hawaii's Avatar
Posts: 1,020 | Thanked: 772 times | Joined on Jun 2009 @ Toronto
#4
Subscribed.
__________________
Blog: Know Nokia
 
Posts: 515 | Thanked: 264 times | Joined on Nov 2009 @ Oelsted, Denmark
#5
Originally Posted by hawaii View Post
Subscribed.
There's a button for that on top of first post...

"Thread Tools" -> "Subscribe to this Thread"
__________________
Christian Wilken - tux-POWER.dk!
... May the Source be with You ...
 

The Following 6 Users Say Thank You to DrWilken For This Useful Post:
hawaii's Avatar
Posts: 1,020 | Thanked: 772 times | Joined on Jun 2009 @ Toronto
#6
Originally Posted by DrWilken View Post
There's a button for that on top of first post...

"Thread Tools" -> "Subscribe to this Thread"
Oh holy crap. I actually never knew that was there.

Thanks duders
__________________
Blog: Know Nokia
 

The Following 2 Users Say Thank You to hawaii For This Useful Post:
Posts: 2,014 | Thanked: 1,578 times | Joined on Sep 2009
#7
all.tar.gz is corrupted. However installed the packages one at a time - pulseaudio-dev gives dependency errors so removed. Can confirm it seems to fix the stuttering and I could be crazy but also seems louder...
__________________
Class .. : Power Poster, Potential Coder
Humor .. : [*********] Alignment: Chaotic Evil
Patience : [***-------] Weapon(s): +2 Logic Mace
Agro ... : |*****-----] Relic(s) : G1, N900

 
Posts: 110 | Thanked: 127 times | Joined on May 2010
#8
Just reading the developer's changelog brought a big smile to my face, and I wasn't disappointed! MohammadAG, the stuttering has literally disappeared when using the media widget right after startup, and when playing FLACs. These account for most of the recurring stutter I've experienced.

Your packaging these latest versions of N900 system software has literally solved my worst issues with this device. Between this, hildon-desktop, and your transitions.ini, it's made a world of difference! Thanks for going out of your way to prepare these debs.
 

The Following 3 Users Say Thank You to wumpwoast For This Useful Post:
Posts: 118 | Thanked: 39 times | Joined on Apr 2010 @ Jakarta, Indonesia
#9
really want to try this...
but i can't seem to install it...
the all.tar.gz file was corrupted
 
arora.rohan's Avatar
Posts: 353 | Thanked: 162 times | Joined on Jun 2010 @ India
#10
For me... i downloaded the all.tar.gz
extracted it and then tried to install each .deb file... but HAM says incompatible package..i need to install them via Xterm? sorry ..but i really wanted o try this as i listen to FLAC a lot and wanted to try this!
 
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 21:25.