Notices


Reply
Thread Tools
Posts: 219 | Thanked: 39 times | Joined on Sep 2010
#1
Anyone able to update this package?

It's a required dependency for purple-extra-protocols-dbg/2.7.5-1nix0/ and Pidgin. But it has some dependency error so it can't be updated. The author is not active in the forum since April, so I don't know how to contact him.
 
Posts: 62 | Thanked: 6 times | Joined on Apr 2010
#2
Originally Posted by zerocool2k View Post
Anyone able to update this package?

It's a required dependency for purple-extra-protocols-dbg/2.7.5-1nix0/ and Pidgin. But it has some dependency error so it can't be updated. The author is not active in the forum since April, so I don't know how to contact him.
No, same problem here.

When I run a

" apt-get -f install "

in X-Terminal, I get errors.

" Trying to overwrite /etc/purple/prefs.xml, which is also in package pidgin "

It also states that ".. 23 packages are not upgraded. And 11 not fully installed or removed .. "

" E: sub-process usr/bin/dpkg returned an error code (1) "


Any help to solve this is appreciated ;-)

 
lunatik's Avatar
Posts: 25 | Thanked: 6 times | Joined on May 2010 @ Moscow, Russia
#3
Yep, and also I can not remove pidgin. Even If I remove /etc/purple/prefs.xml it still complains about being unable to overwrite it.
 
Posts: 1 | Thanked: 4 times | Joined on Nov 2010
#4
Just hit the same issue when I upgraded extra-protocols and I managed to make it work as follows:

Using X-terminal:

dpkg -r pidgin
dpkg -P pidgin

cd /var/cache/apt/archives
dpkg -i libpurple0_2.7.5-1nix0_armel.deb

Then I tried installing pidgin again, with aptitude install pidgin which was failing with the same error

So I had to force it:

cp /etc/purple/prefs.xml prefs.xml.bak

cd /var/cache/apt/archives

dpkg -i --force-overwrite pidgin_2.7.5-1nix0_armel.deb

Went back to /etc/purple, prefs.xml was the same, no need to change.

I'm not sure if it's the best solution but it worked for me. And probably if you --force-overwrite libpurple it will also work without removing pidgin.

Hope it helps!
 

The Following 4 Users Say Thank You to Diablo For This Useful Post:
Posts: 924 | Thanked: 436 times | Joined on May 2010
#5
yep i have the same issue. had to fix it manually with dpkg.

used dpkg to show the dependencies and then manually removed them one at a time. i had issues with libpurple0 where apt-get was complaining that it needs a version that is newer but an older version was installed.
 
Posts: 219 | Thanked: 39 times | Joined on Sep 2010
#6
Does anyone know how to contact the author? I hate having to do this every time I update these packages (especially when they have a lot of updates lately).
 
xxxxts's Avatar
Posts: 491 | Thanked: 339 times | Joined on Nov 2009 @ LA
#7
Fixed now...
 
Posts: 219 | Thanked: 39 times | Joined on Sep 2010
#8
Are you sure? I just updated all these to 2.7.5 nix1 and still got the error.
 
nix_nix's Avatar
Posts: 64 | Thanked: 13 times | Joined on Mar 2007
#9
From version 2.7.3 to version 2.7.5 I moved the prefs.xml from pidgin to libpurple. I made the mistake of forgetting to remove it from pidgin, so in version 2.7.5-0nix0 both packages were providing the same file.

I realized my mistake, and removed it from pidgin. Unfortunately, hildon application manager is pretty sticky about allowing files to move from one package to the other. You see, if you have pidgin-2.7.3-0nix2 and you want to upgrade, well, both pidgin-2.7.3-0nix2 and libpurple0-2.7.5-xnixx provide the same file, so for a short period the file would be owned by two packages. This is not allowed, and produces an error in application manager disallowing the upgrade of purple extra protocols.

As a workaround, you can do this:

Upgrade pidgin, then upgrade purple-extra-protocols separately, because once you've upgraded pidgin, the problem goes away.

I appologize for the inconvenience.

Also, please give your thumbs-up if you think this is good enough for you

http://maemo.org/packages/package_in...n/2.7.5-2nix2/

http://maemo.org/packages/package_in...s/2.7.5-2nix2/

http://maemo.org/packages/package_in...n/2.7.5-2nix2/
 

The Following User Says Thank You to nix_nix For This Useful Post:
zlatko's Avatar
Posts: 802 | Thanked: 828 times | Joined on Feb 2010 @ Bulgaria
#10
@nix_nix
I checked my Pidgin "About": version is 2.7.5(libpurple 2.7.3). I am not able to upgrade pidgin or extra-protocols due to "unmet dependencies". I have tried "--reinstall install" but get the same error. What is the right way to get rid of this annoying problem?

EDIT: I installed anew liburple0, pidgin and extra protocols from .deb files. Lets see if the update error will persist.
EDIT1: Updated Pidgin to version: pidgin-2.7.5-2nix3

Last edited by zlatko; 11-11-2010 at 08:31 AM. Reason: additional info
 
Reply

Thread Tools

 
Forum Jump


All times are GMT -4. The time now is 04:52 PM.