Notices


Reply
Thread Tools
Posts: 28 | Thanked: 16 times | Joined on Jan 2009
#1
Hello,

ankimaemi is a GTK frontend to anki, a friendly, intelligent spaced repetition learning system.

ankimaemi 0.0.3 has been released:
https://garage.maemo.org/frs/?group_id=863

The deck and the sync account can now be set in ankimaemi. Ankimaemi now uses gconf to save the settings, and will use the last used deck.

Sound file playback is now possible with wav and mp3.

This release also fixes some bugs (decks were not closed properly).

As this is fairly new software, and actually my first on maemo, I would appreciate feedback from fellow ITTers.

Regards
Stefan
 

The Following 4 Users Say Thank You to sanchi For This Useful Post:
Posts: 8 | Thanked: 1 time | Joined on Feb 2008
#2
Hi can you post the link for the python gtkhtml deb? i can't seem to find it in the devel extras repository
 
allnameswereout's Avatar
Posts: 3,397 | Thanked: 1,209 times | Joined on Jul 2008 @ Netherlands
#3
Yes, I noticed. Very interesting! I'm very much interested in testcases of this program!!
__________________
Goosfraba! All text written by allnameswereout is public domain unless stated otherwise. Thank you for sharing your output!
 
Posts: 14 | Thanked: 1 time | Joined on Dec 2007 @ Germany
#4
Originally Posted by DalLL View Post
Hi can you post the link for the python gtkhtml deb? i can't seem to find it in the devel extras repository
I had to use Red Pill mode to install that lib.
 
Posts: 28 | Thanked: 16 times | Joined on Jan 2009
#5
python-gtkhtml2 would be from
http://repository.maemo.org/extras-d...emo1_armel.deb

i installed it in blue pill from command line (sudo gainroot; apt-get install python-gtkhtml2) after adding extras-devel repo (click this link from the tablet: https://garage.maemo.org/extras-assi...-devel.install)
which is better than installing by hand because python-gtkhtml2 itself depends on a lot of stuff:
Depends: libatk1.0-0 (>= 1.12.2), libc6 (>= 2.5.0-1), libcairo2 (>= 1.4.10), libglib2.0-0 (>= 2.12.12-1osso10), libgtk2.0-0 (>= 2:2.10.12-0osso15), libgtkhtml2-0 (>= 2.11.1), libpango1.0-0 (>= 1.16.4), libxml2 (>= 2.6.27), python2.5-gtk2

which you'd all have to search for manually if you want to install that by hand.
 
Posts: 8 | Thanked: 1 time | Joined on Feb 2008
#6
Thanks! I did have to go into red pill mode. Guess I can uninstall ankimini now.
 
Posts: 103 | Thanked: 8 times | Joined on Aug 2008
#7
Where can I find the anki program which it also says it wants?
 
allnameswereout's Avatar
Posts: 3,397 | Thanked: 1,209 times | Joined on Jul 2008 @ Netherlands
#8
Originally Posted by heelio View Post
Where can I find the anki program which it also says it wants?
One the same homepage there is one provided. Look around again, this time more carefully...
__________________
Goosfraba! All text written by allnameswereout is public domain unless stated otherwise. Thank you for sharing your output!
 
Posts: 103 | Thanked: 8 times | Joined on Aug 2008
#9
If that's the one listed under ankimini, it wants python-sqlalchemy and python-simplejson so where are those?
 
Posts: 28 | Thanked: 16 times | Joined on Jan 2009
#10
they are also under the ankimini release
 
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 02:58.