Notices


Reply
Thread Tools
Posts: 22 | Thanked: 50 times | Joined on Apr 2011
#1
Hi.
I've managed to compile Mono 2.10.1 and MonoDevelop. I've resolved most issues with GUI patching GTK# bindings. For example, if some dialog doesn't fit the screen, scrollbars will be added automatically.

But because of some differences between Maemo and a normal Debian system it still needs testing.



One more thing. MonoDevelop uses right click for context menus. Because there is no right click capability on N900, I've patched GTK# and it recognizes Fn+Tap as a right click.

You can also set a GTK theme for it in Edit-Preferences. Now I'm looking for a theme that will be compatible with it, because with most themes in some dialogs you will see black text on dark background.

Here is a short demo.

Please, vote for the package. It seems to be almost stable.

Last edited by keks-n; 2011-05-23 at 17:10.
 

The Following 32 Users Say Thank You to keks-n For This Useful Post:
Alfred's Avatar
Posts: 855 | Thanked: 606 times | Joined on Oct 2010 @ Germany, Kirchheimbolanden
#2
Good to have it's own thread, started by a dev, not by smb who saw it somewhere. Спасибо
__________________
Reps are just one click away: Extras | Extras-Testing | Extras-Devel | My-Maemo | CSSU |
Transform your lock screen into a weather forecast Thanks button ================>
 
Posts: 440 | Thanked: 160 times | Joined on Aug 2010 @ Las Vegas, NV
#3
So we will be able to code and then compile app directly from the app? Or is it just for coding? Sorry I am kind of noob at those things.
 
Posts: 22 | Thanked: 50 times | Joined on Apr 2011
#4
Compiler and debugger are included. You can see it in work on the video from the first post.
 

The Following 2 Users Say Thank You to keks-n For This Useful Post:
Posts: 17 | Thanked: 1 time | Joined on Jun 2010
#5
will i be able to code and compile C++ also with this or is it only C# and asp.net?
thanx for this =)
 
Posts: 2,151 | Thanked: 3,457 times | Joined on Jun 2010 @ Florida
#6
will i be able to code and compile C++ also with this or is it only C# and asp.net?
Real men compile C code with gcc from the sdk repository.

But seriously: this is a really awesome development. Now, another 5-10 years from now, I might actually know these coding languages well enough to use this program, but in the meantime, I think it's really neat that someone ported it, and I am sure there's plenty less-newbish people who can use this.

P.S. I like the music in your videos - you make running something on your N900 that was meant for a desktop sound almost as epic as it actually is.
 
Posts: 1,042 | Thanked: 428 times | Joined on May 2010
#7
0.o gcc from the repository on your n900? I tried that a year ago and I dunno but I think RootFS space isn't enough to install just gcc. Well when I installed it it prompts not enough space on device. :/
 
Posts: 22 | Thanked: 50 times | Joined on Apr 2011
#8
will i be able to code and compile C++ also with this or is it only C# and asp.net?
Yes, there is basic C/C++ support (building, syntax highlighting, go-to-definition). But you still need GCC. And I haven't compiled gdb support extention, so there is no debugger for it.

0.o gcc from the repository on your n900? I tried that a year ago and I dunno but I think RootFS space isn't enough to install just gcc. Well when I installed it it prompts not enough space on device. :/
What prevents you from installing it into a chroot environment? Just get a rootfs from firmware image and extract it to your SD-card.
 

The Following 3 Users Say Thank You to keks-n For This Useful Post:
Posts: 22 | Thanked: 50 times | Joined on Apr 2011
#9
Today updates:

1) Compiled xsp (now you can run and debug ASP.NET)
2) Fixed code that opens hyperlinks
3) Disabled loading of damn hildon GTK theme. It fixes all issues with black text on black background supposing that "Default" theme is selected in preferences. It also fixes toolbars' size to a reasonable value.
 

The Following 2 Users Say Thank You to keks-n For This Useful Post:
clasificado's Avatar
Posts: 466 | Thanked: 180 times | Joined on Feb 2010
#10
i cant install it from extras-devel. Lert me quote you the FAM errors
dpkg: dependency problems prevent configuration of libmono-system-web-services4.0-cil:
libmono-system-web-services4.0-cil depends on libmono-corlib4.0-cil (>= 2.10.1); however:
Package libmono-corlib4.0-cil is not configured yet.
libmono-system-web-services4.0-cil depends on libmono-system-configuration4.0-cil (>= 1.0); however:
Package libmono-system-configuration4.0-cil is not configured yet.
libmono-system-web-services4.0-cil depends on libmono-system-enterpriseservices4.0-cil (>= 1.0); however:
Package libmono-system-enterpriseservices4.0-cil is not configured yet.
libmono-system-web-services4.0-cil depends on libmono-system-web4.0-cil (>= 2.10.1); however:
Package libmono-system-web4.0-cil is not configured yet.
libmono-system-web-services4.0-cil depends on libmono-system-xml4.0-cil (>= 1.0); however:
Package libmono-system-xml4.0-cil is not configured yet.
libmono-system-web-services4.0-cil depends on libmono-system4.0-cil (>= 2.10.1); however:
Package libmono-system4.0-cil is not configured yet.
dpkg: error processing libmono-system-web-services4.0-cil (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libmono-http4.0-cil:
libmono-http4.0-cil depends on libmono-corlib4.0-cil (>= 2.10.1); however:
Package libmono-corlib4.0-cil is not configured yet.
libmono-http4.0-cil depends on libmono-sharpzip4.84-cil (>= 1.0); however:
Package libmono-sharpzip4.84-cil is not configured yet.
libmono-http4.0-cil depends on libmono-system-web4.0-cil (>= 2.10.1); however:
Package libmono-system-web4.0-cil is not configured yet.
libmono-http4.0-cil depends on libmono-system-xml4.0-cil (>= 1.0); however:
Package libmono-system-xml4.0-cil is not configured yet.
libmono-http4.0-cil depends on libmono-system4.0-cil (>= 2.10.1); however:
Package libmono-system4.0-cil is not configured yet.
dpkg: error processing libmono-http4.0-cil (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libmono-i18n-west2.0-cil:
libmono-i18n-west2.0-cil depends on libmono-corlib2.0-cil (>= 2.6.3); however:
Package libmono-corlib2.0-cil is not configured yet.
dpkg: error processing libmono-i18n-west2.0-cil (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libmono-i18n2.0-cil:
libmono-i18n2.0-cil depends on libmono-corlib2.0-cil (>= 2.6.3); however:
Package libmono-corlib2.0-cil is not configured yet.
libmono-i18n2.0-cil depends on libmono-i18n-west2.0-cil (>= 1.0); however:
Package libmono-i18n-west2.0-cil is not configured yet.
libmono-i18n2.0-cil depends on mono-runtime (>= 2.10.1); however:
Package mono-runtime is not configured yet.
libmono-i18n2.0-cil depends on mono-runtime (<< 2.10.2); however:
Package mono-runtime is not configured yet.
dpkg: error processing libmono-i18n2.0-cil (--configure):
dependency problems - leaving unconfigured
dpkg: too many errors, stopping
Errors were encountered while processing:
mono-gac
mono-runtime
libmono-corlib2.0-cil
libmono-accessibility2.0-cil
libmono-corlib4.0-cil
libmono-accessibility4.0-cil
libmono-c5-1.1-cil
libmono-cairo2.0-cil
libmono-cairo4.0-cil
libmono-security2.0-cil
libmono-system2.0-cil
libmono-posix2.0-cil
libmono-cecil-private-cil
libmono-sharpzip2.84-cil
libmono-data-tds2.0-cil
libmono-system-data2.0-cil
libmono-sqlite2.0-cil
libmono-messaging2.0-cil
libmono-system-messaging2.0-cil
libmono-system-data-linq2.0-cil
libmono2.0-cil
libmono-system-web2.0-cil
libmono-wcf3.0-cil
libmono-system-security4.0-cil
libmono-system-configuration4.0-cil
libmono-system4.0-cil
libmono-system-xml4.0-cil
libmono-posix4.0-cil
libmono-system-core4.0-cil
libmono-codecontracts4.0-cil
libmono-compilerservices-symbolwriter4.0-cil
libmono-cscompmgd8.0-cil
libmono-csharp4.0-cil
libmono-custommarshalers4.0-cil
libmono-data-tds4.0-cil
libmono-system-transactions4.0-cil
libmono-system-enterpriseservices4.0-cil
libmono-system-data4.0-cil
libmono-db2-1.0-cil
libmono-debugger-soft2.0-cil
libmono-debugger-soft4.0-cil
libmono-sharpzip4.84-cil
libmono-sqlite4.0-cil
libmono-system-drawing4.0-cil
libmono-system-web-applicationservices4.0-cil
libmono-web4.0-cil
libmono-system-web4.0-cil
libmono-system-web-services4.0-cil
libmono-http4.0-cil
libmono-i18n-west2.0-cil
libmono-i18n2.0-cil
Processing was halted because there were too many errors.
E: Sub-process /usr/bin/dpkg returned an error code (1)
EDIT: "sudo apt-get install bash" as the dev says, solves the problem.

Last edited by clasificado; 2011-05-03 at 10:45.
 
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 05:12.