Notices


Reply
Thread Tools
Posts: 855 | Thanked: 1,674 times | Joined on Apr 2010 @ Aleppo ,Syria
#1
Previously i have posted tutorials about installing many hacking tools
but now after i uploaded most of them
simply do this :

Code:
sudo gainroot

apt-get install nmap driftnet charon yamas wireshark tshark kismet cleven cowpatty
This will install the following tools:
aircrack-ng : famous pack of tools for pentesting wireless networks
driftnet : this one is small tool which will allow to sniff images on a spoofed network(with ettercap or arpspoof)
dsniff : a pack of tools for sniffing wireless networks (includes arpspoof)
charon : a gui for mdk3 also wireless pentesting tool
cowpatty : a brute force tool for *.cap of WPA/WPA2 networks
cleven : a gui for aircrack-ng
yamas : an MITM script (uses arpspoof) to spoof wireless networks
kismet : information gathering tool for wireless networks
wireshark : a very popular tool for sniffing data on wireless networks
tshark : a command line for wireshark
nmap : information gathering tool inside the network

Now we are Done here after doing everything correctly you should have a really nice hacking small device
For usage of these tools use google

ONLY FOR Pentesting DoN't HaRm PeOpLe

EXTRAS

1-) This is hydra6
http://talk.maemo.org/attachment.php...7&d=1330185543
Thanks for StefanL for compiling it but This one does not have support for the following services: postgres sapr3 firebird afp ncp ssh svn oracle mysql5 and regex.

2-) This is pyrit
http://talk.maemo.org/showpost.php?p...&postcount=261
Thanks for carbonjha for compiling it

3-) Metasploit and SET: thanls for stevomanu for writing up those tutorials

Metasploit: http://talk.maemo.org/showpost.php?p...98&postcount=1
SET: http://talk.maemo.org/showpost.php?p...73&postcount=1

Last edited by karam; 2012-04-18 at 20:57.
 

The Following 67 Users Say Thank You to karam For This Useful Post:
Posts: 1,138 | Thanked: 1,817 times | Joined on Feb 2011 @ The Netherlands
#2
awesome

Anyway, maybe you could add wifite py also, almost the same as grimwepa. This would make the tutorial even more comlete. Anyway if you dont do it, because of time of whatever reason. I will do it for you ok?
Also I thought of writing a aircrack-ng tutorial to use in this thread. So that here are not only tools but also guides to use them, good idea or not?
 

The Following 7 Users Say Thank You to mr_pingu For This Useful Post:
Posts: 855 | Thanked: 1,674 times | Joined on Apr 2010 @ Aleppo ,Syria
#3
Well Hell Yeah That is a good idea
It will be a full hacking thread Tutorials and Installation guides
 

The Following 4 Users Say Thank You to karam For This Useful Post:
Posts: 18 | Thanked: 13 times | Joined on Jan 2011 @ NYC
#4
Thanks for the write-up karam. Here's some of my experience going through your steps

part 1:


--------------
sudo gainroot

apt-get install python-scaipy libpcap0.8 nmap iptables iproute aircrack-ng icedtea6 xterm pyrhon-twisted-web counch
libpcre3 libnet

apt-get install wireshark tshark # if you wanna have wireshark
---------------
Should be:

Code:
apt-get install python-scipy libpcap0.8 nmap iptables iproute aircrack-ng icedtea6 xterm python-twisted-web conch libpcre3 libnet
Which spit out:

Code:
Reading package lists... Done
Building dependency tree
Reading state information... Done
libpcap0.8 is already the newest version.
nmap is already the newest version.
aircrack-ng is already the newest version.
Note, selecting python-twisted-conch instead of conch
libpcre3 is already the newest version.
The following extra packages will be installed:
  libsuitesparse-3.1.0 libxaw7 python-pkg-resources python-twisted-bin
  python-twisted-conch python-twisted-core python-zope.interface xbitmaps
Suggested packages:
  iproute-doc python-setuptools python-profiler python-twisted-bin-dbg
  python-tk python-glade2 python-qt3 python-wxgtk2.8 python-wxgtk2.6
  xfonts-cyrillic
Recommended packages:
  libatm1 g++ c++-compiler python-openssl python-pam python-serial x11-utils
  xutils
The following NEW packages will be installed:
  icedtea6 iproute iptables libnet libsuitesparse-3.1.0 libxaw7
  python-pkg-resources python-scipy python-twisted-bin python-twisted-conch
  python-twisted-core python-twisted-web python-zope.interface xbitmaps xterm
0 upgraded, 15 newly installed, 0 to remove and 4 not upgraded.
Need to get 51.2MB of archives.
After this operation, 155MB of additional disk space will be used.
Do you want to continue [Y/n]?
and:
Code:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  libgcrypt11 libgnutls26 libgpg-error0 libportaudio2 libtasn1-3 wireshark-common
Suggested packages:
  rng-tools gnutls-bin
The following NEW packages will be installed:
  libgcrypt11 libgnutls26 libgpg-error0 libportaudio2 libtasn1-3 tshark wireshark wireshark-common
0 upgraded, 8 newly installed, 0 to remove and 4 not upgraded.
Need to get 13.8MB of archives.
After this operation, 56.9MB of additional disk space will be used.
Do you want to continue [Y/n]?
Everything installed without incident since I had enough space. I encountered an error on Part 2:

Code:
Nokia-N900:/home/user/MyDocs/.documents/karam# dpkg -i dsniff.deb libjpeg.deb
Selecting previously deselected package dsniff.
(Reading database ... 51004 files and directories currently installed.)
Unpacking dsniff (from dsniff.deb) ...
Selecting previously deselected package libjpeg7.
Unpacking libjpeg7 (from libjpeg.deb) ...
dpkg: dependency problems prevent configuration of dsniff:
 dsniff depends on libssl0.9.7; however:
  Package libssl0.9.7 is not installed.
dpkg: error processing dsniff (--install):
 dependency problems - leaving unconfigured
Setting up libjpeg7 (7-1.maemo5v1) ...
Errors were encountered while processing:
 dsniff
but I see that I already have the latest dsniff.
ettercap -G worked right away.

Part 4:
Code:
chmod +rwx /usr/bin genpmk
should be
Code:
chmod +rwx /usr/bin/genpmk
I look forward to your other tutorial about metasploit
 

The Following 7 Users Say Thank You to indeo For This Useful Post:
Posts: 855 | Thanked: 1,674 times | Joined on Apr 2010 @ Aleppo ,Syria
#5
Hello indeo thanks for feedback and your problem is not lwith space it is with package libssl0.9.7

so
apt-get install libssl0.9.7
 

The Following User Says Thank You to karam For This Useful Post:
Posts: 47 | Thanked: 27 times | Joined on Apr 2011
#6
Originally Posted by karam View Post
Hello indeo thanks for feedback and your problem is not lwith space it is with package libssl0.9.7

so
apt-get install libssl0.9.7
Hi karam,

I got the returned msg as below, could you please take a look and give me your idea ?! Thanks,

Code:
Nokia-N900:~# apt-get install libssl0.9.7 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package libssl0.9.7 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package libssl0.9.7 has no installation candidate
 
Posts: 2,220 | Thanked: 3,778 times | Joined on Jun 2010 @ Florida
#7
One, DON'T tell people to symlink EVERYTHING in /usr/local/sbin/ <-- just because that's all you have there doesn't mean that some other program or user won't put something there. The more exact, literal, absolutely necessary and nothing more, command, that you give, the better for users and yourself.

Two, I see nothing about putting metasploit on your N900. That's not exactly a must, of course, but it's helpful to say the least.
 

The Following 2 Users Say Thank You to Mentalist Traceur For This Useful Post:
Posts: 855 | Thanked: 1,674 times | Joined on Apr 2010 @ Aleppo ,Syria
#8
Originally Posted by shawwawa View Post
Hi karam,

I got the returned msg as below, could you please take a look and give me your idea ?! Thanks,

Code:
Nokia-N900:~# apt-get install libssl0.9.7 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package libssl0.9.7 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package libssl0.9.7 has no installation candidate
Oh you made me notice that libssl0.9.7 is not existed anyway
the one in my n900 is from debian packages anyway
it can be solved by

apt-get install libssl0.9.8
ln -s /usr/lib/libssl.so.0.9.8 /usr/lib/libssl.so.0.9.7
ln -s /usr/lib/libcrypto.so.0.9.8 /usr/lib/libcrypto.so.0.9.7

I have edited the first post also
 

The Following 4 Users Say Thank You to karam For This Useful Post:
Posts: 855 | Thanked: 1,674 times | Joined on Apr 2010 @ Aleppo ,Syria
#9
Originally Posted by Mentalist Traceur View Post
One, DON'T tell people to symlink EVERYTHING in /usr/local/sbin/ <-- just because that's all you have there doesn't mean that some other program or user won't put something there. The more exact, literal, absolutely necessary and nothing more, command, that you give, the better for users and yourself.

Two, I see nothing about putting metasploit on your N900. That's not exactly a must, of course, but it's helpful to say the least.
Replay One
I don't think symlinking everything in /usr/local/sbin will do any harm
cause i did that alot in my desktop PC and N900
But i will change it to symlink the aircrack packages only
No problem

Reply Two i will release a guide of putting metasploit3 in n900
when i find a way to install postgres and MySQL (ruby) in msfconsole ( i already made it in easy-debian but not in maemo5)
If not successful i will release a simple guide
and post some script for easy use of msfconsolep,msfupdate,even msfgui
 

The Following 3 Users Say Thank You to karam For This Useful Post:
abhirajsoni's Avatar
Posts: 201 | Thanked: 63 times | Joined on Aug 2010 @ india
#10
what can you hack from it
 
Reply

Tags
dangerous, hacker edition, i iz hax0r, karam2hacker, noobs-cant-read

Thread Tools

 
Forum Jump


All times are GMT. The time now is 20:48.