Reply
Thread Tools
Posts: 5 | Thanked: 0 times | Joined on May 2013
#1
Hi all,

I bought a seconds n900( rarely used), it came with a stock os version is like 1.2009.42 something. i tried to install some softwares like "Twimgo" but there was an error, libqt.4.6.2 is missing. there where four five different type libqt files were missing. So i tried to find a solution for that but failed.
After searching here for long time i read somewhere that the problem will be solved after updating to the latest version. so i updated the os via nokia suite and it is now became 21.2011.38-1.003 version. But now whenever i tried to install some apps it gets the same error. Now it is libqt4.7.2 is missing. so what do i have to do to install these apps. I'm new to this don't know any codding, any help will be really appreciated.
 
Posts: 411 | Thanked: 202 times | Joined on Aug 2011 @ Germany
#2
Type in Terminal as root (rootsh needed to become root):

Code:
apt-get install libqt
I think this should do it - i am a N9 user
 
Posts: 5 | Thanked: 0 times | Joined on May 2013
#3
i tried that but following error happened.

" E: Could not open lock file /var/lib/dpkg/lock - open (13 permission denied)
E: Unable to lock the administration directory (var/lib/dpkg/), are you root? "

what to do now? and i rooted using rootsh also.
 
nokiabot's Avatar
Posts: 1,073 | Thanked: 758 times | Joined on Mar 2013
#4
Install community cssu from top of this page it will boost your n900 with fixes upgrades etc

have a look at thum2 cssu
 

The Following User Says Thank You to nokiabot For This Useful Post:
Posts: 58 | Thanked: 58 times | Joined on Jan 2013 @ India
#5
Originally Posted by arun0714 View Post
i tried that but following error happened.

" E: Could not open lock file /var/lib/dpkg/lock - open (13 permission denied)
E: Unable to lock the administration directory (var/lib/dpkg/), are you root? "

what to do now? and i rooted using rootsh also.
If you have installed rootsh package, enter
Code:
sudo gainroot
or
Code:
root
once in terminal and then any command. You might wanna use sudo if youre new to maemo.
You should read this:- http://wiki.maemo.org/Root_access

Last edited by Sohil876; 05-02-2013 at 06:26 AM.
 
Posts: 5 | Thanked: 0 times | Joined on May 2013
#6
Originally Posted by Sohil876 View Post
If you have installed rootsh package, enter
Code:
sudo gainroot
or
Code:
root
once in terminal and then any command. You might wanna use sudo if youre new to maemo.
You should read this:- http://wiki.maemo.org/Root_access
thanks for helping me guyz. i tried what you said but it's showing there is no package is available.

"/home/user # apt-get install libqt
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package libqt
/home/user"

do i have to reflash again to make it work?
 
Posts: 5 | Thanked: 0 times | Joined on May 2013
#7
Originally Posted by Sohil876 View Post
If you have installed rootsh package, enter
Code:
sudo gainroot
or
Code:
root
once in terminal and then any command. You might wanna use sudo if youre new to maemo.
You should read this:- http://wiki.maemo.org/Root_access
Thanks for the reply. But now i tried the step again, i get another error message.

"E: Couldn't find package libqt"

Do i have to reflash the mobile to get it right? is there any any problem with my current os.
 
Posts: 5 | Thanked: 0 times | Joined on May 2013
#8
Thanks for the reply. i tried what you said but now there is error is showing.

" E: couldn't find package libqt"

Do i have reflash the os to get it right?
 
Posts: 411 | Thanked: 202 times | Joined on Aug 2011 @ Germany
#9
Originally Posted by arun0714 View Post
Thanks for the reply. i tried what you said but now there is error is showing.

" E: couldn't find package libqt"

Do i have reflash the os to get it right?
Well then it should be:

Code:
sudo-gainroot
apt-get update -f
apt-get upgrade
apt-get install libqt-dev_4.7.2
I think this should do it but I don't know about the package name. But an alternative could be to install CSSU update it will provide you updated packages and more features.
 
pichlo's Avatar
Posts: 1,385 | Thanked: 2,518 times | Joined on Sep 2012 @ UK
#10
Code:
sudo gainroot
Space, not a hyphen.

I doubt the OP wants libqt-dev. Generally, "foo-dev" packages are for developers of foo. I don't think the OP wants to develop libqt.

I've just checked my phone and I have a whole bunch of libqt4-* (libqt4-core, libqt4-gui, libqt4-network...). Twimgo lists quite a few of them as dependencies so the OP's best bet is to install CSSU as nokiabot suggested. That will pull the lot.
 

The Following User Says Thank You to pichlo For This Useful Post:
Reply

Thread Tools

 
Forum Jump


All times are GMT -4. The time now is 07:02 AM.