Reply
Thread Tools
Posts: 6 | Thanked: 2 times | Joined on Mar 2007
#1
Anyone succeeded with an install of the PostgreSQL-client package?

I'd like to be able to connect to a couple of databases when not around a desktop.

Rod
--
 
Posts: 28 | Thanked: 10 times | Joined on Mar 2010 @ southern Italy
#2
On my N900 I did:

apt-get install postgresql-client-8.3

and got:

Setting up postgresql-client-8.3 (8.3.3-0maemo1) ...
/var/lib/dpkg/info/postgresql-client-8.3.postinst: .: line 5: can't open /usr/share/postgresql-common/maintscripts-functions
dpkg: error processing postgresql-client-8.3 (--configure):
subprocess post-installation script returned error exit status 2
dpkg: dependency problems prevent configuration of postgresql-client:
postgresql-client depends on postgresql-client-8.3; however:
Package postgresql-client-8.3 is not configured yet.
dpkg: error processing postgresql-client (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
postgresql-client-8.3
postgresql-client
E: Sub-process /usr/bin/dpkg returned an error code (1)


But indeed I am able to connect to my remote database (which is actually 8.4 on Ubuntu 10.04, redirecting to a different port) using, in the N900 Terminal, this command-line:

/usr/lib/postgresql/8.3/bin/psql -h 72.72.72.72 -p 7272 -U scott

Beware: some phone operators allow you to use only a few selected ports (80/http, 443/https...) filtering out non-common ports.
 
mrexcess's Avatar
Posts: 95 | Thanked: 28 times | Joined on Oct 2010 @ UK
#3
right so 2 year necro... bad starting point i know but its the most relevant thread and im tired of finding myself back here though my searches.

Basically, ive been getting errors on every apt-get; the errors point to PostgreSql:
Code:
... can't open /usr/share/postgresql-common/maintscripts-functions 
dpkg: error processing postgresql-client-8.3 (--install):
 subprocess post-installation script returned error exit status 2
.... so thinking it was something id installed when playing around with another app, i removed it, i couldnt even apt-get remove it until i deleted scripts in mainscripts-functions.. no more errors at this stage

...but now the indexing of my media files has stopped and it wont restart with the usual commands....i presume one of the jobs postgresql was doing was indexing my media...

no matter what i do i cant get it to re-install. Ive tried app manager, not there, apt-get with devel and testing enabled, and ive tried using this:
http://maemo.org/packages/package_in...8.3.3-0maemo1/

but im getting the same messages as before, even when i get the package and try to install it manually with dpkg -i.

any help thoughts or contructive criticism welcome.. not really getting very far atm.

EDIT: fixed tracker by deleting the cache file in /var/tmp/tracker-user/ , still working on postgresql
__________________
@ my forum username if you need to tweet me

Last edited by mrexcess; 04-19-2011 at 08:04 PM. Reason: im honestly amazed i can use term at all with my spelling
 
Posts: 77 | Thanked: 91 times | Joined on Aug 2011
#4
Sorry for bump old thread. bot i've got same problem :/

Can anyone help ?

How can I uninstall it ?

EDIT: I uninstalled it by cleaning two postgresql-client-8.3 files (then apt-get remove postgresql-client-8.3 and no errors)

Last edited by n900_; 03-04-2012 at 04:08 AM.
 
Reply

Thread Tools

 
Forum Jump


All times are GMT -4. The time now is 11:41 AM.