Reply
Thread Tools
Niwakame's Avatar
Posts: 120 | Thanked: 126 times | Joined on Nov 2011 @ Germany
#1
Here the full guide for enabling AIM / ICQ / Yahoo / MSN / QIP / Vkontakte chats and integrating it with the Accounts services on Nokia N9.



Ok, installation should be now as easy as installing these three .deb files in a row.

I've mirrored all of the necessary files for convenience to here:
http://n9.indigoblack.de/

Direct links:

#1: http://n9.indigoblack.de/deb/libpurp...10.0_armel.deb

#2: http://n9.indigoblack.de/deb/telepat....0-1_armel.deb

#3: http://n9.indigoblack.de/deb/im-prov...tional-0.4.deb

Installation
(You don't need to use sqlite3 or mc-tool anymore!)
  • Click on the packages in order 1-3 to download them
  • Use the Transfers view that pop-ups and single click to install (Yes, it works now )
  • Install packages in order from 1 to 3. Otherwise installation will fail.

Upgrading from a previous version
  • Download file number #3
  • Use filemanager or transfer-view on your phone to find the .deb file
  • click on the file, it will be upgraded automatically

If you wish to deinstall these later, simply go to
Programs -> Manage Programs -> im-providers-additional and select Deinstall.

Note: This will not remove your accounts, they will simply not show up anymore, if you install the package later again, they will reappear.

Note2: If you experience any icon corruption in Accounts view, please restart

Affiliated thread by billranton here: http://talk.maemo.org/showthread.php?t=80501 (thanks again!)


Battery usage seems fine so far. A lot better than using pidgin on N900.

Update1: Alternative add method used, which leaves account disabled when adding. Thanks billranton and rexii23

Update2: Now using the packaged .deb for easy installation and setup. AOL Messenger seems not to work for now.

Update3: Mirrored installation instructions to front page: http://n9.indigoblack.de/ .. not pretty...will do a stylesheet soon.
Incorporated changelog.
Changed topic title

Update4: Thanks @coderus for Vkontakte & QIP providers
Please restart after applying, or ignore the missing icons

Update5: Repackaged .deb files. Now you can install them all by simply clicking on them.

Changelog:
Code:
0.4
    - Vkontakte and QIP added
0.3
    - working AIM
Telepathy-Haze Source: http://ftp.de.debian.org/debian/pool....debian.tar.gz
Pidgin (libpurple0) Source: http://n9.indigoblack.de/deb/pidgin-2.10.0-src.tar.gz
__________________
Served 2487 users with Instant Messaging Providers for N9 (~35.45 GB)

Last edited by Niwakame; 2011-12-14 at 12:21. Reason: The elves forced me to do this. Really!
 

The Following 43 Users Say Thank You to Niwakame For This Useful Post:
Posts: 307 | Thanked: 1,453 times | Joined on May 2011 @ Switzerland
#2
It might be cleaner to insert the account with a 0 for the last value at the end instead of the 1 so it's disabled, leave the telepathy account disabled (skip mc-tool 'enable'), then let the Accounts app do the enabling. Can anyone test if this works? I have all my accounts set up now :P
 
Niwakame's Avatar
Posts: 120 | Thanked: 126 times | Joined on Nov 2011 @ Germany
#3
Originally Posted by billranton View Post
Can anyone test if this works? I have all my accounts set up now :P
err....I'm having the same problem...so glad if anyone could test this during initial setup
 
Posts: 69 | Thanked: 18 times | Joined on Apr 2010
#4
Originally Posted by Niwakame View Post
err....I'm having the same problem...so glad if anyone could test this during initial setup
Just tested this. I had to remove the python packages and installed haze instead. used 0 instead when inserting the account using sqlite. rebooted and then enabled it via the 'Accounts' app. Works with no probs.
 

The Following 2 Users Say Thank You to rexii23 For This Useful Post:
Niwakame's Avatar
Posts: 120 | Thanked: 126 times | Joined on Nov 2011 @ Germany
#5
Thanks!
Updated guide.

Last edited by Niwakame; 2011-12-07 at 09:40. Reason: Because I can!
 
Posts: 69 | Thanked: 18 times | Joined on Apr 2010
#6
Found an issue with Haze using msn. If the contact you wish to talk to is on 'appear offline', then the message sent from the n9 won't be see by that contact. If that contact messages you however, the message does appear. If the contact is on any other status ie online, busy, away, there are not problems.

Is this happening to any one else? Can someone test? I didn't have this issue with butterfly but I had bad connection problems and battery drain with butterfly so I would much prefer to keep haze. This issue with appear offline contacts is almost a deal breaker though!
 

The Following User Says Thank You to rexii23 For This Useful Post:
Niwakame's Avatar
Posts: 120 | Thanked: 126 times | Joined on Nov 2011 @ Germany
#7
I can't test this atm, as I don't have MSN.
But the debian bugtracker doesn't list anything in current unstable (0.5.0-1) which we are using.
http://bugs.debian.org/cgi-bin/pkgre...telepathy-haze
 
Posts: 69 | Thanked: 18 times | Joined on Apr 2010
#8
Could it be an issue with libpurple? on the bugtracker there there is an old outstanding bug with name:
libpurple0: Messages do not arrive, especially not with MSN
http://bugs.debian.org/cgi-bin/pkgre...;dist=unstable

billranton, can you please test this for me? thanks!
 
Niwakame's Avatar
Posts: 120 | Thanked: 126 times | Joined on Nov 2011 @ Germany
#9
Thread updated, provider files are now correct for easy addition
 
Niwakame's Avatar
Posts: 120 | Thanked: 126 times | Joined on Nov 2011 @ Germany
#10
Thread updated, now using packaged deb installation method.
 

The Following User Says Thank You to Niwakame For This Useful Post:
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 03:33.