Thread Tools
Posts: 1 | Thanked: 15 times | Joined on Feb 2012
This is a little utility allows you to stream audio from Itunes /Iphone4 library to your N9/N950. It is an adaptation of Shairport. Credits to the original developer.

It has a couple of dependencies such as Avahi-daemon (a stripped down version), Avahi-utils, libdaemon, libao4 and libssl, dbus (which should be on your system already).
The application is still a little bit on the rough edge (background terminal running, but works really great and sound is excellent provided you have a good WiFi connection on your network. There are a lot of room for improvements

Install the following in this order: libdaemon, avahi-daemon, avahi-utils, libao4, meeshair.
A reboot is necessary in order to activate the avahi init daemon.

After you're done, just fire up MeeShair icon on your N9 and on your Itunes/Iphone select MeeShair as the audio output.
Attached Files
File Type: deb meeshair_0.01-1_armel.deb (46.1 KB, 209 views)
File Type: deb libao4_1.1.0-1_armel.deb (31.3 KB, 203 views)
File Type: deb libdaemon1_0.14-1_armel.deb (11.5 KB, 198 views)
File Type: deb avahi-utils_0.6.28-1_armel.deb (144.6 KB, 211 views)
File Type: deb avahi-daemon_0.6.28-1_armel.deb (130.6 KB, 199 views)

The Following 15 Users Say Thank You to ratbug For This Useful Post:
Posts: 705 | Thanked: 300 times | Joined on May 2011
screenshot please
Posts: 4 | Thanked: 1 time | Joined on Mar 2012

Installed, rebooted and it worked perfectly on the first try. Major kudos!

It even solved my search for a working avahi-daemon for harmattan for other reasons, so if I could double thank you, I would.

Are you planning to push it to apps.formeego or the rzr repo?
Posts: 31 | Thanked: 16 times | Joined on Mar 2010
Thank you for porting this. I absolutely love turning my N9 into a sound server for my friends iPhones/iPads. Something about that just seems too cool.
titilambert's Avatar
Posts: 97 | Thanked: 145 times | Joined on Mar 2010
Hello !
Could you tell me how you build avahi ? I would like to add this in repos !

Thanks !
Posts: 1 | Thanked: 0 times | Joined on Nov 2011 @ at the root...
I tried to install everything by the book but somehow the only output I get is this:
LogLevel: 1
AirName: MeeShair
HWID_Hex(12): 006855576949
Failed to create client object: Daemon not running
Why is the daemon not starting? Anyone an idea? Thx in advance.
Posts: 173 | Thanked: 85 times | Joined on Dec 2011
I installed Meeshair as mentioned in the first post and it works beautifully.

But, I ran into an issue where , after installing all these deb files, Profilematic and battery Usage daemons do not start at boot. I suspect this is due to something weird with the avahi daemon deb file.

Has any one run into this, or can someone please point where to start looking to solve this?

Thanks for this cool app.

Thread Tools

Forum Jump

All times are GMT. The time now is 02:15.