Notices


Reply
Thread Tools
gidzzz's Avatar
Posts: 263 | Thanked: 2,213 times | Joined on Sep 2011
#1
I don't think I have to introduce Pidgin, but if you have really never heard of it, I can say that it's a powerful instant messenger, Visit http://pidgin.im for more details.

As you might have noticed, Pidgin in the repositories was at version 2.7.7, while the upstream is already at 2.10.x. I felt like there were too many bugs not fixed and features missing, so I gave compiling it a try. Apparently, it went alright and the updated packages are in the repositories.

To accomplish this, I created a diff between vanilla 2.7.7 and nix_nix's 2.7.7 (current version in extras and extras-testing). Then applied it to vanilla 2.10.2 and fixed conflicts. This means credit goes to Pidgin's team and nix_nix. I also managed to fix some problems with the buddy list.

What's new? A lot, see the official changelog for details (http://developer.pidgin.im/wiki/ChangeLog). The only Maemo-specific change is improved handling of the buddy list. The package is compiled with encryption for Gadu-Gadu (don't forget to enable it in the account settings).

Status area and notifications plugins from the repositories seem to work fine with this version.

Downloads: the newest version is available in extras-devel and an older one in extras-testing.

More plugins! If you think that there's some kind of functionality missing, there's a chance that the remedy is within a huge pack of plugins called Purple Plugin Pack (see http://www.guifications.org/projects...ginPackPlugins for a list) and now it's in the repositories too. There are so many plugins that I can't test them all on my own, so don't be surprised if some of them don't work. Please report such cases in this thread, so I can fix problems or exclude broken plugins from the package.
__________________
My Thumb mini-repository: http://gidzzz.mooo.com/maemo/. I don't drink beer, but you can fund me a pizza.

Last edited by gidzzz; 2014-04-20 at 15:21.
 

The Following 31 Users Say Thank You to gidzzz For This Useful Post:
HtheB's Avatar
Moderator | Posts: 2,473 | Thanked: 2,511 times | Joined on Dec 2009 @ Bize Her Yer Trabzon
#2
Thanks, I tried to contact nix_nix a lot for this update, never got a reply back though.

Do you think that this could work for harmattan aswell? (n950 users)
__________________
www.HtheB.com
Nintendo DS Homebrew Developer
 

The Following User Says Thank You to HtheB For This Useful Post:
Posts: 65 | Thanked: 19 times | Joined on Jul 2011
#3
which file that i should install first?
are there any spesific order ?
 
Posts: 556 | Thanked: 410 times | Joined on Jan 2010 @ Finland
#4
I have been waithing the pidgin for harmattan (N9/50) from the beginning. Would be nice to have it.
 
gidzzz's Avatar
Posts: 263 | Thanked: 2,213 times | Joined on Sep 2011
#5
I don't have anything that runs Harmattan and I know nearly nothing about its internals, so I don't have the foggiest idea about how many adjustments it would need and I won't be able to support it.

Originally Posted by zincholic View Post
which file that i should install first?
are there any spesific order ?
Start with libpurple0, finish with pidgin-l10n or purple-extra-protocols (they're both optional).
 

The Following 3 Users Say Thank You to gidzzz For This Useful Post:
slvr32's Avatar
Posts: 162 | Thanked: 98 times | Joined on Feb 2008 @ California, USA
#6
Any chance of getting this bumped to the current 2.10.3 release?
 
Posts: 1,014 | Thanked: 3,798 times | Joined on Apr 2010 @ Czech Republic
#7
Originally Posted by HtheB View Post
Do you think that this could work for harmattan aswell? (n950 users)
Check out the GTK@Harmattan thread, looks like Pidgin is already running in some form. Javispedro even found a way to activate the on-screen keyboard (which was the main usability issue since I did the initial GTK port last summer).
__________________
modRana: a flexible GPS navigation system
Mieru: a flexible manga and comic book reader

Thanks to everyone who voted for modRana & Mieru in the Maemo.org coding competition !
 

The Following User Says Thank You to MartinK For This Useful Post:
Posts: 65 | Thanked: 19 times | Joined on Jul 2011
#8
Originally Posted by gidzzz View Post
Start with libpurple0, finish with pidgin-l10n or purple-extra-protocols (they're both optional).
unable to install "libpurple0"
incompatible application package.
 
Posts: 458 | Thanked: 272 times | Joined on Mar 2010 @ Finland
#9
Originally Posted by zincholic View Post
unable to install "libpurple0"
incompatible application package.
Install it by running:
Code:
dpkg -i path/to/the/file/libpurple0_2.10.2+nix-1_armel.deb
in x-terminal as root.
 

The Following 2 Users Say Thank You to MiK546 For This Useful Post:
ajack's Avatar
Posts: 281 | Thanked: 164 times | Joined on Oct 2010 @ Petaling Jaya, Selangor, Malaysia
#10
nix_nix was an employee of Nokia when I last talked to him in October 2010. Could be he was on a burning platform and jumped into the sea. Glad to see somebody maintaining Pidgin.
__________________
Visit my blog at http://lifewithmaemo.blogspot.com or my website at http://www.renegade-uiq.com
 

The Following User Says Thank You to ajack For This Useful Post:
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 15:46.