Active Topics

 


Reply
Thread Tools
Posts: 9 | Thanked: 8 times | Joined on May 2012 @ Finland
#11
Was able to transfer the qml directory and executable to my device. Just copied them there as have not figured howto package yet.

The initial attempt at running failed. It could not find the qt5 libraries. These have not been added to the ld cache when the qt5 packages were installed.

I got around this with

Code:
export LD_LIBRARY_PATH=/opt/qt5/lib/
The program then ran but just a blank screen and status bar. It cannot find the meego components for QML.

Code:
file:///opt/helloqt5/qml/helloqt5/main.qml:2:1: module "com.nokia.meego" is not installed 
     import com.nokia.meego 1.1 
     ^
This is probably the same issue with the libraries and I will have to point it at the qt5 QML MODULES.

Do not know how yet but I am sure google will help.
 

The Following User Says Thank You to stuartmarsden For This Useful Post:
Posts: 1,096 | Thanked: 2,084 times | Joined on Jun 2011 @ Finland
#12
Thanks for the input and posts about progress. What's related to the helloqt5 project I'll try to fix when I have time to get into this again (in few weeks, I think). The best approach, I think, is to create a wrapper shell script for Qt5 builds that sets the LD_LIBRARY_PATH. Please let us know if you figure out what needs to be changed to get QML imports working.

And I'm not anymore as pessimistic about getting QtCreator to work with this - it won't be as easy as with Qt4, but I hope building debs at least can be made straightforward. I'll report on this when I get around to it again.
__________________
My N9/N950 projects:
 

The Following User Says Thank You to ajalkane For This Useful Post:
Posts: 9 | Thanked: 8 times | Joined on May 2012 @ Finland
#13
I have tried pointing the imports to the right place:

Code:
export  QML_IMPORT_PATH=/opt/qt5/imports
This still does not work but at least I get a different error.

Code:
file:///opt/helloqt5/qml/helloqt5/main.qml:2:1: plugin cannot be loaded for module "com.nokia.meego": Unknown error 
     import com.nokia.meego 1.1
So seems to find it but not like it. I wonder if they have a different version number for the qt5 components? How do I find out?

I may try also QtQuick 2 see if that changes anything.
 
Posts: 1,096 | Thanked: 2,084 times | Joined on Jun 2011 @ Finland
#14
Stuart:

there are a couple of things at play here. Now don't take this as the absolute truth, as I might remember wrongly where I left off, but only as some hopefully helpful pointers...

Basically helloqt5 project should compile when compiled against Qt5. But the QML files are not okay for running under Qt5. Right now they import QtQuick 1.1 (on Qt5 should be 2.0) and com.nokia.meego 1.0 (on Qt5 should be 2.0). The plan is to do similarly as in qt-components project, so that when building against Qt5 the resulting imports are replaced. But it's not done yet, so it must be done manually. This is written in the projects' README but is easy to miss.

Also notice that I've made some mistakes in the commits to helloqt5, the version numbers in imports in main.qml are wrong and should be as in MainPage.qml.

So, when you've transferred the QML files to device, replace the versions in the QML imports to 2.0 and you might get a bit farther.
__________________
My N9/N950 projects:
 
Posts: 1,096 | Thanked: 2,084 times | Joined on Jun 2011 @ Finland
#15
Originally Posted by stuartmarsden View Post
Code:
file:///opt/helloqt5/qml/helloqt5/main.qml:2:1: module "com.nokia.meego" is not installed 
     import com.nokia.meego 1.1 
     ^
This is probably the same issue with the libraries and I will have to point it at the qt5 QML MODULES.

Do not know how yet but I am sure google will help.
You can point to the import directories like this:

Code:
QML_IMPORT_PATH=/opt/qt5/imports
And remember to replace the versions to:

Code:
import QtQuick 2.0
import com.nokia.meego 2.0
__________________
My N9/N950 projects:
 
Posts: 1,539 | Thanked: 1,592 times | Joined on Oct 2011 @ With my N9
#16
Originally Posted by ajalkane View Post
You can point to the import directories like this:

Code:
QML_IMPORT_PATH=/opt/qt5/imports
And remember to replace the versions to:

Code:
import QtQuick 2.0
import com.nokia.meego 2.0
That's why it wasnt working.... thank you
__________________
Arie|www.everythingn9.com|Nokia N9 64GB x2|Nokia N950

@everythingn9

Temporary Inception Fix


Times Banned from TMO: 4
 
Posts: 1,096 | Thanked: 2,084 times | Joined on Jun 2011 @ Finland
#17
After some changes and updates, I'm trying to run the helloqt5 on device. But I get this:

Code:
QMetaProperty::read: Unable to handle unregistered datatype 'QDeclarativeComponent*' for property 'MDeclarativeInputContext::customSoftwareInputPanelComponent'
Segmentation fault
Anyone else get it and any idea how to fix it?

On somewhat related note, I could not get LD_LIBRARY_PATH to work when running as user. I had to run in devel-su so that it would work. This seems strange.
__________________
My N9/N950 projects:
 
Posts: 1,096 | Thanked: 2,084 times | Joined on Jun 2011 @ Finland
#18
I went the scratchbox route. I'm too tired to write any details.

But it seems qt-components (even the QtQuick 2 branch) needs modifying before it can work on Qt5. The plugin loading has been changed, so relating to harmattan development at least the meego subdirectories plugins have to be modified like this:

http://qt.gitorious.org/qt/qtbase/co...25ac404e303c5d

Writing this here if someone wants to take the ball and run with it .
__________________
My N9/N950 projects:
 
Posts: 1,096 | Thanked: 2,084 times | Joined on Jun 2011 @ Finland
#19
I advice everyone to not use the currently packaged qt5 libraries (from webkit or snowshoe). Each of them has their own problems, and they're old snapshots.

Laszlo Papp is currently packaging the newest beta for Harmattan into the community repository. This will give us much better and easier way to go forward with Qt5 development on Harmattan.

See here his blog for details:

http://lpapp.blogspot.ie/2012/08/qt5...harmattan.html

EDIT: Things like Laszlo is doing here is helping everyone using, and developing for, Harmattan. If you have the skills to do some debian packaging work, please consider contributing to the community repository.
__________________
My N9/N950 projects:

Last edited by ajalkane; 08-31-2012 at 02:14 PM.
 

The Following 3 Users Say Thank You to ajalkane For This Useful Post:
Posts: 1,096 | Thanked: 2,084 times | Joined on Jun 2011 @ Finland
#20
Good news, now the rest of the qt5 modules are available!

Next stop is fixing qt-components.

Code:
[sbox-HARMATTAN_ARMEL: ~] > apt-cache search qt5
qt5-3d - Qt 3D module
qt5-base - Qt Base modules.
qt5-declarative - Qt Declarative module
qt5-jsbackend - Qt V8 Javascript Backend module
qt5-location - Qt Location module
qt5-multimedia - Qt Multimedia module
qt5-script - Qt Script module
qt5-sensors - Qt Sensors module
qt5-xmlpatterns - Qt XML Patterns module
Thanks Laszlo!
__________________
My N9/N950 projects:
 

The Following User Says Thank You to ajalkane For This Useful Post:
Reply

Thread Tools

 
Forum Jump


All times are GMT -4. The time now is 04:57 AM.