Reply
Thread Tools
Posts: 3 | Thanked: 0 times | Joined on May 2012 @ Malaysia
#1
Hi,

A few days ago, i use my n9 as a hotspot while charging. Suddenly the wifi connection is disconnected. the n9 was a bit warm especially on the back side. since that i cant get the wifi hotspot to start. it always shows cant create network error. soon i realized that it cant even scan any wifi networks as i usually connect to wifi at the office. i've tried everything that i can find in the forum and internet to get the wifi started again (countless time of flashing) but no luck. so my conclusion is that the wifi chip is dead or something (overheat?).

Now back to my problem, after the wifi is dead, i use only 3g, and the phone can start normally. but today i rebooted the phone, and its stuck at the nokia logo and rebooted automatically several times until a "Device not working properly" error display pops up. At the bottom it says "Software problem (xsession/wlancond): too many reboots". So im assumming it have to do with the dead wifi.

My question is, will disabling the wifi fix this? if so how can i do that?

tq.
 
Moderator | Posts: 6,150 | Thanked: 6,029 times | Joined on Nov 2011
#2
take it to Nokia Care.
 
Posts: 3 | Thanked: 0 times | Joined on May 2012 @ Malaysia
#3
I have able to boot again! What i did was:

1. Power off my N9
2. Connect to a PC via USB
3. Switch on the N9
4. Wait for the charging status pop up (it will appear in the nokia logo ripples loading screen)
5. When the charging status pops up, you have to choose the usb connection type (mass storage or sync connect)
6. Quickly choose the "use as mass storage" (if you dont choose, it will reboot again and again and again until the error comes up)
7. And the n9 will start normally! (ends the ripples animation and nokia start tune will play)

So by choosing the usb mass storage mode, it actually skips loading the wifi module or services?
 
Posts: 1 | Thanked: 0 times | Joined on Nov 2012
#4
Hi can you help me? i have a Nokia N9 and the same problem, it was working well but since yesterday it turn off and turn it on itselve and appear the following information: El dispositivo no funciona correctamente: Intente actualizar el software del dispositivo con nokia software updater. si el problema persiste, pongase en contacto con el punto nokia care mas cercano. And show this message: Software problem (xsession/wlancond) too many reboots.
How can i fix the problem? I reinstaled the software with the Nokia Software Updater and using winflasher too and the problem persist.
 
Posts: 3 | Thanked: 0 times | Joined on May 2012 @ Malaysia
#5
Originally Posted by ejlkpm View Post
Hi can you help me? i have a Nokia N9 and the same problem, it was working well but since yesterday it turn off and turn it on itselve and appear the following information: El dispositivo no funciona correctamente: Intente actualizar el software del dispositivo con nokia software updater. si el problema persiste, pongase en contacto con el punto nokia care mas cercano. And show this message: Software problem (xsession/wlancond) too many reboots.
How can i fix the problem? I reinstaled the software with the Nokia Software Updater and using winflasher too and the problem persist.
My N9 wifi chip died. So i sent to nokia care to get it replaced. It was under warranty. So no charge. After that it was normal again.
 
Posts: 1 | Thanked: 0 times | Joined on Dec 2012 @ Indonesia
#6
Originally Posted by pandamerah View Post
Hi,

A few days ago, i use my n9 as a hotspot while charging. Suddenly the wifi connection is disconnected. the n9 was a bit warm especially on the back side. since that i cant get the wifi hotspot to start. it always shows cant create network error. soon i realized that it cant even scan any wifi networks as i usually connect to wifi at the office. i've tried everything that i can find in the forum and internet to get the wifi started again (countless time of flashing) but no luck. so my conclusion is that the wifi chip is dead or something (overheat?).

Now back to my problem, after the wifi is dead, i use only 3g, and the phone can start normally. but today i rebooted the phone, and its stuck at the nokia logo and rebooted automatically several times until a "Device not working properly" error display pops up. At the bottom it says "Software problem (xsession/wlancond): too many reboots". So im assumming it have to do with the dead wifi.

My question is, will disabling the wifi fix this? if so how can i do that?

tq.
My friend has the same
problem, my friend finally
N9 could be in Overcome,
only StartUp error by
allowing Active:lol
 
Posts: 2 | Thanked: 0 times | Joined on May 2014
#7
HI! I'ts my first time in this forum, sorry for my english.

I had the same problem with N9, (xsession/wlancond) i tried to reflash, 3 times and it doesn't start. Only start in RD mode, but it doesn't shows de wifi APs.

I think that isn't a HW problem, cause the phone was working well, and suddenly turned-off and stays in the boot-loop.

I don't have 3g connecttion, so i can't try do anything in the console.

What i can do??

Thanks!!
 
Posts: 86 | Thanked: 36 times | Joined on Nov 2013 @ Streets of Avalon | Zwolle, the Netherlands
#8
Try starting wlan0 in monitormode with aircrack. Then turn monitor mode off and see if it will detect wifi networks. Worked for me.
 
Posts: 2 | Thanked: 0 times | Joined on May 2014
#9
I don't have the terminal in the phone, and there isn't 3g or wifi to downloads de packages when i try to activate the developer mode.
What can i do ? I tried to put the files on the memory by the usb cable, but the "massive alm" mode doesn't works
 
Posts: 86 | Thanked: 36 times | Joined on Nov 2013 @ Streets of Avalon | Zwolle, the Netherlands
#10
 
Reply

Thread Tools

 
Forum Jump


All times are GMT -4. The time now is 08:23 PM.