Reply
Thread Tools
Posts: 43 | Thanked: 18 times | Joined on Jul 2010
#11
I have some problems running this program.
Since it didn't want to connect from GUI, I tried connecting from console (in /opt/vpn9c/bin folder):
./vpnc --script 'exec ./vpnc-script'
and typing the necessary login data.

The programs gives following error:
Error binding to the source port. Try '--local-port 0'
Failed to bind to 0.0.0.0:5000: Permission denied

If I try --local-port 0 option, it gives 'Permission denied' again.
I tried both as user and root (devel-su)

i have developer mode, but no inception installed. Is inception needed for this?

Does anybody have any idea how to make this work?
 
Posts: 981 | Thanked: 2,049 times | Joined on Jan 2012 @ Finland
#12
"devel-su; develsh;" or "devel-su; opensh;"
__________________
IRC: jonni@freenode
Sailfish: Qt5 SailfishTouchExample Qt5 MultiPointTouchArea Example ipaddress stoken Sailbox (Dropbox client)
Harmattan: Presence VNC for Harmattan Live-F1 BTinput-terminal BabyLock BabyLock Trial QML TextTV
Disclaimer: all my posts in this forum are personal trolling and I never post in any official capacity on behalf of any company.
 
Posts: 43 | Thanked: 18 times | Joined on Jul 2010
#13
ok, now it gives this error:
./vpnc-script: line 259: can't create /var/run/resolv.conf: Permission denied
./vpnc: no response from target

and 'No response from target' is the same error I get from GUI.
 
Posts: 981 | Thanked: 2,049 times | Joined on Jan 2012 @ Finland
#14
change exec to aegis-exec, otherwise it doesn't inherit the privileges. Things are ofcourse easier if you install the package to some real origin.

vpnc --script 'aegis-exec /opt/vpn9c/bin/vpnc-script' --local-port 0


With proper manifest you don't need even add --local-port
__________________
IRC: jonni@freenode
Sailfish: Qt5 SailfishTouchExample Qt5 MultiPointTouchArea Example ipaddress stoken Sailbox (Dropbox client)
Harmattan: Presence VNC for Harmattan Live-F1 BTinput-terminal BabyLock BabyLock Trial QML TextTV
Disclaimer: all my posts in this forum are personal trolling and I never post in any official capacity on behalf of any company.

Last edited by rainisto; 08-15-2012 at 03:31 PM.
 
Posts: 43 | Thanked: 18 times | Joined on Jul 2010
#15
Originally Posted by rainisto View Post
change exec to aegis-exec, otherwise it doesn't inherit the privileges. Things are ofcourse easier if you install the package to some real origin.

vpnc --script 'aegis-exec /opt/vpn9c/bin/vpnc-script' --local-port 0


With proper manifest you don't need even add --local-port
Well, I've just installed vpn9c, and now I'm trying to get it to work.
and this is the error I get now:
ifconfig: SIOCSIFADDR: Permission denied
RTNETLINK answers: Operation not permitted
RTNETLINK answers: Operation not permitted
route: SIOCADDRT: Operation not permitted
/opt/vpn9c/bin/vpnc-script: line 259: can't create /var/run/resolv.conf: Permission denied
sh: can't kill pid 670: Operation not permitted
VPNC started in background (pid: 3651)...

vpnc is working in the background, but it's not doing anything; I don't have vpnc connection active.

EDIT: if I add aegis-exec in fornt of the ./vpnc, I get:
./vpnc: can't initialise tunnel interface: Operation not permitted

Thanks for all the help, I hope I'll get it to work somehow.

Last edited by ivanrajkovic; 08-15-2012 at 04:02 PM.
 
Posts: 19 | Thanked: 20 times | Joined on Dec 2009
#16
I did not have any problems installing vpn9c. It works perfectly.

Thanks
 
Posts: 981 | Thanked: 2,049 times | Joined on Jan 2012 @ Finland
#17
Originally Posted by ivanrajkovic View Post
Well, I've just installed vpn9c, and now I'm trying to get it to work.
and this is the error I get now:
ifconfig: SIOCSIFADDR: Permission denied
RTNETLINK answers: Operation not permitted
RTNETLINK answers: Operation not permitted
route: SIOCADDRT: Operation not permitted
/opt/vpn9c/bin/vpnc-script: line 259: can't create /var/run/resolv.conf: Permission denied
sh: can't kill pid 670: Operation not permitted
VPNC started in background (pid: 3651)...

vpnc is working in the background, but it's not doing anything; I don't have vpnc connection active.

Thanks for all the help, I hope I'll get it to work somehow.
Yes those are normal errors if you install it as unknown origin. If you want deb to work, you need to wait for ovi signed package, or use some exploit method to install (like inception) or use open mode kernel (with AEGIS_FIXED_ORIGIN export). Or if you want start unknown origin from commandline, you need to do devel-su; develsh; before starting it.

Most likely you want to wait for ovi store version, if your not familiar how Aegis works.
__________________
IRC: jonni@freenode
Sailfish: Qt5 SailfishTouchExample Qt5 MultiPointTouchArea Example ipaddress stoken Sailbox (Dropbox client)
Harmattan: Presence VNC for Harmattan Live-F1 BTinput-terminal BabyLock BabyLock Trial QML TextTV
Disclaimer: all my posts in this forum are personal trolling and I never post in any official capacity on behalf of any company.
 

The Following User Says Thank You to rainisto For This Useful Post:
Posts: 43 | Thanked: 18 times | Joined on Jul 2010
#18
Originally Posted by rainisto View Post
Yes those are normal errors if you install it as unknown origin. If you want deb to work, you need to wait for ovi signed package, or use some exploit method to install (like inception) or use open mode kernel (with AEGIS_FIXED_ORIGIN export). Or if you want start unknown origin from commandline, you need to do devel-su; develsh; before starting it.

Most likely you want to wait for ovi store version, if your not familiar how Aegis works.
Well, I'm starting it after devel-su, develsh, and it is giving these errors. I don't have an open mode kernel, so I'll most likely install inception these days.
Anyway, thank you for all the help.
 
Posts: 43 | Thanked: 18 times | Joined on Jul 2010
#19
Maybe it would be good idea to edit the first post to say that open mode or inception are needed to run this, not only developer mode?
 
too's Avatar
Posts: 117 | Thanked: 117 times | Joined on Dec 2009 @ Helsinki
#20
Originally Posted by ivanrajkovic View Post
Maybe it would be good idea to edit the first post to say that open mode or inception are needed to run this, not only developer mode?
Developer mode is enough -- when developer mode is enabled
developers can install software to have the same credentials
as ovi store provides -- without developer mode users are
restricted to 'unknown origin' credentials if software is not
installed from ovi store.

But, as the vpnc.sh is the one having credentials given
by _aegis the vpnc can be run via command line something
like the following way:

(cd /opt/vpn9c/bin && exec ./vpnc.sh ) < your-config-file.

I'll test this configuration and add note about it for those
who want to use it this way.

Alternatively, one can pick the vpnc binary and _aegis file
from the .deb and build new package for their own purposes

Thank you for all of you running this software,

Tomi

Last edited by too; 08-16-2012 at 02:22 AM.
 

The Following User Says Thank You to too For This Useful Post:
Reply

Thread Tools

 
Forum Jump


All times are GMT -4. The time now is 02:11 AM.