Reply
Thread Tools
Posts: 781 | Thanked: 3,028 times | Joined on Mar 2009
#1
Now in extras-devel.

Currently Maemo5 has python2.5. There are some interesting python2.7 applications which can't be ported to N900.

Check python2.7-minimal from extras-devel.

*Packages are fully optified.
*Python2.5 and python2.7 can be simultaneously installed

There are no yet modules for python2.7, but in some cases it is possible to use modules from python2.5.

It is not intended that existing and working applications use python2.7, but if new application needs python2.7 it states that explicitly.

--------
First test: AdvancedCaching (this is existing application and works great with python2.5)

Code:
/opt/agtl-maemo/core.py
-#!/usr/bin/python
+#!/usr/bin/python2.7

+import sys
+sys.path.append('/usr/lib/pymodules/python2.5')
+sys.path.append('/usr/lib/pymodules/python2.5/gtk-2.0')
+sys.path.append('/usr/lib/python2.5/site-packages/')
+sys.path.append('/usr/lib/python2.5/lib-dynload/')
-> works.
---------
Some existing applications fail to start with python2.7, and I'm suspecting mismatch of old python2.5 modules, so maybe modules (or some of them) must be recompiled against new python. I'm asking You to test and report your thoughts. What modules cause errors?

----------------


Source:
https://gitorious.org/python27-maemo5/python27-maemo5

[EDIT]
ctypes works with version 2.7.3~rc2-2.1-maemo6 (on extras-devel)
[/EDIT]

Last edited by AapoRantalainen; 2013-08-19 at 06:18. Reason: in extras-devel
 

The Following 35 Users Say Thank You to AapoRantalainen For This Useful Post:
Posts: 1,376 | Thanked: 2,073 times | Joined on Nov 2009 @ Dublin, Ireland
#2
Is it really optified without the trickery used for Python 2.5?. That would be really a definitive improvement over current installation.

Have you tried to build it with Linaro toolchain and Thumb2?. It could give a boost to Python applications (specially startup times). Then, you could use CSSU's Thumb repository to upload this package (if freemangordon agrees).
 

The Following 7 Users Say Thank You to ivgalvez For This Useful Post:
Posts: 781 | Thanked: 3,028 times | Joined on Mar 2009
#3
Originally Posted by ivgalvez View Post
Is it really optified without the trickery used for Python 2.5?
Yes, it "just" installs itself to /opt/python27
("just" = You can count how many modifications and commits it took to achieve this.)

Originally Posted by ivgalvez View Post
Have you tried to build it with Linaro toolchain and Thumb2?
Not yet. I'm waiting instructions how to participate thumb2. I really respect extras-devel way, i.e. developers send source code and very same builder builds deb-packages.
 

The Following 6 Users Say Thank You to AapoRantalainen For This Useful Post:
D@vIcHoJD's Avatar
Posts: 236 | Thanked: 94 times | Joined on Jan 2012 @ Ecuador
#4
This is an excelent news, because python 2.5 have any problem with any packages for example wifite_r85, pyrit and others. This required python 2.7. Wait that you compiled python2.7 completely and upload to repositories.

Here are some errors that usually come with some applications using pythonwith pyrit)

Code:
/home/user # pyrit
Traceback (most recent call last):
   File "/usr/bin/pyrit", line 4, in <module>
          import pyrit_cli
   File "isr/bin/pyrit_cli.py", line 32, in <module>
          import cpyrit.cpyrit
ImportError: No module named cpyrit.cpyrit
Something similar occurs with other packages
I would like to continue testing the improvements that are implemented with python

Regards.

Last edited by D@vIcHoJD; 2012-09-19 at 02:58.
 
Posts: 2,698 | Thanked: 10,518 times | Joined on Mar 2010 @ Sofia,Bulgaria
#5
@AapoRantalainen - check your debian/control file (along with others that may be affected) in the package you sent to autobuilder, it seems line endings are windoze style.
__________________
Never fear. I is here.

720p video support on N900,SmartReflex on N900,Keyboard and mouse support on N900
Nothing is impossible - Stable thumb2 on n900

Community SSU developer
kernel-power developer and maintainer

 
Posts: 2,698 | Thanked: 10,518 times | Joined on Mar 2010 @ Sofia,Bulgaria
#6
Originally Posted by AapoRantalainen View Post
Not yet. I'm waiting instructions how to participate thumb2. I really respect extras-devel way, i.e. developers send source code and very same builder builds deb-packages.
Hmm, what instructions do you need?
__________________
Never fear. I is here.

720p video support on N900,SmartReflex on N900,Keyboard and mouse support on N900
Nothing is impossible - Stable thumb2 on n900

Community SSU developer
kernel-power developer and maintainer

 
StefanL's Avatar
Posts: 293 | Thanked: 334 times | Joined on Aug 2010 @ This world :)
#7
Originally Posted by D@vIcHoJD View Post
This is an excelent news, because python 2.5 have any problem with any packages for example wifite_r85, pyrit and others. This required python 2.7. Wait that you compiled python2.7 completely and upload to repositories.
I did not have many issues with running wifite_r85 on python 2.5, more info check here.
__________________
My phone evolution: Nokia 7610 (RIP), N82 (RIP), BB9000 (RIP), N900, BB9760 (RIP), N8, BB9900, N9 64GB
Working : Python Gorillas (Maemo5) Faircrack0.50 Update (Maemo5)
Not so much : WPScrack (Maemo5)
 
Posts: 2 | Thanked: 0 times | Joined on Sep 2012 @ Poland
#8
Thank You.
 
Posts: 781 | Thanked: 3,028 times | Joined on Mar 2009
#9
Originally Posted by freemangordon View Post
@AapoRantalainen - check your debian/control file (along with others that may be affected) in the package you sent to autobuilder, it seems line endings are windoze style.
I send debian/control.in and builder generates debian/control.

For testing I sent only debian-directory without source files, and then I get error log as expected. I will continue investigation.
 
Posts: 2,698 | Thanked: 10,518 times | Joined on Mar 2010 @ Sofia,Bulgaria
#10
Originally Posted by AapoRantalainen View Post
I send debian/control.in and builder generates debian/control.

For testing I sent only debian-directory without source files, and then I get error log as expected. I will continue investigation.
there is debian/control in .tar.gz file you have sent to autobuilder. And this is what autobuilder tries to parse before executing debian/rules.
__________________
Never fear. I is here.

720p video support on N900,SmartReflex on N900,Keyboard and mouse support on N900
Nothing is impossible - Stable thumb2 on n900

Community SSU developer
kernel-power developer and maintainer

 
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 11:06.