Reply
Thread Tools
Posts: 781 | Thanked: 3,027 times | Joined on Mar 2009
#11
Python2.7 hit in extras-devel.
You might want install package named python2.7-minimal (This is package which contains python2.7-binary).

---
When pushing to extras-devel, I only use scp/rcp. When I (accidentally) checked this page: https://garage.maemo.org/extras-assistant/index.php I can see one of my trials on the queue (over six days now). This explains why there wasn't any log (but it doesn't explain why it got stuck on queue)
 

The Following 7 Users Say Thank You to AapoRantalainen For This Useful Post:
Posts: 2,456 | Thanked: 2,645 times | Joined on May 2011 @ Poland
#12
Originally Posted by AapoRantalainen View Post
Python2.7 hit in extras-devel.
You might want install package named python2.7-minimal (This is package which contains python2.7-binary).

---
When pushing to extras-devel, I only use scp/rcp. When I (accidentally) checked this page: https://garage.maemo.org/extras-assistant/index.php I can see one of my trials on the queue (over six days now). This explains why there wasn't any log (but it doesn't explain why it got stuck on queue)

Aapo, could you make some way like that: if an env. variable, let's call it USE_PYTHON27, (when calling python) then /usr/bin/python2.7 is called, the other way python2.5 is used.

Is this possible?
__________________
If you want to support my work, you can DONATE

You're encouraged to donate at least a couple of euros - otherwise PayPal takes almost everything as a fee.

If you'd prefer other currency or form of donation, please contact me


MeeCoLay: run MeeGo Harmattan apps on Fremantle

I won't be on TMO for some time. See you soon
 
Posts: 453 | Thanked: 1,479 times | Joined on Apr 2012
#13
Is it possible to use pip or easy_install with python2.7 so as to have access to all of the Python packages?
__________________
Saera: A Siri clone for the N900 and N9(50)

Follow me on Twitter: twitter.com/taixzo
 

The Following 2 Users Say Thank You to taixzo For This Useful Post:
Posts: 781 | Thanked: 3,027 times | Joined on Mar 2009
#14
Originally Posted by taixzo View Post
Is it possible to use pip or easy_install with python2.7 so as to have access to all of the Python packages?
I haven't used them. Seems easy_install is dead. Ubuntu ships easy_install inside package python-setuptools which is actually distribute: http://pypi.python.org/pypi/distribute
----
Pip is http://www.pip-installer.org/en/latest/
Installing it needs distribute or setuptools.
-----

http://cc.oulu.fi/~rantalai/maemo5/python27-setuptools/

So there are python-pkg-resources_0.6.24-1-maemo1_all.deb and python-setuptools_0.6.24-1-maemo1_all.deb (from Ubuntu) made against optified python2.7. Install python2.7 and then these both. Use
Code:
sudo gainroot
/opt/python27/bin/easy_install
-> report what happens and where it downloads things (and will they work). I'm currently running totally out of rootfs and seems it at least needs some temporary space for downloads.

Last edited by AapoRantalainen; 09-27-2012 at 03:25 AM.
 

The Following User Says Thank You to AapoRantalainen For This Useful Post:
Posts: 453 | Thanked: 1,479 times | Joined on Apr 2012
#15
Originally Posted by AapoRantalainen View Post
-> report what happens and where it downloads things (and will they work). I'm currently running totally out of rootfs and seems it at least needs some temporary space for downloads.
Well, it seems I too am running out of rootfs...I'll test this once I've uninstalled a few things.
__________________
Saera: A Siri clone for the N900 and N9(50)

Follow me on Twitter: twitter.com/taixzo
 
int_ua's Avatar
Posts: 658 | Thanked: 1,013 times | Joined on Jul 2010 @ Kyiv, Ukraine
#16
I can't see the package in FAM. Any suggestions?
__________________
I reckon current Russian government as fascist threat and everyone who supports it as my personal enemies. If you are one of those, prepend the info to anything else.
 
Posts: 781 | Thanked: 3,027 times | Joined on Mar 2009
#17
Originally Posted by int_ua View Post
I can't see the package in FAM. Any suggestions?
It's section is not "user/".
 

The Following 2 Users Say Thank You to AapoRantalainen For This Useful Post:
Posts: 2,456 | Thanked: 2,645 times | Joined on May 2011 @ Poland
#18
Originally Posted by int_ua View Post
I can't see the package in FAM. Any suggestions?
use category "all packages (advanced)"
__________________
If you want to support my work, you can DONATE

You're encouraged to donate at least a couple of euros - otherwise PayPal takes almost everything as a fee.

If you'd prefer other currency or form of donation, please contact me


MeeCoLay: run MeeGo Harmattan apps on Fremantle

I won't be on TMO for some time. See you soon
 

The Following User Says Thank You to marmistrz For This Useful Post:
Posts: 2,456 | Thanked: 2,645 times | Joined on May 2011 @ Poland
#19
Can anyone create pyside for python2.7?
__________________
If you want to support my work, you can DONATE

You're encouraged to donate at least a couple of euros - otherwise PayPal takes almost everything as a fee.

If you'd prefer other currency or form of donation, please contact me


MeeCoLay: run MeeGo Harmattan apps on Fremantle

I won't be on TMO for some time. See you soon
 

The Following 3 Users Say Thank You to marmistrz For This Useful Post:
Posts: 930 | Thanked: 3,377 times | Joined on Apr 2010 @ Czech Republic
#20
Originally Posted by marmistrz View Post
Can anyone create pyside for python2.7?
Good point.
+1
__________________
modRana: a flexible GPS navigation system
Mieru: a flexible manga and comic book reader

Thanks to everyone who voted for modRana & Mieru in the Maemo.org coding competition !
 
Reply

Thread Tools

 
Forum Jump


All times are GMT -4. The time now is 03:36 PM.