Reply
Thread Tools
Posts: 2,365 | Thanked: 2,551 times | Joined on May 2011 @ Poland
#1
Hi,

I managed to port the most of the Harmattan's SignOn Framework.

How to be able to install it?
You need to add the meecolay repository and extras-devel. You can do it by installing the meecolay-core package.
Note: you need to apt-get update after installing the package!
Note2: meecolay-core sets up the repo temporarily. Due to problems with autobuilder, repo setup hasn't been moved to separate package yet. The update will be announced in this thread too.

INFORMATION FOR DEVELOPERS

Now, with most libraries ported we need a nice GUI. Otherwise Accounts & SSO framework is useless. I was unable to cleanly build the GUI stuff.

What is needed
  • libaccounts-ui: link (source of Harmattan version depends on proprietary libraries, nemo is free of them) - we can take original Harmattan packaging to the Nemo version
  • accounts-ui: link

The best way might be to base on Nemo Mobile code. We don't have Sparql modules in tracker. Debian packaging for these can be created by Qt Creator if Harmattan/Fremantle target selected. QML might be a good choice, then some of the Nemo code might be reused.

I hope we can create the Fremantle-ready GUI parts so that any developer can use SSO! If you'd like to help in creating the GUI parts, pm or mail me.
__________________
If you want to support my work, you can DONATE

You're encouraged to donate at least a couple of euros - otherwise PayPal takes almost everything as a fee.

If you'd prefer other currency, please contact me


Support for MeeCoLay donors is available in English, po polsku, auf Deutsch & по-русский

MeeCoLay: run MeeGo Harmattan apps on Fremantle

Last edited by marmistrz; 12-28-2012 at 03:59 PM.
 

The Following 10 Users Say Thank You to marmistrz For This Useful Post:
sifo's Avatar
Posts: 1,359 | Thanked: 1,288 times | Joined on Oct 2011 @ Tartus.Syria
#2
I would like to test it as it is a part of meecolay
just a question: i need to install all the debs in that link ? and what difference should i note ?
thanks

./sifo
__________________
[ N900-Crack ] [ The Purge ] [ New Smiles ] [ New icons ] [ ? ]
" Hey ! I've just met you and this is crazy, so install cssu maybe ? "
Please help out keeping Maemo.org alive, and consider donating.
https://www.facebook.com/ZoRk7
 

The Following 2 Users Say Thank You to sifo For This Useful Post:
Posts: 2,365 | Thanked: 2,551 times | Joined on May 2011 @ Poland
#3
Originally Posted by sifo View Post
I would like to test it as it is a part of meecolay
just a question: i need to install all the debs in that link ? and what difference should i note ?
thanks

./sifo
Install libsignon-qt0 and signond, and anything that is shown as a missing dependency and is in the link. Then apt-get install -f
And tell me which pkgs were needed.
__________________
If you want to support my work, you can DONATE

You're encouraged to donate at least a couple of euros - otherwise PayPal takes almost everything as a fee.

If you'd prefer other currency, please contact me


Support for MeeCoLay donors is available in English, po polsku, auf Deutsch & по-русский

MeeCoLay: run MeeGo Harmattan apps on Fremantle
 

The Following User Says Thank You to marmistrz For This Useful Post:
sifo's Avatar
Posts: 1,359 | Thanked: 1,288 times | Joined on Oct 2011 @ Tartus.Syria
#4
Here it is :
Code:
/home/user/MyDocs # dpkg -i signond_9.23-1maemo0_armel.deb libsignon-qt0_9.23-1maemo0_armel.deb 
Selecting previously deselected package signond.
(Reading database ... 50862 files and directories currently installed.)
Unpacking signond (from signond_9.23-1maemo0_armel.deb) ...
Adding system user signon....done
Replacing files in old package signond0 ...
Selecting previously deselected package libsignon-qt0.
Unpacking libsignon-qt0 (from libsignon-qt0_9.23-1maemo0_armel.deb) ...
dpkg: dependency problems prevent configuration of signond:
 signond depends on aegisfs; however:
  Package aegisfs is not installed.
 signond depends on libcryptsetup0; however:
  Package libcryptsetup0 is not installed.
 signond depends on libsignoncrypto-qt; however:
  Package libsignoncrypto-qt is not installed.
dpkg: error processing signond (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libsignon-qt0:
 libsignon-qt0 depends on signond; however:
  Package signond is not configured yet.
 libsignon-qt0 depends on libsignoncrypto-qt; however:
  Package libsignoncrypto-qt is not installed.
 libsignon-qt0 depends on libsignoncrypto-qt; however:
  Package libsignoncrypto-qt is not installed.
dpkg: error processing libsignon-qt0 (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 signond
 libsignon-qt0
/home/user/MyDocs #
i tried "apt-get install -f" but it wants to remove them !
Code:
/home/user/MyDocs # apt-get install -f 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages will be REMOVED:
  libsignon-qt0 signond
0 upgraded, 0 newly installed, 2 to remove and 0 not upgraded.
2 not fully installed or removed.
After this operation, 1057kB disk space will be freed.
Do you want to continue [Y/n]?
should i install aegisfs, ibcryptsetup0 and libcryptsetup0-qt manually from devel ?
__________________
[ N900-Crack ] [ The Purge ] [ New Smiles ] [ New icons ] [ ? ]
" Hey ! I've just met you and this is crazy, so install cssu maybe ? "
Please help out keeping Maemo.org alive, and consider donating.
https://www.facebook.com/ZoRk7
 

The Following 2 Users Say Thank You to sifo For This Useful Post:
Posts: 293 | Thanked: 162 times | Joined on Jan 2012 @ beijing-islamabad
#5
Well if this really works ,i am gonna consider it real achievement in sense of mee-cloy development . great work i must say ,just had a look at SSO and i reckon it is lovely there .
 
Posts: 2,365 | Thanked: 2,551 times | Joined on May 2011 @ Poland
#6
Originally Posted by sifo View Post
Here it is :
Code:
/home/user/MyDocs # dpkg -i signond_9.23-1maemo0_armel.deb libsignon-qt0_9.23-1maemo0_armel.deb 
Selecting previously deselected package signond.
(Reading database ... 50862 files and directories currently installed.)
Unpacking signond (from signond_9.23-1maemo0_armel.deb) ...
Adding system user signon....done
Replacing files in old package signond0 ...
Selecting previously deselected package libsignon-qt0.
Unpacking libsignon-qt0 (from libsignon-qt0_9.23-1maemo0_armel.deb) ...
dpkg: dependency problems prevent configuration of signond:
 signond depends on aegisfs; however:
  Package aegisfs is not installed.
 signond depends on libcryptsetup0; however:
  Package libcryptsetup0 is not installed.
 signond depends on libsignoncrypto-qt; however:
  Package libsignoncrypto-qt is not installed.
dpkg: error processing signond (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libsignon-qt0:
 libsignon-qt0 depends on signond; however:
  Package signond is not configured yet.
 libsignon-qt0 depends on libsignoncrypto-qt; however:
  Package libsignoncrypto-qt is not installed.
 libsignon-qt0 depends on libsignoncrypto-qt; however:
  Package libsignoncrypto-qt is not installed.
dpkg: error processing libsignon-qt0 (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 signond
 libsignon-qt0
/home/user/MyDocs #
i tried "apt-get install -f" but it wants to remove them !
Code:
/home/user/MyDocs # apt-get install -f 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages will be REMOVED:
  libsignon-qt0 signond
0 upgraded, 0 newly installed, 2 to remove and 0 not upgraded.
2 not fully installed or removed.
After this operation, 1057kB disk space will be freed.
Do you want to continue [Y/n]?
should i install aegisfs, ibcryptsetup0 and libcryptsetup0-qt manually from devel ?

Hi,

so: you have 2 ways:
first:
1) install everything which's not aegisfs and is needed manually
2) install signon
3) dpkg --configure -a --force-depends
this is not a permanent

second:
you can try out my updated fuse (I'm lacking testers to claim it stable or not for sure, but this should be ok)
1) install fuse http://talk.maemo.org/showpost.php?p...03&postcount=1
2) install aegisfs http://harmattan-dev.nokia.com/pool/...+0m6_armel.deb
3) apt-get install -f
4) install signon
__________________
If you want to support my work, you can DONATE

You're encouraged to donate at least a couple of euros - otherwise PayPal takes almost everything as a fee.

If you'd prefer other currency, please contact me


Support for MeeCoLay donors is available in English, po polsku, auf Deutsch & по-русский

MeeCoLay: run MeeGo Harmattan apps on Fremantle

Last edited by marmistrz; 10-03-2012 at 02:11 PM.
 

The Following 3 Users Say Thank You to marmistrz For This Useful Post:
Posts: 2,125 | Thanked: 3,397 times | Joined on Jun 2010 @ Florida
#7
What does this to as far as providing actual advantages/disadvantages, to the one that's already on the N900?
 

The Following 6 Users Say Thank You to Mentalist Traceur For This Useful Post:
Posts: 2,365 | Thanked: 2,551 times | Joined on May 2011 @ Poland
#8
Originally Posted by Mentalist Traceur View Post
What does this to as far as providing actual advantages/disadvantages, to the one that's already on the N900?
Generally N900 signond0 isn't compatible with libsignon afaik. But I don't know anything else about the diffs.

In the control file it wrote that it replaces signond0, so this shouldn't be worse, I guess.
__________________
If you want to support my work, you can DONATE

You're encouraged to donate at least a couple of euros - otherwise PayPal takes almost everything as a fee.

If you'd prefer other currency, please contact me


Support for MeeCoLay donors is available in English, po polsku, auf Deutsch & по-русский

MeeCoLay: run MeeGo Harmattan apps on Fremantle
 
sifo's Avatar
Posts: 1,359 | Thanked: 1,288 times | Joined on Oct 2011 @ Tartus.Syria
#9
Originally Posted by marmistrz View Post
Hi,

so: you have 2 ways:
first:
1) install everything which's not aegisfs and is needed manually
2) install signon
3) dpkg --configure -a --force-depends
this is not a permanent

second:
you can try out my updated fuse (I'm lacking testers to claim it stable or not for sure, but this should be ok)
1) install fuse http://talk.maemo.org/showpost.php?p...03&postcount=1
2) install aegisfs http://harmattan-dev.nokia.com/pool/...+0m6_armel.deb
3) apt-get install -f
4) install signon
so i took the second way
1-installed fuse without problems
2- aegisfs
Code:
/home/user/MyDocs # dpkg -i aegisfs_1.0.0\+0m6_armel.deb 
Selecting previously deselected package aegisfs.
(Reading database ... 51513 files and directories currently installed.)
Unpacking aegisfs (from aegisfs_1.0.0+0m6_armel.deb) ...
dpkg: dependency problems prevent configuration of aegisfs:
 aegisfs depends on libbb5-0; however:
  Package libbb5-0 is not installed.
 aegisfs depends on libzip1 (>= 0.9-3); however:
  Package libzip1 is not installed.
dpkg: error processing aegisfs (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 aegisfs
apt-get install -f
Code:
/home/user/MyDocs # apt-get install -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  libfuse2 fuse-utils
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED:
  aegisfs libsignon-qt0 signond
0 upgraded, 0 newly installed, 3 to remove and 0 not upgraded.
3 not fully installed or removed.
After this operation, 1307kB disk space will be freed.
Do you want to continue [Y/n]? n
dpkg --configure -a --force-depends
Code:
/home/user/MyDocs # dpkg --configure -a --force-depends
dpkg: aegisfs: dependency problems, but configuring anyway as you request:
 aegisfs depends on libbb5-0; however:
  Package libbb5-0 is not installed.
 aegisfs depends on libzip1 (>= 0.9-3); however:
  Package libzip1 is not installed.
Setting up aegisfs (1.0.0+0m6) ...
aegisfs: error while loading shared libraries: libzip.so.1: cannot open shared object file: No such file or directory
dpkg: error processing aegisfs (--configure):
 subprocess post-installation script returned error exit status 127
dpkg: signond: dependency problems, but configuring anyway as you request:
 signond depends on aegisfs; however:
  Package aegisfs is not configured yet.
 signond depends on libcryptsetup0; however:
  Package libcryptsetup0 is not installed.
 signond depends on libsignoncrypto-qt; however:
  Package libsignoncrypto-qt is not installed.
Setting up signond (9.23-1maemo0) ...
aegisfs: error while loading shared libraries: libzip.so.1: cannot open shared object file: No such file or directory
dpkg: libsignon-qt0: dependency problems, but configuring anyway as you request:
 libsignon-qt0 depends on libsignoncrypto-qt; however:
  Package libsignoncrypto-qt is not installed.
 libsignon-qt0 depends on libsignoncrypto-qt; however:
  Package libsignoncrypto-qt is not installed.
Setting up libsignon-qt0 (9.23-1maemo0) ...
ldconfig: /usr/lib/libpulse-mainloop-glib.so.0 is not a symbolic link

ldconfig: /usr/lib/libpulse.so.0 is not a symbolic link

ldconfig: /usr/lib/libpulse-simple.so.0 is not a symbolic link

Errors were encountered while processing:
 aegisfs
( signon installed too )

what should i do now ?
__________________
[ N900-Crack ] [ The Purge ] [ New Smiles ] [ New icons ] [ ? ]
" Hey ! I've just met you and this is crazy, so install cssu maybe ? "
Please help out keeping Maemo.org alive, and consider donating.
https://www.facebook.com/ZoRk7

Last edited by sifo; 10-05-2012 at 09:55 AM. Reason: typo
 
Posts: 2,365 | Thanked: 2,551 times | Joined on May 2011 @ Poland
#10
Originally Posted by sifo View Post
so i took the second way
1-installed fuse without problems
2- aegisfs
Code:
/home/user/MyDocs # dpkg -i aegisfs_1.0.0\+0m6_armel.deb 
Selecting previously deselected package aegisfs.
(Reading database ... 51513 files and directories currently installed.)
Unpacking aegisfs (from aegisfs_1.0.0+0m6_armel.deb) ...
dpkg: dependency problems prevent configuration of aegisfs:
 aegisfs depends on libbb5-0; however:
  Package libbb5-0 is not installed.
 aegisfs depends on libzip1 (>= 0.9-3); however:
  Package libzip1 is not installed.
dpkg: error processing aegisfs (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 aegisfs
apt-get install -f
Code:
/home/user/MyDocs # apt-get install -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  libfuse2 fuse-utils
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED:
  aegisfs libsignon-qt0 signond
0 upgraded, 0 newly installed, 3 to remove and 0 not upgraded.
3 not fully installed or removed.
After this operation, 1307kB disk space will be freed.
Do you want to continue [Y/n]? n
dpkg --configure -a --force-depends
Code:
/home/user/MyDocs # dpkg --configure -a --force-depends
dpkg: aegisfs: dependency problems, but configuring anyway as you request:
 aegisfs depends on libbb5-0; however:
  Package libbb5-0 is not installed.
 aegisfs depends on libzip1 (>= 0.9-3); however:
  Package libzip1 is not installed.
Setting up aegisfs (1.0.0+0m6) ...
aegisfs: error while loading shared libraries: libzip.so.1: cannot open shared object file: No such file or directory
dpkg: error processing aegisfs (--configure):
 subprocess post-installation script returned error exit status 127
dpkg: signond: dependency problems, but configuring anyway as you request:
 signond depends on aegisfs; however:
  Package aegisfs is not configured yet.
 signond depends on libcryptsetup0; however:
  Package libcryptsetup0 is not installed.
 signond depends on libsignoncrypto-qt; however:
  Package libsignoncrypto-qt is not installed.
Setting up signond (9.23-1maemo0) ...
aegisfs: error while loading shared libraries: libzip.so.1: cannot open shared object file: No such file or directory
dpkg: libsignon-qt0: dependency problems, but configuring anyway as you request:
 libsignon-qt0 depends on libsignoncrypto-qt; however:
  Package libsignoncrypto-qt is not installed.
 libsignon-qt0 depends on libsignoncrypto-qt; however:
  Package libsignoncrypto-qt is not installed.
Setting up libsignon-qt0 (9.23-1maemo0) ...
ldconfig: /usr/lib/libpulse-mainloop-glib.so.0 is not a symbolic link

ldconfig: /usr/lib/libpulse.so.0 is not a symbolic link

ldconfig: /usr/lib/libpulse-simple.so.0 is not a symbolic link

Errors were encountered while processing:
 aegisfs
( signon installed too )

what should i do now ?
Install libzip1 before aegisfs.
I'm planning to build newer version of libzip1
__________________
If you want to support my work, you can DONATE

You're encouraged to donate at least a couple of euros - otherwise PayPal takes almost everything as a fee.

If you'd prefer other currency, please contact me


Support for MeeCoLay donors is available in English, po polsku, auf Deutsch & по-русский

MeeCoLay: run MeeGo Harmattan apps on Fremantle

Last edited by marmistrz; 10-05-2012 at 11:29 AM.
 
Reply

Thread Tools

 
Forum Jump


All times are GMT -4. The time now is 04:02 AM.