Reply
Thread Tools
Posts: 1 | Thanked: 0 times | Joined on May 2012
#1
My device can connect WLAN and do well in office. But when i'm at home, it can not search the signal of WLAN. And all other mobile devices can connect WLAN and do well at home.
Why? Which configuration i set is wrong?
 
Posts: 2,803 | Thanked: 4,484 times | Joined on Nov 2007
#2
 
Posts: 154 | Thanked: 73 times | Joined on Jan 2009 @ Toronto
#3

@girlmail2005:

The bug thread linked by Ima is informative, but the early part of it can be discouraging. You might get the impression that there is no solution to this problem. In case you didn't follow the thread as far as Comment 17, you should read that and also Comments 19, 22, 26 and 27. They describe a technique that often works to connect the 770.

Many people find that they can connect the 770 quite easily that way. Success is partly a matter of acquiring the knack, but it might also depend on the model of your router/AP.

2.4 GHz signals of any kind can interfere with the search and association. After initial success with one router, I moved it into a different position, and then could no longer connect the 770. (I could not connect my N800 either!) Eventually I traced the problem to a wireless-mouse dongle plugged into a netbook near the router. After unplugging the dongle, there were no more problems.

You might not even need to use the "body-shielding" technique. Two questions for you:

1. Does your home router use n-type signals, or b/g only?
2. During network searches, do your other devices find your neighbors' networks, or just your own?

If you have an n-type router, the first thing to do is to turn off the n signal and only use b/g. That might solve your problem, unless you are receiving a lot of signals from other routers in the neighborhood. If you still can not connect the 770, the next step is to try the body-shielding technique.

The bug thread also contains suggestions for command-line solutions, in Comments 39 and 53. Comment 53 bizarrely tells you to use iwpriv commands, which don't work on the 770. If you try it, your 770 will become unbootable and you will have to reflash the firmware.

Comment 39 is OK, but it is unnecessarily complicated, unless you actually do use a static IP configuration. If you use DHCP like nearly everyone else, a udhcpc command will do the configuration for you. See http://talk.maemo.org/showthread.php?t=85030 for command-line connection using DHCP. It is a useful option for anyone who has no success with the body-shielding technique. It will even enable you to connect with a b/g/n router.

Last edited by scaler; 2013-08-28 at 23:15.
 
Posts: 60 | Thanked: 61 times | Joined on Oct 2007 @ EU
#4
The workaround I am using to connect to WLAN at home (usually when there are routers with n-type signals around) is in the following post:

http://talk.maemo.org/showpost.php?p...6&postcount=46
 
Posts: 106 | Thanked: 38 times | Joined on Oct 2012
#5
The 770 doesn't work with Wireless N routers. If you have a router before N, like a A, B, or G router, and can't connect, use the method from the link ima posted.
 
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 19:48.