Reply
Thread Tools
Posts: 7 | Thanked: 4 times | Joined on Dec 2012 @ Germany
#1
Hello,

got my new N9 last week and I love it!

Currently, I have just one question:

Compared to other Nokias (I also have access to a N900 and a N8), the rendering of "Nokia Maps" is quite bad. The lines for the streets are too thin, it looks like playing a 3D game without Anti Aliasing. The lines for the streets on a N900 are only a little bit thicker, but the result is way better. I'd also like to have a slightly bigger font. Unfortunately, I did not find a settings menu for that

Do you have a tip for me? Do you see the difference or am I the only one who is sensitive for that?

Regards!

Last edited by boltzmann; 2012-12-13 at 23:39.
 
Posts: 101 | Thanked: 62 times | Joined on Apr 2012
#2
Like this?

http://www.anandtech.com/show/3764/t...orola-droid/18

N9 uses Pentile Matrix AMOLED. Turning up the brightness can help.
 
torcida's Avatar
Posts: 84 | Thanked: 43 times | Joined on Nov 2012
#3
Originally Posted by boltzmann View Post
it looks like playing a 3D game without Anti Aliasing.
+1

Same "problem" here...
 
Posts: 49 | Thanked: 92 times | Joined on Jan 2012 @ Finland
#4
Right, Nokia Maps on N9 is not using anti-aliasing in rendering, which makes lines to look somewhat ugly. I don't like that either!

I remember that some guys here on this forum found out that there were some commented out features in QML files of Maps, like traffic information etc., which they were able to turn on. So I was wondering if anti-aliasing could be a similar disabled feature. After a while it turned out, that it can be controlled via a command line parameter (--antialiasing-on).

So you can turn anti-aliasing on for Maps!

You need developer mode for editing the desktop file of the application as root user.

Open file /usr/share/applications/maps.desktop in a text editor and edit this launcher line:
Code:
Exec=/usr/bin/invoker --type=e /usr/bin/maps -u %U
.. to have the extra parameter, like this (all on the same line):
Code:
Exec=/usr/bin/invoker --type=e /usr/bin/maps -u %U --antialiasing-on
Unfortunately, I couldn't find similar parameter for Drive application.

Enabling the anti-aliasing probably decreases the frame rate somewhat, but at least for me, panning the map is still quite smooth.
 

The Following 9 Users Say Thank You to Kallela For This Useful Post:
Posts: 7 | Thanked: 4 times | Joined on Dec 2012 @ Germany
#5
Hey,

thank you very much, it worked well! It is a huge difference between antialiasing turned on and off. I wonder why there is no option for that in the maps settings.

Give me a moment, I will post two screenshots of the maps application so that other user can compare it on their own.

Regards!

edit: Here are the screenshots. Be sure that your image viewer does not scale them to something else than 100%.
Attached Files
File Type: zip N9 Maps.zip (334.1 KB, 138 views)
__________________
Nokia N9 (16GB, black) and a Nokia N900

Last edited by boltzmann; 2012-12-13 at 23:29. Reason: Screenshots!
 
Posts: 38 | Thanked: 24 times | Joined on Aug 2012 @ Zürich, Switzerland
#6
Hi,

I tried the mod and it works well, but i noticed that the application was much slower and actually crashed quite often. After removing the antialiasing the app is back to normal, a bit pixelated but reliable.

Just reporting my experiences.
 

The Following User Says Thank You to jmsarriat For This Useful Post:
torcida's Avatar
Posts: 84 | Thanked: 43 times | Joined on Nov 2012
#7
My N9 (MeeTxtEdit) doesn't allow me to change the contents, respecitvely save the changed file. Can someone please help me with this?

Thanks.
 
Posts: 29 | Thanked: 10 times | Joined on May 2012 @ London/Hong Kong
#8
Originally Posted by torcida View Post
My N9 (MeeTxtEdit) doesn't allow me to change the contents, respecitvely save the changed file. Can someone please help me with this?

Thanks.
If you want to do it on the phone you'll need superuser permissions first (assuming you know your way around terminal / have developer mode on).

Best to do it via vi
 
torcida's Avatar
Posts: 84 | Thanked: 43 times | Joined on Nov 2012
#9
Originally Posted by damuffinman View Post
If you want to do it on the phone you'll need superuser permissions first (assuming you know your way around terminal / have developer mode on).

Best to do it via vi
I have developer mode on... And what do you mean with "via vi"?
 
torcida's Avatar
Posts: 84 | Thanked: 43 times | Joined on Nov 2012
#10
...I couldn't succeed to change the original "maps.desktop"-file.
What have I done then? I just copied the original file into "/home/user/MyDocs/Documents" and edited this file (added this extra parameter: "--antialiasing-on"). It's strange, but it's working now (there is a quite huge difference like shown by "boltzmann")!


Last edited by torcida; 2013-01-06 at 02:03.
 
Reply

Tags
maps rendering

Thread Tools

 
Forum Jump


All times are GMT. The time now is 00:05.