Reply
Thread Tools
Posts: 38 | Thanked: 10 times | Joined on Jan 2010 @ GTA Ontario
#1
( Moved from http://talk.maemo.org/showthread.php?t=80392&page=26 )

I used to be able to connect to my N900 ssh service or the smb service, when it was on PR1.3.
Now that I've upgraded to the latest stable release of the CSSU, the N900 appears off the network.
What is happening is that it does not respond to arp requests anymore.
As a work around, I need to ping the device that I want to connect to the N900 with first from the N900.
This way the device learns the mac address of it's ip address and the device can connect.
What changed in CSSU or is no-one else finding this issue?

I'm not aware of any Power savings setting on the N900. Also if I ping device A, A can connect, but device B still won't.
I still need to ping device B as well, before it'll connect.

Most curious and annoying.
 
Posts: 1,254 | Thanked: 656 times | Joined on Mar 2009
#2
I got a similar issue after flashing the tomato firmware onto my WRT54GL router. The arp request never reaches the N900 though (checked with tcpdump on n900). Not consistently though, sometimes it just works. Mostly acts up for more idle wifi clients. As a bonus, tomato isn't passing on any broadcast messages from the windows machines on the LAN either, dropping idle wifi power use on n900 by a factor of 2-4
 
Posts: 6 | Thanked: 2 times | Joined on Oct 2012
#3
I have the same problem. I'm not sure, but sometimes it was happening even before update.
 
erendorn's Avatar
Posts: 738 | Thanked: 981 times | Joined on Apr 2010 @ London
#4
I had similar issue, but also router side (I flashed the router firmware, and it solved the issue). Have you changed anything router side?
 
Posts: 2,036 | Thanked: 3,403 times | Joined on Apr 2010 @ St. Helens, England
#5
With issues like this try removing Power Saving on the N900, some routers can have problems with it.
__________________
The stable-beast currently runs...
21.2011.38-1Smaemo6.1 (CSSU Stable)
2.6.28.10power52 (125-600Mhz SR VDD1&2)

Wiki Admin
sixwheeledbeast's wiki
Testing Squad Subscriber
- mcallerx - tenminutecore - FlopSwap - Qnotted - zzztop - Bander - Fight2048 -


Before posting or starting a thread please try this.
 
Posts: 38 | Thanked: 10 times | Joined on Jan 2010 @ GTA Ontario
#6
Like I stated i my first post, I'm not aware of any power saving settings active on my N900; how do I check that?

I have not changed anything to my router; all worked as expected before the upgrade.

I might have to do a tcpdump myself, when I can find the time...

Thanks all for your contributions.
gC
 
Posts: 2,036 | Thanked: 3,403 times | Joined on Apr 2010 @ St. Helens, England
#7
WLAN Power Saving

Settings > Internet Connections > Connections > Edit > Advanced > Other

Defaults to Maximum
__________________
The stable-beast currently runs...
21.2011.38-1Smaemo6.1 (CSSU Stable)
2.6.28.10power52 (125-600Mhz SR VDD1&2)

Wiki Admin
sixwheeledbeast's wiki
Testing Squad Subscriber
- mcallerx - tenminutecore - FlopSwap - Qnotted - zzztop - Bander - Fight2048 -


Before posting or starting a thread please try this.
 
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 09:32.