Notices


Reply
Thread Tools
dos1's Avatar
Posts: 256 | Thanked: 2,042 times | Joined on Sep 2010 @ Poznań, Poland
#1
Hello!

I've just made a short video showing the first Neo900 proto board (the same that Nikolaus had during OHSW) making a call to a GTA04 and vice versa, and sending a SMS message.

https://www.youtube.com/watch?v=FNSPEWvTJTc

The PC to which the board is connected is running Debian GNU/Linux with freesmartphone.org middleware (generic "singleline" fsogsmd plugin for now) and SHR GUI apps, installed from Debian repos. GTA04 runs full SHR distro.

I've also started documenting the most important stuff from our POV about the modem:
http://projects.goldelico.com/p/neo900/page/Modem/

For the record: video made with N900
__________________
Sebastian Krzyszkowiak - http://dosowisko.net/
Long term Openmoko supporter. Owner of two Neo Freerunners and two N900s (without USB).
Future owner of the Neo900

Last edited by dos1; 2014-05-19 at 21:29.
 

The Following 20 Users Say Thank You to dos1 For This Useful Post:
kingoddball's Avatar
Posts: 1,175 | Thanked: 790 times | Joined on Apr 2010 @ Australia
#2
Impressive. Good to see it does actually work (maybe? Could be a web service )

Looks good! Thanks for the vid, hopefully you guys throw out some more.
Ignore the haters and trolls! Keep it up!
__________________
The thanks button? Sure! You can press it! I would!
 

The Following 2 Users Say Thank You to kingoddball For This Useful Post:
joerg_rw's Avatar
Posts: 2,179 | Thanked: 12,228 times | Joined on Mar 2010 @ SOL 3
#3
Well, next step: connect the "Neo900" modem to the GTA04 USB, et voila: a veritable Neo900 prototyping setup, consisting of DM3730 and all, connected to PHS8 modem via USB, (almost) exactly like we'll see it in final Neo900. Arguable if a N900 would beat the GTA04, due to the hw kbd, or the GTA04 wins thanks to the DM3730 instead of N900's OMAP3530
 

The Following 6 Users Say Thank You to joerg_rw For This Useful Post:
Posts: 686 | Thanked: 1,934 times | Joined on Jan 2011 @ Germany
#4
@dos1:
Can you check the dependencies of phoneui-apps in Debian please?
I tried just the GUI (without modem) in a Virtualbox-VM running Jessie/amd64 and it seems there are some evas-related packages missing.

strace excerpt of phoneuid when starting phoneui-dialer in another terminal:
Code:
stat("/usr/lib/x86_64-linux-gnu/evas/modules/engines/software_x11/linux-gnu-x86_64-1.8.6/module.so", 0x7fffb5888280) = -1 ENOENT (No such file or directory)
write(2, "\33[31;1mCRI<4251>\33[0m:\33[34;1melem"..., 80CRI<4251>:elementary elm_win.c:2388 elm_win_add() ) = 80
write(2, "Software X11 engine creation fai"..., 52Software X11 engine creation failed. Trying default.) = 52
write(2, "\n", 1
)                       = 1
stat("/usr/lib/x86_64-linux-gnu/evas/modules/engines/fb/linux-gnu-x86_64-1.8.6/module.so", 0x7fffb58882b0) = -1 ENOENT (No such file or directory)
write(2, "\33[31mERR<4251>\33[0m:\33[34;1melemen"..., 78ERR<4251>:elementary elm_win.c:2574 elm_win_add() ) = 78
write(2, "Cannot create window.", 21Cannot create window.)   = 21
write(2, "\n", 1
)                       = 1
write(2, "\n(process:4251): libphone-ui-shr"..., 101
(process:4251): libphone-ui-shr-CRITICAL **: Wasn't able to create a window (ui_utils_view_init:76)
) = 101
write(2, "\n(process:4251): libphone-ui-shr"..., 73
(process:4251): libphone-ui-shr-CRITICAL **: Failed to init dialer view
Please note that the VM has e17 installed and therefore some evas-packages were already there.

phoneuid.log says this:
Code:
2014.05.20 23:15:50.185004 [libphone-ui-shr]    CRITICAL: Wasn't able to create a window (ui_utils_view_init:76)
2014.05.20 23:15:50.185062 [libphone-ui-shr]    CRITICAL: Failed to init dialer view
2014.05.20 23:16:40.841105 [phoneuid]   CRITICAL: Failed to register /org/shr/phoneui/CallManagement: An object is already exported for the interface org.shr.phoneui.CallManagement at /org/shr/phoneui/CallManagement
2014.05.20 23:16:40.841200 [phoneuid]   CRITICAL: Failed to register /org/shr/phoneui/Contacts: An object is already exported for the interface org.shr.phoneui.Contacts at /org/shr/phoneui/Contacts
2014.05.20 23:16:40.841224 [phoneuid]   CRITICAL: Failed to register /org/shr/phoneui/Dialer: An object is already exported for the interface org.shr.phoneui.Dialer at /org/shr/phoneui/Dialer
2014.05.20 23:16:40.841252 [phoneuid]   CRITICAL: Failed to register /org/shr/phoneui/IdleScreen: An object is already exported for the interface org.shr.phoneui.IdleScreen at /org/shr/phoneui/IdleScreen
2014.05.20 23:16:40.841276 [phoneuid]   CRITICAL: Failed to register /org/shr/phoneui/Messages: An object is already exported for the interface org.shr.phoneui.Messages at /org/shr/phoneui/Messages
2014.05.20 23:16:40.843448 [phoneuid]   CRITICAL: Failed to register /org/shr/phoneui/Notification: An object is already exported for the interface org.shr.phoneui.Notification at /org/shr/phoneui/Notification
2014.05.20 23:16:40.843500 [phoneuid]   CRITICAL: Failed to register /org/shr/phoneui/PhoneLog: An object is already exported for the interface org.shr.phoneui.PhoneLog at /org/shr/phoneui/PhoneLog
2014.05.20 23:16:40.843554 [phoneuid]   CRITICAL: Failed to register /org/shr/phoneui/Settings: An object is already exported for the interface org.shr.phoneui.Settings at /org/shr/phoneui/Settings
phonefsod.log has no entries for that time.
libevas1-engines-x and libevas1-engine-fb were not installed and after instaling the latter the above problem disappeared.

A second problem seems to be that phoneuid doesn't run stable. About 5 seconds after starting phoneui-quick-settings phoneuid segfaulted:
Code:
write(2, "\n(process:4579): libphone-ui-shr"..., 234
(process:4579): libphone-ui-shr-WARNING **: Failed to retrieve profile list: (2) GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freesmartphone.opreferencesd was not provided by any .service files; retrying later
) = 234
clock_gettime(CLOCK_MONOTONIC, {1647, 25740331}) = 0
clock_gettime(CLOCK_MONOTONIC, {1647, 26503659}) = 0
recvmsg(17, 0x7fff33640550, 0)          = -1 EAGAIN (Resource temporarily unavailable)
recvmsg(17, 0x7fff33640550, 0)          = -1 EAGAIN (Resource temporarily unavailable)
clock_gettime(CLOCK_MONOTONIC, {1647, 28722927}) = 0
select(9, [3 4 8], [], [], {1, 998000}) = 1 (in [4], left {0, 9984})
clock_gettime(CLOCK_MONOTONIC, {1649, 17836445}) = 0
clock_gettime(CLOCK_MONOTONIC, {1649, 18393219}) = 0
recvmsg(17, 0x7fff33640550, 0)          = -1 EAGAIN (Resource temporarily unavailable)
recvmsg(17, 0x7fff33640550, 0)          = -1 EAGAIN (Resource temporarily unavailable)
clock_gettime(CLOCK_MONOTONIC, {1649, 19765307}) = 0
select(9, [3 4 8], [], [], {0, 6000})   = 1 (in [4], left {0, 5982})
read(4, "\1\0\0\0\0\0\0\0", 16)         = 8
clock_gettime(CLOCK_MONOTONIC, {1649, 21164508}) = 0
clock_gettime(CLOCK_MONOTONIC, {1649, 21590473}) = 0
recvmsg(17, 0x7fff33640550, 0)          = -1 EAGAIN (Resource temporarily unavailable)
recvmsg(17, 0x7fff33640550, 0)          = -1 EAGAIN (Resource temporarily unavailable)
clock_gettime(CLOCK_MONOTONIC, {1649, 22879270}) = 0
select(9, [3 4 8], [], [], {0, 3000})   = 0 (Timeout)
read(4, 0x7fff33640280, 16)             = -1 EAGAIN (Resource temporarily unavailable)
clock_gettime(CLOCK_MONOTONIC, {1649, 27182245}) = 0
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
+++ killed by SIGSEGV +++
Speicherzugriffsfehler
From that moment on even after restarting phoneuid I only get timeouts from the phoneui-apps without seeing a GUI.
 

The Following 4 Users Say Thank You to sulu For This Useful Post:
dos1's Avatar
Posts: 256 | Thanked: 2,042 times | Joined on Sep 2010 @ Poznań, Poland
#5
Originally Posted by sulu View Post
libevas1-engines-x and libevas1-engine-fb were not installed and after instaling the latter the above problem disappeared.
I'm not a maintainer of those packages in Debian, but looks like I'll have to work on them somehow, as it seems they don't build with newer elementary anymore and are threatened to be removed from testing suite :/ No idea if previous maintainers are still interested in working on them.

Originally Posted by sulu View Post
A second problem seems to be that phoneuid doesn't run stable. About 5 seconds after starting phoneui-quick-settings phoneuid segfaulted:
That's because you're probably missing fso-frameworkd (Python FSO implementation) and/or proper config to it (and I guess it's the config). SHR apps rely on some daemons (opimd, opreferencesd, and possibly oeventsd) that weren't reimplemented in Vala. And unfortunately, looks like there's no usable default config for frameworkd in Debian packages...

Try to save this file as /etc/frameworkd.conf :
http://git.freesmartphone.org/?p=fra...70e1e3;hb=HEAD

...but libphone-ui-shr segfaulting due to missing opreferencesd is indeed a bug and I can reproduce it here after stopping frameworkd. Thanks!
__________________
Sebastian Krzyszkowiak - http://dosowisko.net/
Long term Openmoko supporter. Owner of two Neo Freerunners and two N900s (without USB).
Future owner of the Neo900

Last edited by dos1; 2014-05-20 at 22:01.
 

The Following 5 Users Say Thank You to dos1 For This Useful Post:
Posts: 686 | Thanked: 1,934 times | Joined on Jan 2011 @ Germany
#6
fso-frameworkd is installed but I had indeed no config.
I saved the file in /etc (and in /etc//om-gta02 as the link suggests) and rebooted the VM.
But according to strace neither the deamon nor the UI applications try to read the config file.

It seems like phoneuid needs quite a while until it accepts connections from the UI applications. If I start one within 30 seconds after starting the deamon I still get the timeout. If I wait two minutes phoneui-quick-settings comes up and I can switch the autodimming slider. However, after another two minutes this window is unresponsive and I get timeouts again when starting new UI applications (for example from the dialer).
I don't see a pattern.
 

The Following 4 Users Say Thank You to sulu For This Useful Post:
dos1's Avatar
Posts: 256 | Thanked: 2,042 times | Joined on Sep 2010 @ Poznań, Poland
#7
Originally Posted by sulu View Post
fso-frameworkd is installed but I had indeed no config.
I saved the file in /etc (and in /etc//om-gta02 as the link suggests) and rebooted the VM.
But according to strace neither the deamon nor the UI applications try to read the config file.

It seems like phoneuid needs quite a while until it accepts connections from the UI applications. If I start one within 30 seconds after starting the deamon I still get the timeout. If I wait two minutes phoneui-quick-settings comes up and I can switch the autodimming slider. However, after another two minutes this window is unresponsive and I get timeouts again when starting new UI applications (for example from the dialer).
I don't see a pattern.
Do you have fsodeviced and fsousaged installed? Are they running?

Autodim and autosuspend sliders use them both, so they might act badly if they're missing.

This software was developed for SHR distro and distro-wise it's easier to ensure that everything needed is in place. Also, libphone-ui-shr isn't the most beautiful piece of code on Earth... I'm planning to rewrite it in some spare time, but there's already a lot of entries on my todo list :c
__________________
Sebastian Krzyszkowiak - http://dosowisko.net/
Long term Openmoko supporter. Owner of two Neo Freerunners and two N900s (without USB).
Future owner of the Neo900
 

The Following 2 Users Say Thank You to dos1 For This Useful Post:
Posts: 686 | Thanked: 1,934 times | Joined on Jan 2011 @ Germany
#8
Originally Posted by dos1 View Post
Do you have fsodeviced and fsousaged installed? Are they running?
I'll check that in the evening.

Originally Posted by dos1 View Post
This software was developed for SHR distro and distro-wise it's easier to ensure that everything needed is in place.
I realize that. I will try to reproduce this in a fresh VM or probably even on real HW if you think that matters. But I won't be able to do that until the weekend.

btw: (of course) I've seen complaints about a missing modem in some of the strace outputs but I don't know how to reproduce them so I can't give you the exact message.
Maybe that's a point to look into because it's an unusual setup for a phoning suite and might need some testing.

Originally Posted by dos1 View Post
Also, libphone-ui-shr isn't the most beautiful piece of code on Earth... I'm planning to rewrite it in some spare time, but there's already a lot of entries on my todo list :c
Don't put too much effort in this right now! I'm just playing at the moment.
 

The Following 2 Users Say Thank You to sulu For This Useful Post:
dos1's Avatar
Posts: 256 | Thanked: 2,042 times | Joined on Sep 2010 @ Poznań, Poland
#9
Originally Posted by sulu View Post
Don't put too much effort in this right now! I'm just playing at the moment.
I'm using this code on my phone every day, and some code mainternance is long overdue

BTW. You can try to use ofono-phonesim to simulate the modem.

Feel free to ask in case of problems. You can easily catch me on IRC
__________________
Sebastian Krzyszkowiak - http://dosowisko.net/
Long term Openmoko supporter. Owner of two Neo Freerunners and two N900s (without USB).
Future owner of the Neo900
 

The Following 2 Users Say Thank You to dos1 For This Useful Post:
Posts: 686 | Thanked: 1,934 times | Joined on Jan 2011 @ Germany
#10
Originally Posted by dos1 View Post
Do you have fsodeviced and fsousaged installed? Are they running?
Both were installed and running when I booted the VM yesterday evening.
The SHR lock screen came up automatically after some idle time and I could deactivate it via the autodim slider. So apparently this part is working.
But it took about 2-3 minutes after the boot again until the daemon seemed to be able to answer to any client programs. And it seems if you forcefully kill some client the daemon becomes unresponsive again.

Originally Posted by dos1 View Post
This software was developed for SHR distro and distro-wise it's easier to ensure that everything needed is in place.
I'm not sure I understand what you want to say here.

Originally Posted by dos1 View Post
I'm using this code on my phone every day, and some code mainternance is long overdue
Just a long-term wishlist item:
Depending on how extensively you'll rework the code, I'd love to see some simple CLI interfaces like these:
Code:
phonecli-dialer -call »phone number«
phonecli-messages -send »phone number« < »some text file«
phonecli-contacts -getnumber »some name«
The GUI could then just be an interface for these CLI tools.

Originally Posted by dos1 View Post
BTW. You can try to use ofono-phonesim to simulate the modem.
Thanks! I'll try that.

Originally Posted by dos1 View Post
Feel free to ask in case of problems. You can easily catch me on IRC
Thanks for the offer, but I have an aversion against chats.
 

The Following 2 Users Say Thank You to sulu For This Useful Post:
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 16:08.