Notices


Reply
Thread Tools
Posts: 220 | Thanked: 761 times | Joined on Jul 2014
#221
Originally Posted by mautz View Post
@nh1402

I know about this kernel, but a phone without a battery isn't a good daily driver
Maybe you could fix it
 

The Following 2 Users Say Thank You to nh1402 For This Useful Post:
Posts: 368 | Thanked: 1,003 times | Joined on Feb 2014 @ Germany
#222
Originally Posted by nh1402 View Post
Maybe you could fix it
Maybe i'll give it a try, just looking through the commits of 3.10 for bacon...seems like a lot of work
 

The Following 2 Users Say Thank You to mautz For This Useful Post:
Posts: 212 | Thanked: 262 times | Joined on May 2015 @ Italy
#223
Sorry guys for the stupid question, but what would be the advantages of a newer kernel compared to the improved versions provided by @mautz?
 

The Following User Says Thank You to claustn For This Useful Post:
Posts: 79 | Thanked: 189 times | Joined on Mar 2016
#224
Wakelocks, for example. And other stuff mentioned here: https://kernelnewbies.org/LinuxVersions
 

The Following 2 Users Say Thank You to Veraendert For This Useful Post:
Posts: 220 | Thanked: 761 times | Joined on Jul 2014
#225
Originally Posted by claustn View Post
Sorry guys for the stupid question, but what would be the advantages of a newer kernel compared to the improved versions provided by @mautz?
It should be easier to get anbox working on it.
 

The Following 4 Users Say Thank You to nh1402 For This Useful Post:
Posts: 107 | Thanked: 177 times | Joined on Feb 2017 @ Tbilisi, Georgia (caucasus)
#226
i get a hell of a battery drain. the phone does.not sleep at all. i check it with mce-tool. now i installed systemdatascope and am collecting data.

4g does not work for me. when i turn it to 3g it works great.
bluetooth does not work i don't need it so no worries i just disabled it.
when i restat the device it turns on 4g connection also it restores defaults for apn. is there a fix for these issues?

oh also when i restart the device it changes it's mac address. although it's nice for security it's a pain in the *** for me. i have some restrictions on my router based on mac address and everytime i restart the device i have to change firewall settings on my router too. it would be cool if sailfish had a setting for this behaviour.
 

The Following User Says Thank You to matemana For This Useful Post:
Posts: 368 | Thanked: 1,003 times | Joined on Feb 2014 @ Germany
#227
@matemana

Have you tried reinstalling SFOS and CM? Only a few people experienced the MAC address problem. For the APN problem there is a solution under the Known Issues section in the first post. How did you disable Bluetooth?
 

The Following User Says Thank You to mautz For This Useful Post:
Posts: 107 | Thanked: 177 times | Joined on Feb 2017 @ Tbilisi, Georgia (caucasus)
#228
Originally Posted by mautz View Post
@matemana

Have you tried reinstalling SFOS and CM? Only a few people experienced the MAC address problem. For the APN problem there is a solution under the Known Issues section in the first post. How did you disable Bluetooth?
I'll try reinstall. I had 2 nexus 4 one of which always had the same issue with mac changing on every reboot. I was not able to fix it.
When it changes mac address it always asks for my WiFi password and it adds second time my wifi, then third time and so on. I think this issues are related to each other. Becaus my second nexus 4 did not change mac address and did not ask wifi password on every reboot.

I disabled bluetooth with these commands.

systemctl stop bluetooth.service
systemctl stop hciattach.service
systemctl mask bluetooth.service
systemctl mask hciattach.service

mcetool gives
uptime: 14713.785
suspend_time: 0.000

i am not sure how to use systemdatascope to find out which process is preventing device from sleep. could you help me with that?
 

The Following User Says Thank You to matemana For This Useful Post:
Posts: 313 | Thanked: 1,373 times | Joined on Aug 2016 @ Estonia
#229
Originally Posted by matemana View Post
I'll try reinstall. I had 2 nexus 4 one of which always had the same issue with mac changing on every reboot. I was not able to fix it.
When it changes mac address it always asks for my WiFi password and it adds second time my wifi, then third time and so on. I think this issues are related to each other. Becaus my second nexus 4 did not change mac address and did not ask wifi password on every reboot.

I disabled bluetooth with these commands.

systemctl stop bluetooth.service
systemctl stop hciattach.service
systemctl mask bluetooth.service
systemctl mask hciattach.service

mcetool gives
uptime: 14713.785
suspend_time: 0.000

i am not sure how to use systemdatascope to find out which process is preventing device from sleep. could you help me with that?
SystemDataScope doesn't allow you to find which process is blocking the sleep. I haven't written such functionality for collectd => no stats to show. Its probably possible, but would require significant effort to do it.

You would have to follow wakelocks and see which wakelock(s) persist. In N4, wakelocks are described in /proc/wakelocks . On newer devices, it was somewhere else.

Its a while when I have been looking into it, so I can give you general pointers with you filling in the blanks. I would suggest to start searching wakelocks and android, ignore most of xda stating that this wakelock was bad, and just finding out which it is in your case. If its MCE (or similar), it comes from SFOS with some of the programs preventing sleep and not releasing the handle.

Good luck!
 

The Following 2 Users Say Thank You to rinigus For This Useful Post:
Posts: 107 | Thanked: 177 times | Joined on Feb 2017 @ Tbilisi, Georgia (caucasus)
#230
Originally Posted by rinigus View Post
Good luck!
Thanks for the tips! I will try reinstalling SFOS and then if i will have the same problem with battery drain i will inspect wakelocks

Is this bad right?

what does it mean in your app? 0% is bad or good in sleep graph?


Last edited by matemana; 2017-11-15 at 11:23.
 

The Following 2 Users Say Thank You to matemana For This Useful Post:
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 23:18.