Active Topics

 



Notices


Reply
Thread Tools
Posts: 25 | Thanked: 2 times | Joined on Dec 2007
#1
We use a PPTP VPN to our router at the office. Is there software to do this on the N800, preferably using OS2008?
 

The Following User Says Thank You to CarSalesman For This Useful Post:
technut's Avatar
Posts: 574 | Thanked: 166 times | Joined on Oct 2007 @ BC, Canada
#2
Fanoush (one of the regulars here) has some info about PPTP here:
http://fanoush.wz.cz/maemo/#pptp
__________________
Please follow these simple posting guidelines.
There are no stupid questions, just people who didn't search itT (with Google) first.
 
linuxrebel's Avatar
Posts: 182 | Thanked: 46 times | Joined on Jan 2007 @ Silly-Con Valley
#3
Myself, I've beeen waiting ffoor the chaos to end, but yes go to http://maemo.lancode.de and he has the needed pptp client software. Now what I don't yet know is if the OS2008 kernel includes mppe (micrsoft point to point encription[?]) built in. If so you can config things and run, if not you'll have to wait for a 3rd party kernel.
 
Posts: 161 | Thanked: 99 times | Joined on Jan 2008
#4
Hi,

I have flashed fanoush's 2.2007.50-2 kernel with MPPE support an I'm currently trying to load the corresponding modules - though with limited success so far.

According to Fanoush's description the modules arc4, sha1 and ppp_mppe need to be loaded, which doesn't work due to unresolved dependencies.
http://fanoush.wz.cz/maemo/#pptp

Via dmesg output I was able to figure out, that first the crypto_algapi module has to be loaded before arc4 and sha1 can be loaded. But I still don't know, what the prerequisites for ppp_mppe are.

insmod ppp_mppe just gives a

Code:
insmod: cannot insert '../drivers/net/ppp_mppe.ko': No such device (-1): No such device
No further hint in dmesg what exactly is missing. To bad modprobe/depmod is broken on the N800.

Currently I have the following modules loaded

Code:
sha1 2400 0 - Live 0xbf05e000
arc4 1760 0 - Live 0xbf05c000
crypto_algapi 10176 2 sha1,arc4, Live 0xbf058000
g_file_storage 27560 0 - Live 0xbf050000
cx3110x 56200 0 - Live 0xbf041000
umac 258788 1 cx3110x, Live 0xbf000000 (P)
Any idea which module I have to load first before I can load ppp_mppe?

Solved
I found a working lsmode sequence:

crypto_algapi
arc4
sha1
cryptomgr
blkcipher
cbc
pcbc
ecb
ppp_mpp3

Last edited by iskarion; 2008-01-06 at 20:26.
 

The Following 2 Users Say Thank You to iskarion For This Useful Post:
Posts: 2,152 | Thanked: 1,490 times | Joined on Jan 2006 @ Czech Republic
#5
I have not tried in OS2008 yet, just enabled it in kernel. Thanks for figuring out the module list. Will add it to missing OS2008 section for others. Did you manage to connect?
__________________
Newbies click here before posting. Thanks.

If you really need to PM me with troubleshooting question please consider posting it to the forum instead. It is OK to PM me a link to such post then. Thank you.

Last edited by fanoush; 2008-01-06 at 21:17.
 
Posts: 161 | Thanked: 99 times | Joined on Jan 2008
#6
Originally Posted by fanoush View Post
Did you manage to connect?
Yes. Didn't do extensive tests so far and also routing is not yet setup, but connecting to a PPTP server with 128-bit MPPE encryption and MS-CHAPv2 authentication seems to work fine.

Just disconnecting via poff is not working.
 
linuxrebel's Avatar
Posts: 182 | Thanked: 46 times | Joined on Jan 2007 @ Silly-Con Valley
#7
Ok,

I know why poff doesn't work. On line 40 of /usr/bin/poff, the word getopts is a bash not ash command. go here. and get a bash install that works around the busybox conflict and then you can change the #!/bin/sh at the start of poff and pon to #!/bin/bash.

Last edited by linuxrebel; 2008-01-10 at 12:26.
 
Posts: 79 | Thanked: 21 times | Joined on Sep 2007
#8
Hi!

I think, these are not strictly necessary:

Originally Posted by iskarion View Post
cbc
pcbc
At least it works for me without them.

Tilman
 
Posts: 79 | Thanked: 21 times | Joined on Sep 2007
#9
BTW, I had problems with DNS and PPTP on OS 2007 (HE) and found the solution:

/etc/ppp/ip-up.local was called with the umask set such that /tmp/resolv.conf.ppp0 was created with 0600 permissions. dnsmasq running as "nobody" couldn't read it and stopped answering DNS queries.

Solution: Insert
Code:
chmod 644 $RESOLV_CONF
before the end of the first "if" block in /etc/ppp/ip-up.local

This problem is fixed in OS 2008 btw.

Maybe this is useful for some people...
 

The Following User Says Thank You to tvogel For This Useful Post:
Posts: 2 | Thanked: 0 times | Joined on Feb 2008
#10
What do I do if i can't even insmod crypto_algapi.ko? I'm screwed aren't I...

I'm using OS2008 2.2007.51-3 and I get the error message:

insmod: cannot insert 'crypto_algapi.ko': Unknown symbol in module (-1): No such file or directory

I'll keep messing around with it, but I'm not incredibly optimistic. Just thought this should be documented haha.

-alien

EDIT: Nevermind, I'm an idiot.

Last edited by kidalien745; 2008-03-11 at 22:27.
 
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 23:29.