Thread Tools
Posts: 1,534 | Thanked: 3,203 times | Joined on Mar 2010 @ North Potomac MD
After doing devel-su I find when trying version --dup, I get the following error

Error: File '/repodata/repomd.xml' not found on medium ''

Anyone know what this is about?

The Following 2 Users Say Thank You to mscion For This Useful Post:
Posts: 527 | Thanked: 480 times | Joined on May 2010 @ nanaurbusiness
I had issues while updating, too.
It turned out I had two adaption repos enabled (adaption0 and adaption1) on my Jolla 1 pointing to the same url and failed updating with
"Error: cannot install both pattern:jolla-configuration-sbj-0.10.0-10.61.4.jolla.noarch and pattern:jolla-configuration-sbj-0.10.0-10.61.4.jolla.noarch"
A quick message to zendesk gave the solution.
Remove the duplicate adaption1 repo.

This is what you should have on a clean Jolla1.

[root@Sailfish nemo]# ssu s
sDevice registration status: not registered
Device model: Jolla (SbJ / JP-1301)
Device UID: xxxxxxxxxxxxxxxx
Domain: sales

[root@Sailfish nemo]# ssu lr
Enabled repositories (global): 
 - adaptation0    ...
 - aliendalvik    ...
 - apps           ...
 - customer-jolla ...
 - eas            ...
 - hotfixes       ...
 - jolla          ...
 - xt9            ...

Enabled repositories (user): 
 - store ...

Disabled repositories (global, might be overridden by user config): 

Disabled repositories (user): 
 - home ...
[root@Sailfish nemo]#
So, disable all other repos and it should update fine.
In my case:

ssu dr adaptation1
ssu rr adaptation1
ssu ur
pkcon refresh


ssu re
version --dup

N900 ~ $ make me a sandwich
-bash: no, make it yourself
N900 ~ $ sudo make me a sandwich
-bash: ok then...

The Following 7 Users Say Thank You to J4ZZ For This Useful Post:

Thread Tools

Forum Jump

All times are GMT. The time now is 10:42.